]> git.pld-linux.org Git - packages/gd.git/commitdiff
- fontpath patch - set default FONTPATH to PLD-compatible gd-2_0_1-6
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 10 Aug 2002 16:39:34 +0000 (16:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added patch with GIF support (conditional, default on)
- cleanups in descriptions
- release 6

Changed files:
    gd-fontpath.patch -> 1.1
    gd-gif-acam.patch -> 1.1
    gd.spec -> 1.71

gd-fontpath.patch [new file with mode: 0644]
gd-gif-acam.patch [new file with mode: 0644]
gd.spec

diff --git a/gd-fontpath.patch b/gd-fontpath.patch
new file mode 100644 (file)
index 0000000..43b0836
--- /dev/null
@@ -0,0 +1,11 @@
+--- gd-2.0.1/gd.h.orig Sat Aug 10 17:22:09 2002
++++ gd-2.0.1/gd.h      Sat Aug 10 18:08:33 2002
+@@ -6,7 +6,7 @@
+ #endif
+ /* default fontpath for unix systems */
+-#define DEFAULT_FONTPATH "/usr/share/fonts/truetype"
++#define DEFAULT_FONTPATH "/usr/share/fonts/TTF:/usr/share/fonts/Type1"
+ #define PATHSEPARATOR ":"
+ /* gd.h: declarations file for the graphic-draw module.
diff --git a/gd-gif-acam.patch b/gd-gif-acam.patch
new file mode 100644 (file)
index 0000000..6875ecc
--- /dev/null
@@ -0,0 +1,64 @@
+diff -Nur gd-2.0.1.orig/Makefile.am gd-2.0.1/Makefile.am
+--- gd-2.0.1.orig/Makefile.am  Sat Aug 10 17:03:27 2002
++++ gd-2.0.1/Makefile.am       Sat Aug 10 17:13:28 2002
+@@ -31,6 +31,10 @@
+       gd_wbmp.c \
+       gdhelpers.c \
+       gd_topal.c \
++      gd_gif_in.c \
++      gd_gif_out.c \
++      gd_biggif_out.c \
++      gd_lzw_out.c \
+       gd.h \
+       gdfontt.h \
+       gdfonts.h \
+@@ -51,7 +55,7 @@
+ libgd_la_LDFLAGS = -version-info 2:0:0
+-bin_PROGRAMS = pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng
++bin_PROGRAMS = pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng gd2togif gdcmpgif giftogd2
+ noinst_PROGRAMS = gdtest gddemo gd2time gdtestft testac
+@@ -91,6 +95,15 @@
+ webpng_SOURCES = webpng.c gd.h
+ webpng_LDADD = libgd.la
++gd2togif_SOURCES = gd2togif.c gd.h
++gd2togif_LDADD = libgd.la
++
++gdcmpgif_SOURCES = gdcmpgif.c gd.h
++gdcmpgif_LDADD = libgd.la
++
++giftogd2_SOURCES = giftogd2.c gd.h
++giftogd2_LDADD = libgd.la
++
+ EXTRA_DIST = demoin.png index.html test/*
+ CLEANFILES = demoout.png
+diff -Nur gd-2.0.1.orig/gd_gif_out.c gd-2.0.1/gd_gif_out.c
+--- gd-2.0.1.orig/gd_gif_out.c Sat Aug 10 17:03:27 2002
++++ gd-2.0.1/gd_gif_out.c      Sat Aug 10 17:12:39 2002
+@@ -8,8 +8,6 @@
+ ** Wrapper functions for GIF output.
+ */
+-#define LZW_LICENCED
+-
+ void gdImageGifToSink(gdImagePtr im, gdSinkPtr outSink)
+ {
+         gdIOCtx   *out = gdNewSSCtx(NULL,outSink);
+diff -Nur gd-2.0.1.orig/gd_lzw_out.c gd-2.0.1/gd_lzw_out.c
+--- gd-2.0.1.orig/gd_lzw_out.c Sat Aug 10 17:03:27 2002
++++ gd-2.0.1/gd_lzw_out.c      Sat Aug 10 17:12:39 2002
+@@ -1,3 +1,4 @@
++#ifdef LZW_LICENCED
+ #include <malloc.h>
+ #include <stdio.h>
+ #include <math.h>
+@@ -794,3 +795,4 @@
+ /* |   notice appear in supporting documentation.  This software is    | */
+ /* |   provided "as is" without express or implied warranty.           | */
+ /* +-------------------------------------------------------------------+ */
++#endif
diff --git a/gd.spec b/gd.spec
index a4cd4d85f2232bee5eaf88cad09ce2684f3edd35..2c5f14978e97ad3847c50a30a4b66e6f505a583a 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -1,14 +1,21 @@
+#
+# _without_gif - without GIF support (patch from http://www.rhyme.com.au/gd/)
+# _without_lzw - without LZW compression in GIF creation functions
+#
 Summary:       Library for PNG, JPEG creation
 Summary(es):   Biblioteca para manipulación de imágenes
 Summary(pl):   Biblioteka do tworzenia grafiki w formacie PNG, JPEG
 Summary(pt_BR):        Biblioteca para manipulação de imagens
 Name:          gd
 Version:       2.0.1
-Release:       5
+Release:       6
 License:       BSD-like
 Group:         Libraries
 Source0:       http://www.boutell.com/ftp-materials/boutell/gd/%{name}-%{version}.tar.gz
 Patch0:                %{name}-ac_am.patch
+Patch1:                http://downloads.rhyme.com.au/gd/patch_%{name}%{version}_gif_20011107.gz
+Patch2:                %{name}-gif-acam.patch
+Patch3:                %{name}-fontpath.patch
 URL:           http://www.boutell.com/gd/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -19,20 +26,21 @@ BuildRequires:      libtiff-devel
 BuildRequires: libtool
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+%{!?_without_gif:Provides:     gd(gif) = %{version}}
 
 %define                shlibver        %(echo %{version} | cut -f-2 -d.)
 
 %description
-gd library creates PNG, JPEG and WBMP images, not GIF images. This is
-a good thing. PNG is a more compact format, and full compression is
-available. JPEG works well with photographic images, and is still more
-compatible with the major Web browsers than even PNG is. WBMP is
-intended for wireless devices (not regular web browsers). Existing
-code will need modification to call or gdImageJpeg instead of
-gdImageGif.
-
-This library allows you to easily create and manipulate PNG, JPEG
-image files from your C programs.
+gd is the image manipulating library. It was created to allow graphs,
+charts and the like to be generated on the fly for use on the World
+wide Web, but is useful for any application in which custom images are
+useful. It is not a paint program; it is a library. gd library creates
+PNG, JPEG and WBMP images. This is a good thing. PNG is a more compact
+format, and full compression is available. JPEG works well with
+photographic images, and is still more compatible with the major Web
+browsers than even PNG is. WBMP is intended for wireless devices (not
+regular web browsers).
+%{!?_without_gif:This version has additional GIF images support.}
 
 %description -l es
 Esta es la biblioteca gd para el manejo de imágenes. Fue creada para
@@ -41,8 +49,16 @@ cualquier programa que necesite de im
 programa de dibujo; es una biblioteca.
 
 %description -l pl
-Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
-graficznymi w formacie PNG, JPEG i WBMP, ale nie GIF.
+gd to biblioteka do obróbki obrazów. Zosta³a stworzona, aby umo¿liwiæ
+dynamiczne generowanie wykresów i podobnych rzeczy na potrzeby WWW,
+ale mo¿e byæ przydatna tak¿e dla ka¿dej aplikacji tworz±cej w³asne
+obrazy. Biblioteka ta pozwala na tworzenie plików graficznych w
+formatach PNG, JPEG i WBMP. PNG jest zwartym formatem z bezstratn±
+kompresj±. JPEG dobrze nadaje siê do obrazów fotograficznych i jest
+obs³ugiwany nawet przez wiêcej przegl±darek WWW ni¿ PNG. WBMP jest
+przeznaczony dla urz±dzeñ bezprzewodowych (a nie zwyk³ych przegl±darek
+WWW).
+%{!?_without_gif:Ta wersja ma dodatkowo obs³ugê formatu GIF.}
 
 %description -l pt_BR
 Esta é a biblioteca gd para manipulação de imagens. Ela foi criada
@@ -56,11 +72,12 @@ Summary(es):        Archivos de inclusi
 Summary(pl):   Czê¶æ biblioteki GD przeznaczona dla developerów
 Summary(pt_BR):        Arquivos de inclusão e bibliotecas para desenvolver programas usando gd
 Group:         Development/Libraries
+Requires:      %{name} = %{version}
+Requires:      freetype-devel >= 2.0
+Requires:      libjpeg-devel
 Requires:      libpng-devel
 Requires:      zlib-devel
-Requires:      libjpeg-devel
-Requires:      freetype-devel >= 2.0
-Requires:      %{name} = %{version}
+%{!?_without_gif:Provides:     gd-devel(gif) = %{version}}
 
 %description devel
 This package contains the files needed for development of programs
@@ -80,23 +97,17 @@ necess
 
 %package static
 Summary:       Static GD library
-Summary(es):   Static libraries for libgd development
 Summary(pl):   Statyczna biblioteka GD
 Summary(pt_BR):        Bibliotecas estáticas para desenvolvimento com libgd
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}
+%{!?_without_gif:Provides:     gd-static(gif) = %{version}}
 
 %description static
-This package contains static GD library. This is the gd image
-manipulating library. It was created to allow graphs, charts and the
-like to be generated on the fly for use on the World wide Web, but is
-useful for any application in which custom images are useful. It is
-not a paint program; it is a library.
-
-This package contains static libraries for libgd development.
+This package contains static gd library.
 
 %description static -l pl
-Pakiet ten zawiera statyczn± bibliotekê GD.
+Ten pakiet zawiera statyczn± bibliotekê gd.
 
 %description static -l pt_BR
 Este pacote contem bibliotecas estáticas para desenvolvimento com
@@ -105,19 +116,21 @@ libgd.
 %package progs
 Summary:       Utility programs that use libgd
 Summary(es):   Programas utilitarios libgd
-Summary(pl):   Narzêdzia które u¿ywaj± libgd
+Summary(pl):   Narzêdzia u¿ywaj±ce libgd
 Summary(pt_BR):        Programas utilitários libgd
 Group:         Applications/Graphics
 Requires:      %{name} = %{version}
+%{!?_without_gif:Provides:     gd-progs(gif) = %{version}}
 
 %description progs
-These are utility programs supplied with gd, the .jpeg graphics
+These are utility programs supplied with gd, the image manipulation
 library. The libgd-progs package contains a group of scripts for
 manipulating the graphics files in formats which are supported by the
 libgd library.
 
 %description progs -l pl
-Pakiet ten zawiera dodatkowe programy uzywaj±ce libgd.
+Ten pakiet zawiera programy u¿ywaj±ce biblioteki gd, s³u¿±ce do
+obróbki plików graficznych w formatach obs³ugiwanych przez libgd.
 
 %description progs -l pt_BR
 Este pacote inclui vários utilitários para manipulação de arquivos gd
@@ -126,12 +139,16 @@ para uso pelos programas que usam a libgd.
 %prep
 %setup -q
 %patch0 -p1
+%{!?_without_gif:%patch1 -p1}
+%{!?_without_gif:%patch2 -p1}
+%patch3 -p1
 
 %build
 %{__libtoolize}
 aclocal
 %{__automake}
 %{__autoconf}
+%{!?_without_lzw:CPPFLAGS="-DLZW_LICENCED"}
 %configure
 %{__make}
 
This page took 0.110373 seconds and 4 git commands to generate.