]> git.pld-linux.org Git - packages/gd.git/blob - gd.spec
- release 7,
[packages/gd.git] / gd.spec
1 Summary:        Library for PNG, JPEG creation
2 Summary(pl):    Biblioteka do tworzenia grafiki w formacie PNG, JPEG
3 Name:           gd
4 Version:        1.8.3
5 Release:        7
6 License:        BSD-style
7 Group:          Libraries
8 Group(de):      Libraries
9 Group(fr):      Librairies
10 Group(pl):      Biblioteki
11 Source0:        ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
12 Patch0:         %{name}-ac_am.patch
13 URL:            http://www.boutell.com/gd/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  zlib-devel
18 BuildRequires:  libpng-devel
19 BuildRequires:  freetype-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define shlibver %(echo %{version} | cut -f-2 -d.)
23
24 %description
25 gd library creates PNG, JPEG and WBMP images, not GIF images. This is
26 a good thing. PNG is a more compact format, and full compression is
27 available. JPEG works well with photographic images, and is still more
28 compatible with the major Web browsers than even PNG is. WBMP is
29 intended for wireless devices (not regular web browsers). Existing
30 code will need modification to call or gdImageJpeg instead of
31 gdImageGif.
32
33 This library allows you to easily create and manipulate PNG, JPEG
34 image files from your C programs.
35
36 %description -l pl
37 Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
38 graficznymi w formacie PNG.
39
40 %package devel
41 Summary:        Development part of the GD library
42 Summary(pl):    Czê¶æ biblioteki GD przeznaczona dla developerów
43 Group:          Development/Libraries
44 Group(de):      Entwicklung/Libraries
45 Group(fr):      Development/Librairies
46 Group(pl):      Programowanie/Biblioteki
47 Requires:       libpng-devel
48 Requires:       zlib-devel
49 Requires:       %{name} = %{version}
50
51 %description devel
52 This package contains the files needed for development of programs
53 linked against GD.
54
55 %description -l pl devel
56 Pakiet ten zawiera pliki potrzebne do rozwoju programów korzystaj±cych
57 z biblioteki GD.
58
59 %package static
60 Summary:        Static GD library
61 Summary(pl):    Statyczna biblioteka GD
62 Group:          Development/Libraries
63 Group(de):      Entwicklung/Libraries
64 Group(fr):      Development/Librairies
65 Group(pl):      Programowanie/Biblioteki
66 Requires:       %{name} = %{version}
67
68 %description devel
69 This package contains static GD library.
70
71 %description -l pl static
72 Pakiet ten zawiera statyczn± bibliotekê GD.
73
74 %prep
75 %setup -q 
76 %patch0 -p1 
77
78 %build
79 libtoolize --copy --force
80 automake -a -c
81 aclocal
82 autoconf
83 %configure
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 gzip -9nf readme.txt index.html 
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc readme.txt.gz
103 %attr(755,root,root) %{_bindir}/*
104 %attr(755,root,root) %{_libdir}/*.so.*.*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc index.html.gz 
109 %attr(755,root,root) %{_libdir}/*.so
110 %attr(755,root,root) %{_libdir}/*.la
111 %{_includedir}/*
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/lib*.a
This page took 0.036549 seconds and 4 git commands to generate.