]> git.pld-linux.org Git - packages/gd.git/blob - gd.spec
- v.1.8.3
[packages/gd.git] / gd.spec
1 Summary:        Library for PNG, JPEG creation
2 Summary(pl):    Biblioteka do tworzenia grafiki w formacie PNG, JPEG
3 Name:           gd
4 Version:        1.8.3
5 Release:        1
6 License:        BSD-style
7 Group:          Libraries
8 Group(fr):      Librairies
9 Group(pl):      Biblioteki
10 Source0:        ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
11 Patch0:         gd-pld-patch
12 URL:            http://www.boutell.com/gd/
13 BuildRequires:  zlib-devel
14 BuildRequires:  libpng-devel
15 BuildRequires:  freetype-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 gd library creates PNG, JPEG and WBMP images, not GIF images. This is a
20 good thing. PNG is a more compact format, and full compression is available.
21 JPEG works well with photographic images, and is still more compatible with
22 the major Web browsers than even PNG is. WBMP is intended for wireless
23 devices (not regular web browsers). Existing code will need modification to
24 call or gdImageJpeg instead of gdImageGif.
25
26 This library allows you to easily create and manipulate PNG, JPEG image
27 files from your C programs.
28
29 %description -l pl
30 Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
31 graficznymi w formacie PNG.
32
33 %package devel
34 Summary:        Development part of the GD library
35 Summary(pl):    Czê¶æ biblioteki GD przeznaczona dla developerów
36 Group:          Development/Libraries
37 Group(fr):      Development/Librairies
38 Group(pl):      Programowanie/Biblioteki
39 Requires:       %{name} = %{version}
40
41 %description devel
42 This package contains the files needed for development of programs
43 linked against GD.
44
45 %description -l pl devel
46 Pakiet ten zawiera pliki potrzebne do rozwoju programów korzystaj±cych
47 z biblioteki GD.
48
49 %package static
50 Summary:        Static GD library
51 Summary(pl):    Statyczna biblioteka GD
52 Group:          Development/Libraries
53 Group(fr):      Development/Librairies
54 Group(pl):      Programowanie/Biblioteki
55 Requires:       %{name} = %{version}
56
57 %description devel
58 This package contains static GD library.
59
60 %description -l pl static
61 Pakiet ten zawiera statyczn± bibliotekê GD.
62
63 %prep
64 %setup -q 
65 %patch0 -p1 
66
67 %build
68 CFLAGS="$RPM_OPT_FLAGS -I/usr/include/freetype"
69 LDFLAGS="-s"
70 export CFLAGS LDFLAGS
71 gcc -shared -o libgd.so.%{version} -Wl,-soname=libgd.so.%{shlibver} \
72         `ar t libgd.a` -L/usr/X11R6/lib -lttf -ljpeg -lpng -lz -lm
73
74
75 %install
76
77
78 [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
79 mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
80 make install \
81         INSTALL_BIN=$RPM_BUILD_ROOT%{_bindir} \
82         INSTALL_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
83         INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
84
85 install libgd.so.%{version} $RPM_BUILD_ROOT%{_libdir}/
86 ln -s libgd.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgd.so
87
88 #make DESTDIR="$RPM_BUILD_ROOT" install
89
90 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
91
92 gzip -9nf readme.txt index.html 
93
94 %clean
95 rm -fr $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc readme.txt.gz
103 %attr(755,root,root) %{_bindir}/*
104 %attr(755,root,root) %{_libdir}/*.so.*.*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc index.html.gz 
109 %attr(755,root,root) %{_libdir}/*.so
110 %{_includedir}/*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/lib*.a
This page took 0.090356 seconds and 3 git commands to generate.