]> git.pld-linux.org Git - packages/gcstar.git/blob - gcstar.spec
more verbose files
[packages/gcstar.git] / gcstar.spec
1 # NOTES:- warnings like this: /usr/lib/rpm/perl.prov: weird, cannot determine the package name for
2 #        `/mnt/hda5/tmp/gcstar-0.5.0-root-inter/usr/lib/gcstar/GCLang/BG/GCstar.pm'
3 #       - mark with lang() _datadir/lib/GCLang/*
4 #
5 # /usr/lib/rpm/perl.prov: weird, cannot determine the package name for `/root/tmp/gcstar-1.4.2-root-root/usr/share/gcstar/lib/GCLang/SV/GCstar.pm'
6 # and similar
7 # TODO: - fix this message, IMHO the first byte of utf8 is the source of error - see with 'less' (uzsolt)
8 #       - after the done of the first todo, clear the 'Provides' fields
9 #       - maybe create subpackage
10 #       - fix permssions of /usr/share/gcstar/helpers/xdg-open (or use system xdg-open)
11 #
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        GCstar: collection manager
14 Summary(hu.UTF-8):      GCstar: gyűjtemény kezelő
15 Summary(pl.UTF-8):      GCstar: zarządca kolekcji
16 Name:           gcstar
17 Version:        1.7.0
18 Release:        0.1
19 License:        GPL
20 Group:          X11/Applications
21 Source0:        http://download.gna.org/gcstar/%{name}-%{version}.tar.gz
22 # Source0-md5:  94d0c4d6acc912b4b4d3a72d934cc16d
23 Patch0:         %{name}-mandir.patch
24 Patch1:         %{name}-desktop.patch
25 # copy gcstar perl-libs to /usr/share instead of /usr/lib
26 Patch2:         %{name}-perlmoddir.patch
27 URL:            http://www.gcstar.org/
28 BuildRequires:  perl-Archive-Zip
29 BuildRequires:  perl-Gtk2
30 BuildRequires:  perl-HTML-Parser
31 BuildRequires:  perl-Sort-Naturally
32 BuildRequires:  perl-XML-LibXML
33 BuildRequires:  perl-XML-Simple
34 BuildRequires:  perl-libwww
35 BuildRequires:  rpm-perlprov
36 Requires(post,postun):  desktop-file-utils
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # parts of Gtk2.pm package
41 %define gtk2_subpkgs    Dialog\\\\|MenuBar\\\\|MessageDialog\\\\|ScrolledWindow\\\\|Toolbar\\\\|TreeView\\\\|VBox\\\\|Window
42
43 # don't require/provide itself, it isn't in standard search path
44 %define _noautoprov     ^perl(GC.*)$
45 %define _noautoreq      ^perl(GC.*)$ ^perl(Gtk2::\\\\(%{gtk2_subpkgs}\\\\))$
46
47 %description
48 GCstar is an application to manage different kind of collections. It
49 is designed to be able to support as many type of collections as
50 needed. For the moment it supports these ones:
51  - Movies
52  - Video games
53  - Books
54  - User defined collections
55
56 %description -l hu.UTF-8
57 GCstar egy alkalmazás, amellyel gyűjtemények különféle fajtáit
58 tarthatjuk nyilván. Annyi típusú gyűjteményt tud kezelni, amennyire
59 csak szükségünk lehet. Jelenleg a következőket:
60  - filmek
61  - videójátékok
62  - könyvek
63  - felhasználó által definiált gyűjtemények
64
65 %description -l pl.UTF-8
66 GCstar jest aplikacją do zarządzania różnymi rodzajami kolekcji. Jest
67 zaprojektowana by móc wspierać wszystkie potrzebne typy kolekcji.
68 Aktualnie wspiera kolekcje:
69  - filmów
70  - gier wideo
71  - książek
72  - kolekcje zdefiniowane przez użytkownika
73
74 %prep
75 %setup -q -n %{name}
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79
80 #rm BOM from files - it can confuse perl.prov
81 find -type f -name '*.pm' | xargs sed -i 's/^\xef\xbb\xbf//'
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 ./install --text \
87         --prefix=$RPM_BUILD_ROOT%{_prefix}
88
89 install -d $RPM_BUILD_ROOT%{_desktopdir}
90 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
91 install share/applications/gcstar.desktop $RPM_BUILD_ROOT%{_desktopdir}
92 install share/gcstar/icons/gcstar_64x64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 %update_desktop_database_post
99 %update_icon_cache hicolor
100 %update_mime_database
101
102 %postun
103 %update_desktop_database_postun
104 %update_icon_cache hicolor
105 %update_mime_database
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README
110 %attr(755,root,root) %{_bindir}/gcstar
111 %dir %{_datadir}/%{name}
112 %{_datadir}/%{name}/fonts
113 %{_datadir}/%{name}/genres
114 %{_datadir}/%{name}/helpers
115 %{_datadir}/%{name}/html_models
116 %{_datadir}/%{name}/icons
117 %{_datadir}/%{name}/lib
118 %{_datadir}/%{name}/list_bg
119 %{_datadir}/%{name}/logos
120 %{_datadir}/%{name}/overlays
121 %{_datadir}/%{name}/panels
122 %{_datadir}/%{name}/schemas
123 %{_datadir}/%{name}/style
124 %{_datadir}/%{name}/xml_models
125 %{_datadir}/%{name}/xslt
126 %{_mandir}/man1/gcstar.1*
127 %{_desktopdir}/gcstar.desktop
128 %{_pixmapsdir}/gcstar.png
This page took 0.484853 seconds and 4 git commands to generate.