]> git.pld-linux.org Git - packages/gcr.git/commitdiff
- updated to 3.41.1 auto/th/gcr-3.41.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Mar 2023 17:05:25 +0000 (18:05 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Mar 2023 17:05:25 +0000 (18:05 +0100)
gcr.spec
meson0.61.patch [deleted file]

index 70e0112edf831273d27394481b77066bea24087a..cad97caf5576e30afebe58f67060ea7b20c28327 100644 (file)
--- a/gcr.spec
+++ b/gcr.spec
@@ -1,28 +1,27 @@
 #
 # Conditional build:
-%bcond_without apidocs         # do not build and package API docs
+%bcond_without apidocs         # API documentation
 
 Summary:       GObject and GUI library for high level crypto parsing and display
 Summary(pl.UTF-8):     Biblioteka GObject i GUI do wysokopoziomowej analizy i wyƛwietlania danych kryptograficznych
 Name:          gcr
-Version:       3.41.0
-Release:       4
+Version:       3.41.1
+Release:       1
 License:       LGPL v2+
 Group:         X11/Applications
 Source0:       https://download.gnome.org/sources/gcr/3.41/%{name}-%{version}.tar.xz
-# Source0-md5: 6b6d52de90d4ae95be7d36abf66626fa
-Patch0:                meson0.61.patch
+# Source0-md5: c1e98af977236255006e11e8f8cfbaca
 URL:           https://gitlab.gnome.org/GNOME/gcr
 BuildRequires: gettext-tools >= 0.19.8
 BuildRequires: glib2-devel >= 1:2.44.0
 BuildRequires: gobject-introspection-devel >= 1.34.0
 BuildRequires: gtk+3-devel >= 3.22.0
-BuildRequires: gtk-doc >= 1.9
+%{?with_apidocs:BuildRequires: gi-docgen}
 BuildRequires: libgcrypt-devel >= 1.4.5
 BuildRequires: libsecret-devel >= 0.20
 BuildRequires: libtasn1-devel
 BuildRequires: libxslt-progs
-BuildRequires: meson >= 0.49
+BuildRequires: meson >= 0.52
 BuildRequires: ninja >= 1.5
 BuildRequires: openssh-clients
 BuildRequires: p11-kit-devel >= 0.19.0
@@ -164,7 +163,6 @@ Dokumentacja API bibliotek gcr i gck.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %meson build \
@@ -178,6 +176,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %ninja_install -C build
 
+%if %{with apidocs}
+# FIXME: where to package gi-docgen generated docs?
+install -d $RPM_BUILD_ROOT%{_gtkdocdir}
+%{__mv} $RPM_BUILD_ROOT%{_docdir}/gc* $RPM_BUILD_ROOT%{_gtkdocdir}
+%endif
+
 %find_lang %{name}
 
 %clean
@@ -278,6 +282,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
-%{_gtkdocdir}/gck
-%{_gtkdocdir}/gcr
+%{_gtkdocdir}/gck-1
+%{_gtkdocdir}/gcr-3
+%{_gtkdocdir}/gcr-ui-3
 %endif
diff --git a/meson0.61.patch b/meson0.61.patch
deleted file mode 100644 (file)
index 548368b..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-From b3ca1d02bb0148ca787ac4aead164d7c8ce2c4d8 Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Wed, 12 Jan 2022 00:24:20 +0100
-Subject: [PATCH] meson: Fix unknown kw argument in gnome.generate_gir
-
-This argument has been removed in Meson 0.61.0:
-
-    gck/meson.build:130:2: ERROR: gnome.generate_gir got unknown keyword arguments "packages"
-
-https://github.com/mesonbuild/meson/commit/f8fc5cb860465718fe7c79a1bf1fe00659f138de:
-
-> The packages argument to gnome.generate_gir was allowed, but never did anything, so stop passing it.
-
-Fixes #89
----
- gck/meson.build | 1 -
- gcr/meson.build | 1 -
- ui/meson.build  | 1 -
- 3 files changed, 3 deletions(-)
-
-diff --git a/gck/meson.build b/gck/meson.build
-index 756b4866..a21a1e9d 100644
---- a/gck/meson.build
-+++ b/gck/meson.build
-@@ -131,7 +131,6 @@ if get_option('introspection')
-     sources: gck_gir_sources,
-     namespace: 'Gck',
-     nsversion: '@0@'.format(gck_major_version),
--    packages: gck_deps,
-     export_packages: 'gck-@0@'.format(gck_major_version),
-     includes: [ 'GObject-2.0', 'Gio-2.0' ],
-     header: 'gck/gck.h',
-diff --git a/gcr/meson.build b/gcr/meson.build
-index 2233a445..c83641ba 100644
---- a/gcr/meson.build
-+++ b/gcr/meson.build
-@@ -190,7 +190,6 @@ if get_option('introspection')
-     sources: [ gcr_base_public_sources, gcr_base_headers ],
-     namespace: 'Gcr',
-     nsversion: '@0@'.format(gcr_major_version),
--    packages: gcr_base_deps,
-     export_packages: 'gcr-base-@0@'.format(gcr_major_version),
-     includes: [
-       'GObject-2.0',
-diff --git a/ui/meson.build b/ui/meson.build
-index e656ea23..32ee057f 100644
---- a/ui/meson.build
-+++ b/ui/meson.build
-@@ -152,7 +152,6 @@ if get_option('introspection')
-     export_packages: 'gcr-ui-@0@'.format(gcr_major_version),
-     identifier_prefix: 'Gcr',
-     symbol_prefix: 'gcr',
--    packages: gcr_ui_deps,
-     includes: [
-       'GObject-2.0',
-       'Gio-2.0',
--- 
-GitLab
-
This page took 0.100886 seconds and 4 git commands to generate.