]> git.pld-linux.org Git - packages/gcompris.git/blob - gcompris.spec
disable info file build, gives errors
[packages/gcompris.git] / gcompris.spec
1 #
2 # Conditional build:
3 %bcond_without  gnet    # build without gnet support (disallow GCompris fetch content from a web server)
4 %bcond_with     info    # build info doc
5
6 Summary:        Educational suite for kids 2-10 years old
7 Summary(pl.UTF-8):      Zestaw edukacyjny dla dzieci w wieku 2-10 lat
8 Name:           gcompris
9 Version:        11.09
10 Release:        1
11 License:        GPL v3+
12 Group:          X11/Applications/Games
13 Source0:        http://downloads.sourceforge.net/gcompris/%{name}-%{version}.tar.gz
14 # Source0-md5:  b0066d5e0bb4e2fbb7380f723b51c598
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-desktop.patch
17 URL:            http://gcompris.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gettext-tools
21 BuildRequires:  gnet-devel
22 BuildRequires:  gnome-common
23 BuildRequires:  gstreamer-devel
24 BuildRequires:  intltool
25 BuildRequires:  libao-devel
26 BuildRequires:  libogg-devel
27 BuildRequires:  librsvg-devel >= 1:2.34.1
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool
30 BuildRequires:  libvorbis-devel
31 BuildRequires:  libxml2-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  popt-devel >= 1.5
34 BuildRequires:  python-devel
35 BuildRequires:  python-pycairo-devel
36 BuildRequires:  python-pygtk-devel
37 BuildRequires:  python-sqlite
38 BuildRequires:  sqlite3-devel
39 BuildRequires:  texi2html
40 BuildRequires:  texinfo
41 Requires:       gstreamer-audio-formats
42 Requires:       gstreamer-audiosink
43 Requires:       gstreamer-vorbis
44 Requires:       python-gnome-canvas
45 Requires:       python-modules
46 Requires:       python-sqlite
47 Suggests:       gnuchess
48 Suggests:       tuxpaint
49 Obsoletes:      gcompris-devel
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 GCompris / I Have Understood is an educational game for children
54 starting at 2. Today several Boards are implemented:
55 - Click on the animals => learn the mouse/click usage
56 - Type the falling letters => learn the keyboard usage
57 - Falling Dices
58 - Falling words
59 - Basic algebra
60 - Time learning with an analog clock
61 - Puzzle game with famous paintings
62 - Drive Plane to catch clouds in increasing number
63 - Balance the scales
64 - And much more ...
65
66 The game is included in the GNOME desktop under the Game menu.
67
68 You should install it only if you have children using this computer.
69
70 %description -l fr.UTF-8
71 GCompris / J'ai Compris est un logiciel éducatif pour les enfants à
72 partir de 2 ans.
73
74 Aujourd'hui, plusieurs tableaux sont implémentés :
75 - Cliquer sur les animaux => apprentissage du click et de la souris
76 - Entrer les lettres qui tombent => Apprentissage du clavier
77 - Les dés qui tombent
78 - Les mots qui tombent
79 - Algèbre simple
80 - Apprentissage de la lecture de l'heure sur une horloge analogique
81 - Puzzle avec des tableaux célèbres
82 - Pilote un avion pour attraper les nuages dans l'ordre
83 - Equilibre la balance
84
85 Le jeu est inclus dans le bureau GNOME sous le menu Jeux.
86
87 À installer si vous avez des enfants utilisant cet ordinateur.
88
89 %description -l pl.UTF-8
90 GCompris / Zrozumiałem to gra edukacyjna dla dzieci od 2 lat.
91 Aktualnie zaimplementowane jest kilka plansz:
92 - klikanie na zwierzętach - nauka używania myszy/klikania
93 - wpisywanie spadających liter - nauka używania klawiatury
94 - spadające kostki
95 - spadające słowa
96 - podstawowa algebra
97 - nauka czasu z zegarkiem analogowym
98 - układanka ze słynnymi obrazami
99 - prowadzenie samolotu z łapaniem coraz większej liczby chmur
100 - równoważenie wagi
101 - i wiele więcej...
102
103 Gra jest włączana do menu Gry na pulpicie GNOME.
104
105 Warto ją instalować tylko jeśli mamy dzieci używające komputera.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111
112 %{__sed} -i -e 's/-Werror -O2//' configure.ac
113 %{__sed} -i -e 's/-DG_DISABLE_DEPRECATED//' src/goocanvas/src/Makefile.am
114
115 %build
116 cp %{_datadir}/gettext/config.rpath .
117 %{__glib_gettextize}
118 %{__intltoolize}
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         GNUCHESS="%{_bindir}/gnuchess" \
126         --%{!?with_gnet:dis}%{?with_gnet:en}able-gnet \
127         --disable-silent-rules
128 %{__make} \
129         %{!?with_info:INFO_DEPS=}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         %{!?with_info:INFO_DEPS=} \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 # replace fr with en one
139 %if %{with info}
140 cp -p docs/C/gcompris.info $RPM_BUILD_ROOT%{_infodir}/gcompris.info
141 %endif
142
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
144
145 # unsupported
146 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr_ME
147
148 %find_lang %{name} --with-gnome
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %if %{with info}
154 %post   -p      /sbin/postshell
155 -/usr/sbin/fix-info-dir -c %{_infodir}
156
157 %postun -p      /sbin/postshell
158 -/usr/sbin/fix-info-dir -c %{_infodir}
159 %endif
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog README README.translators THANKS TODO
164 %attr(755,root,root) %{_bindir}/*
165 %dir %{_libdir}/%{name}
166 %attr(755,root,root) %{_libdir}/%{name}/lib*.so
167 %dir %{_datadir}/gcompris
168 %{_datadir}/gcompris/boards
169 %{_datadir}/gcompris/python
170 %{_desktopdir}/*.desktop
171 %{?with_info:%{_infodir}/*.info*}
172 # gcompris uses its own goocanvas libraries with some specific changes
173 %attr(755,root,root) %{_libdir}/gcompris/libgoocanvas.so.0
174 %attr(755,root,root) %{_libdir}/gcompris/libgoocanvas.so.0.0.0
175 %{_mandir}/man6/gcompris.*
176 %{_pixmapsdir}/*.png
This page took 0.585851 seconds and 3 git commands to generate.