]> git.pld-linux.org Git - packages/gcm.git/blob - gcm.spec
- moved documentation to proper dir
[packages/gcm.git] / gcm.spec
1
2 %define         librtftohtml_ver        2.0.2
3
4 Summary:        GNOME Clipboard Manager - an application to manage your selections and clipboards
5 Summary(pl):    Zarz±dca schowka GNOME - aplikacja do zarz±dzania zaznaczeniami i schowkami
6 Name:           gcm
7 Version:        2.0.4
8 Release:        3
9 License:        GPL
10 Group:          X11/Applications
11 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12 # Source0-md5:  27e5dbea93240195296113c874411136
13 Patch0:         %{name}-desktop_location.patch
14 Patch1:         %{name}-gettext_fixes.patch
15 URL:            http://gcm.sf.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel
19 BuildRequires:  intltool
20 BuildRequires:  libtool
21 Requires(post): /sbin/ldconfig
22 Requires(post): GConf2
23 Requires:       librtftohtml = %{librtftohtml_ver}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 GNOME Clipboard Manager (GCM) is an application for managing
28 selections and clipboards. It autocollects selections on a shelf and
29 has the option to choose which selection is to be pasted. Selections
30 can be edited, manually created, deleted, copied, and pasted. The
31 available selection types are clipboard, primary, secondary, or a
32 custom atom.
33
34 %description -l pl
35 GCM (GNOME Clipboard Manager - zarz±dca schowka GNOME) to aplikacja do
36 zarz±dzania zaznaczeniami i schowkami. Automatycznie zbiera zaznaczone
37 fragmenty i umo¿liwia wybór, który fragment ma zostaæ wklejony.
38 Zaznaczenia mog± byæ modyfikowane, rêcznie tworzone, usuwane,
39 kopiowane i wklejane. Dostêpne rodzaje zaznaczeñ to schowek,
40 podstawowe, drugorzêdne lub w³asne.
41
42 %package devel
43 Summary:        Header files for gcm
44 Summary(pl):    Pliki nag³ówkowe gcm
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}
47
48 %description devel
49 Header files for gcm.
50
51 %description devel -l pl
52 Pliki nag³ówkowe gcm.
53
54 %package static
55 Summary:        Static gcm library
56 Summary(pl):    Statyczna biblioteka gcm
57 Group:          X11/Development/Libraries
58 Requires:       %{name}-devel = %{version}
59
60 %description static
61 Static gcm library.
62
63 %description static -l pl
64 Statyczna biblioteka gcm.
65
66 %package -n librtftohtml
67 Summary:        RTF to HTML convert library
68 Summary(pl):    Biblioteka konwertuj±ca RTF do HTML
69 Version:        %{librtftohtml_ver}
70 Group:          X11/Development/Libraries
71
72 %description -n librtftohtml
73 RTF to HTML convert library.
74
75 %description -n librtftohtml -l pl
76 Biblioteka konwertuj±ca RTF do HTML.
77
78 %package -n librtftohtml-devel
79 Summary:        Header files for RTF to HTML convert library
80 Summary(pl):    Pliki nag³ówkowe biblioteki konwertuj±cej RTF do HTML
81 Version:        %{librtftohtml_ver}
82 Group:          X11/Development/Libraries
83 Requires:       librtftohtml = %{librtftohtml_ver}
84
85 %description -n librtftohtml-devel
86 Header files for RTF to HTML convert library.
87
88 %description -n librtftohtml-devel -l pl
89 Pliki nag³ówkowe biblioteki konwertuj±cej RTF do HTML.
90
91 %package -n librtftohtml-static
92 Summary:        Static RTF to HTML convert library
93 Summary(pl):    Statyczna biblioteka konwertuj±ca RTF do HTML
94 Version:        %{librtftohtml_ver}
95 Group:          X11/Development/Libraries
96 Requires:       librtftohtml-devel = %{librtftohtml_ver}
97
98 %description -n librtftohtml-static
99 Static file for RTF to HTML convert library.
100
101 %description -n librtftohtml-static -l pl
102 Statyczna biblioteka konwertuj±ca RTF do HTML.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108
109 %build
110 cd libgcm
111 %{__aclocal}
112 cd ../librtftohtml
113 %{__aclocal}
114 cd ../gcmapplet
115 %{__aclocal}
116 %{__autoconf}
117 cd ..
118 rm -f mkinstalldirs
119 cp /usr/share/automake/mkinstalldirs .
120 glib-gettextize --copy --force
121 intltoolize --copy --force
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoheader}
125 %{__automake}
126 %{__autoconf}
127 %configure \
128         --disable-schemas-install
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT \
136         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
137
138 #remove obsolete files:
139 rm $RPM_BUILD_ROOT%{_libdir}/gcm/Plugins/*.{a,la}
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/ldconfig
148 %gconf_schema_install
149
150 %postun -p /sbin/ldconfig
151
152 %post   -n librtftohtml -p /sbin/ldconfig
153 %postun -n librtftohtml -p /sbin/ldconfig
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog README TODO doc/*.html doc/*.png doc/HACKING
158 %attr(755,root,root) %{_bindir}/gcm
159 %attr(755,root,root) %{_bindir}/gcmui
160 %attr(755,root,root) %{_libdir}/gcmapplet
161 %attr(755,root,root) %{_libdir}/libgcm.so.*.*.*
162 %dir %{_libdir}/gcm
163 %dir %{_libdir}/gcm/Plugins
164 %attr(755,root,root) %{_libdir}/gcm/Plugins/*.so
165 %{_datadir}/gnome-2.0/ui/*
166 %{_desktopdir}/*
167 %{_libdir}/bonobo/servers/*
168 %{_mandir}/man1/gcm.1*
169 %{_pixmapsdir}/*
170 %{_sysconfdir}/gconf/schemas/*
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/gcm-config
175 %attr(755,root,root) %{_libdir}/libgcm.so
176 %{_libdir}/libgcm.la
177 %{_includedir}/libgcm
178 %{_pkgconfigdir}/libgcm.pc
179 %{_mandir}/man1/gcm-config.1*
180
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libgcm.a
184
185 %files -n librtftohtml
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/librtftohtml.so.*.*.*
188
189 %files -n librtftohtml-devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/librtftohtml.so
192 %{_libdir}/librtftohtml.la
193 %{_includedir}/librtftohtml
194 %{_pkgconfigdir}/librtftohtml.pc
195
196 %files -n librtftohtml-static
197 %defattr(644,root,root,755)
198 %{_libdir}/librtftohtml.a
This page took 0.082316 seconds and 3 git commands to generate.