]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- gcc-gcc4.patch. Building still fails in another place.
[packages/gcl.git] / gcl.spec
1 #
2 # Conditional build:
3 %bcond_without  builtin_bfd     # use built in bfd instead of system one
4 #               (currently does not build with system one from new binutils)
5 #
6 Summary:        GNU Common Lisp system
7 Summary(pl):    System GNU Common Lisp
8 Name:           gcl
9 Version:        2.6.6
10 Release:        3
11 License:        LGPL v2
12 Group:          Development/Languages
13 Source0:        ftp://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
14 # Source0-md5:  45d67331b29cafc3e9b1eacb488044ec
15 Patch0:         %{name}-make.patch
16 Patch1:         %{name}-info.patch
17 # It seems this patch doesn't fix what it should: still doesn't build with
18 # newer binutils
19 #Patch2:                %{name}-binutils.patch
20 Patch3:         %{name}-gcc4.patch
21 URL:            http://www.gnu.org/software/gcl/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gmp-devel >= 4.0
25 BuildRequires:  readline-devel
26 BuildRequires:  texinfo
27 %define _tkline 8.4
28 BuildRequires:  tk-devel >= %{_tkline}
29 BuildRequires:  xemacs
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The GNU Common Lisp system, based on KCL.
34
35 %description -l pl
36 System GNU Common Lisp, bazuj±cy na KCL.
37
38 %package tk
39 Summary:        Tcl/Tk bindings for GNU Common Lisp
40 Summary(pl):    Interfejs Tcl/Tk do GNU Common Lisp
41 Group:          Development/Languages
42 Requires:       %{name} = %{version}-%{release}
43
44 %description tk
45 Tcl/Tk bindings for GNU Common Lisp.
46
47 %description tk -l pl
48 Interfejs Tcl/Tk dla GNU Common Lisp.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %patch1 -p1
54 #%%patch2 -p1
55 %patch3 -p1
56
57 %build
58 %{__aclocal}
59 %{__autoconf}
60 cp -f /usr/share/automake/config.* .
61 GCC="%{__cc}"; export GCC
62 # note: full path to xemacs must be passed
63 EMACS=/usr/bin/xemacs; export EMACS
64 %configure \
65         --disable-statsysbfd \
66 %ifnarch alpha hppa ia64 mips
67 %if %{with builtin_bfd}
68         --enable-locbfd \
69 %else
70         --enable-dynsysbfd \
71 %endif
72 %endif
73         --enable-dynsysgmp \
74         --enable-notify=no
75
76 %{__make} \
77         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
82
83 %{__make} install1 \
84         DESTDIR=$RPM_BUILD_ROOT \
85         INSTALL_LIB_DIR=%{_libdir}/gcl
86
87 mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
88 rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
89
90 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
91
92 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
93
94 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
95 #!/bin/sh
96 exec %{_libdir}/gcl/unixport/saved_gcl \
97         -dir {_libdir}/gcl/unixport/ \
98         -libdir %{_libdir}/gcl/ \
99         -eval '(setq si::*allow-gzipped-file* t)' \
100         "$@"
101 EOF
102
103 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
104 #!/bin/sh
105 exec %{_libdir}/gcl/unixport/saved_gcl \
106         -dir {_libdir}/gcl/unixport/ \
107         -libdir %{_libdir}/gcl/ \
108         -eval '(setq si::*allow-gzipped-file* t)' \
109         -eval '(setq si::*tk-library* "/usr/lib/tk%{_tkline}")' \
110         "$@"
111 EOF
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
118
119 %postun
120 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
121
122 %post tk
123 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
124
125 %postun tk
126 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
127
128 %files
129 %defattr(644,root,root,755)
130 %doc readme faq ChangeLog
131 %attr(755,root,root) %{_bindir}/gcl
132 %attr(755,root,root) %{_bindir}/gcl.exe
133 %dir %{_libdir}/gcl
134 %{_libdir}/gcl/clcs
135 %{_libdir}/gcl/cmpnew
136 %{_libdir}/gcl/h
137 %{_libdir}/gcl/lsp
138 %{_libdir}/gcl/pcl
139 %dir %{_libdir}/gcl/unixport
140 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
141 %{_libdir}/gcl/unixport/*.lsp
142 # to -devel?
143 #%{_libdir}/gcl/unixport/*.a
144 %{_infodir}/gcl-si.info*
145 %{_mandir}/man1/*
146
147 %files tk
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_bindir}/gcl-tk
150 %dir %{_libdir}/gcl/gcl-tk
151 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
152 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
153 %{_libdir}/gcl/gcl-tk/*.o
154 %{_libdir}/gcl/gcl-tk/*.tcl
155 %{_infodir}/gcl-tk.info*
This page took 0.178327 seconds and 4 git commands to generate.