]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
d148e02f766e3563439dbd93a67857dc87061e80
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp system
2 Summary(pl):    System GNU Common Lisp
3 Name:           gcl
4 Version:        2.6.2
5 Release:        1
6 License:        LGPL v2
7 Group:          Development/Languages
8 Source0:        ftp://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
9 # Source0-md5:  dfb205e96b5cfa1ab1795110cf38f209
10 Patch0:         %{name}-make.patch
11 Patch1:         %{name}-info.patch
12 URL:            http://www.gnu.org/software/gcl/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  gmp-devel >= 4.0
16 BuildRequires:  readline-devel
17 %define _tkline 8.4
18 BuildRequires:  tk-devel >= %{_tkline}
19 BuildRequires:  xemacs
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The GNU Common Lisp system, based on KCL.
24
25 %description -l pl
26 System GNU Common Lisp, bazuj±cy na KCL.
27
28 %package tk
29 Summary:        Tcl/Tk bindings for GNU Common Lisp
30 Summary(pl):    Interfejs Tcl/Tk do GNU Common Lisp
31 Group:          Development/Languages
32 Requires:       %{name} = %{version}-%{release}
33
34 %description tk
35 Tcl/Tk bindings for GNU Common Lisp.
36
37 %description tk -l pl
38 Intefejs Tcl/Tk dla GNU Common Lisp.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43 %patch1 -p1
44
45 %build
46 %{__aclocal}
47 %{__autoconf}
48 cp -f /usr/share/automake/config.* .
49 GCC="%{__cc}"; export GCC
50 # note: full path to xemacs must be passed
51 EMACS=/usr/bin/xemacs; export EMACS
52 %configure \
53         --disable-statsysbfd \
54         --enable-dynsysbfd \
55         --enable-dynsysgmp \
56         --enable-notify=no
57
58 %{__make} \
59         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
64
65 %{__make} install1 \
66         DESTDIR=$RPM_BUILD_ROOT \
67         INSTALL_LIB_DIR=%{_libdir}/gcl
68
69 mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
70 rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
71
72 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
73
74 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
75
76 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
77 #!/bin/sh
78 exec %{_libdir}/gcl/unixport/saved_gcl \
79         -dir {_libdir}/gcl/unixport/ \
80         -libdir %{_libdir}/gcl/ \
81         -eval '(setq si::*allow-gzipped-file* t)' \
82         "$@"
83 EOF
84
85 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
86 #!/bin/sh
87 exec %{_libdir}/gcl/unixport/saved_gcl \
88         -dir {_libdir}/gcl/unixport/ \
89         -libdir %{_libdir}/gcl/ \
90         -eval '(setq si::*allow-gzipped-file* t)' \
91         -eval '(setq si::*tk-library* "/usr/lib/tk%{_tkline}")' \
92         "$@"
93 EOF
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
100
101 %postun
102 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
103
104 %post tk
105 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
106
107 %postun tk
108 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
109
110 %files
111 %defattr(644,root,root,755)
112 %doc readme faq ChangeLog
113 %attr(755,root,root) %{_bindir}/gcl
114 %attr(755,root,root) %{_bindir}/gcl.exe
115 %dir %{_libdir}/gcl
116 %{_libdir}/gcl/clcs
117 %{_libdir}/gcl/cmpnew
118 %{_libdir}/gcl/h
119 %{_libdir}/gcl/lsp
120 %{_libdir}/gcl/pcl
121 %dir %{_libdir}/gcl/unixport
122 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
123 %{_libdir}/gcl/unixport/*.lsp
124 # to -devel?
125 #%{_libdir}/gcl/unixport/*.a
126 %{_infodir}/gcl-si.info*
127 %{_mandir}/man1/*
128
129 %files tk
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/gcl-tk
132 %dir %{_libdir}/gcl/gcl-tk
133 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
134 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
135 %{_libdir}/gcl/gcl-tk/*.o
136 %{_libdir}/gcl/gcl-tk/*.tcl
137 %{_infodir}/gcl-tk.info*
This page took 0.06597 seconds and 2 git commands to generate.