]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- typos / formatting / etc.
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp system
2 Summary(pl):    System GNU Common Lisp
3 Name:           gcl
4 Version:        2.6.5
5 Release:        2
6 License:        LGPL v2
7 Group:          Development/Languages
8 Source0:        ftp://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
9 # Source0-md5:  e0852318b81c93b76bc7e012f036ec6c
10 Patch0:         %{name}-make.patch
11 Patch1:         %{name}-info.patch
12 URL:            http://www.gnu.org/software/gcl/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  gmp-devel >= 4.0
16 BuildRequires:  readline-devel
17 %define _tkline 8.4
18 BuildRequires:  tk-devel >= %{_tkline}
19 BuildRequires:  xemacs
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The GNU Common Lisp system, based on KCL.
24
25 %description -l pl
26 System GNU Common Lisp, bazuj±cy na KCL.
27
28 %package tk
29 Summary:        Tcl/Tk bindings for GNU Common Lisp
30 Summary(pl):    Interfejs Tcl/Tk do GNU Common Lisp
31 Group:          Development/Languages
32 Requires:       %{name} = %{version}-%{release}
33
34 %description tk
35 Tcl/Tk bindings for GNU Common Lisp.
36
37 %description tk -l pl
38 Interfejs Tcl/Tk dla GNU Common Lisp.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43 %patch1 -p1
44
45 %build
46 %{__aclocal}
47 %{__autoconf}
48 cp -f /usr/share/automake/config.* .
49 GCC="%{__cc}"; export GCC
50 # note: full path to xemacs must be passed
51 EMACS=/usr/bin/xemacs; export EMACS
52 %configure \
53         --disable-statsysbfd \
54 %ifnarch alpha hppa ia64 mips
55         --enable-dynsysbfd \
56 %endif
57         --enable-dynsysgmp \
58         --enable-notify=no
59
60 %{__make} \
61         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
66
67 %{__make} install1 \
68         DESTDIR=$RPM_BUILD_ROOT \
69         INSTALL_LIB_DIR=%{_libdir}/gcl
70
71 mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
72 rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
73
74 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
75
76 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
77
78 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
79 #!/bin/sh
80 exec %{_libdir}/gcl/unixport/saved_gcl \
81         -dir {_libdir}/gcl/unixport/ \
82         -libdir %{_libdir}/gcl/ \
83         -eval '(setq si::*allow-gzipped-file* t)' \
84         "$@"
85 EOF
86
87 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
88 #!/bin/sh
89 exec %{_libdir}/gcl/unixport/saved_gcl \
90         -dir {_libdir}/gcl/unixport/ \
91         -libdir %{_libdir}/gcl/ \
92         -eval '(setq si::*allow-gzipped-file* t)' \
93         -eval '(setq si::*tk-library* "/usr/lib/tk%{_tkline}")' \
94         "$@"
95 EOF
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
102
103 %postun
104 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
105
106 %post tk
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
108
109 %postun tk
110 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
111
112 %files
113 %defattr(644,root,root,755)
114 %doc readme faq ChangeLog
115 %attr(755,root,root) %{_bindir}/gcl
116 %attr(755,root,root) %{_bindir}/gcl.exe
117 %dir %{_libdir}/gcl
118 %{_libdir}/gcl/clcs
119 %{_libdir}/gcl/cmpnew
120 %{_libdir}/gcl/h
121 %{_libdir}/gcl/lsp
122 %{_libdir}/gcl/pcl
123 %dir %{_libdir}/gcl/unixport
124 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
125 %{_libdir}/gcl/unixport/*.lsp
126 # to -devel?
127 #%{_libdir}/gcl/unixport/*.a
128 %{_infodir}/gcl-si.info*
129 %{_mandir}/man1/*
130
131 %files tk
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/gcl-tk
134 %dir %{_libdir}/gcl/gcl-tk
135 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
136 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
137 %{_libdir}/gcl/gcl-tk/*.o
138 %{_libdir}/gcl/gcl-tk/*.tcl
139 %{_infodir}/gcl-tk.info*
This page took 0.072365 seconds and 3 git commands to generate.