]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- s/tk/Tk/
[packages/gcl.git] / gcl.spec
1
2 Summary:        GNU Common Lisp
3 Summary(pl):    GNU Common Lisp
4 Name:           gcl
5 Version:        2.4.4
6 Release:        1
7 License:        LGPL v2
8 Group:          Development/Languages
9 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
10 # Source0-md5:  cd2326647d1cd18ccec088370ebdf58d
11 Patch0:         %{name}-make.patch
12 Patch1:         %{name}-OPT.patch
13 Patch2:         %{name}-info.patch
14 Patch3:         %{name}-libgmp.patch
15 Patch4:         %{name}-bfd.patch
16 URL:            http://www.ma.utexas.edu/users/wfs/gcl.html
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gmp-devel
20 BuildRequires:  tk-devel
21 BuildRequires:  xemacs
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 ExclusiveArch:  %{ix86} sparc
24
25 %description
26 The GNU Common Lisp system, based on KCL.
27
28 %description -l pl
29 System GNU Common Lisp, bazuj±cy na KCL.
30
31 %package tk
32 Summary:        Tcl/Tk bindings for GNU Common Lisp
33 Summary(pl):    Interfejs Tcl/Tk do GNU Common Lisp
34 Group:          Development/Languages
35 Requires:       %{name} = %{version}
36
37 %description tk
38 Tcl/Tk bindings for GNU Common Lisp.
39
40 %description tk -l pl
41 Intefejs Tcl/Tk dla GNU Common Lisp.
42
43 %prep
44 %setup  -q
45 %patch0 -p1
46 %patch1 -p1
47 %patch2 -p1
48 %patch3 -p1
49 #%patch4 -p1
50
51 %build
52 rm -f missing
53 %{__aclocal}
54 %{__autoconf}
55 cp -f /usr/share/automake/config.* .
56 GCC="%{__cc}"; export GCC
57 # note: full path to xemacs must be passed
58 EMACS=/usr/bin/xemacs; export EMACS
59 %configure \
60         --enable-notify=no
61
62 %{__make} OPTFLAGS="%{rpmcflags}" \
63         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
68         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
69         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
70
71 (cd info
72 rm -f *info*
73 makeinfo gcl-si.texi gcl-tk.texi
74 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
75 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
76
77 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
78 install info/*info* $RPM_BUILD_ROOT%{_infodir}
79 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
80 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
81 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
82         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
83
84 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
85
86 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
87 #!/bin/sh
88 exec %{_libdir}/gcl/unixport/saved_gcl \
89         -dir {_libdir}/gcl/unixport/ \
90         -libdir %{_libdir}/gcl/ \
91         -eval '(setq si::*allow-gzipped-file* t)' \
92         "$@"
93 EOF
94
95 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
96 #!/bin/sh
97 exec %{_libdir}/gcl/unixport/saved_gcl \
98         -dir {_libdir}/gcl/unixport/ \
99         -libdir %{_libdir}/gcl/ \
100         -eval '(setq si::*allow-gzipped-file* t)' \
101         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
102         "$@"
103 EOF
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
110
111 %postun
112 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
113
114 %post tk
115 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
116
117 %postun tk
118 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
119
120 %files
121 %defattr(644,root,root,755)
122 %doc readme faq ChangeLog
123 %attr(755,root,root) %{_bindir}/gcl
124 %attr(755,root,root) %{_bindir}/gcl.exe
125 %{_libdir}/gcl/cmpnew
126 %{_libdir}/gcl/lsp
127 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
128 %{_infodir}/gcl-si.info*
129 %{_mandir}/man1/*
130
131 %files tk
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/gcl-tk
134 %dir %{_libdir}/gcl/gcl-tk
135 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
136 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
137 %{_libdir}/gcl/gcl-tk/*.o
138 %{_libdir}/gcl/gcl-tk/*.tcl
139 %{_infodir}/gcl-tk.info*
This page took 0.059966 seconds and 3 git commands to generate.