]> git.pld-linux.org Git - packages/gccxml.git/blob - gccxml.spec
- added naive gcc 5.1/5.2 support (treat as 4.9); release .3
[packages/gccxml.git] / gccxml.spec
1 Summary:        GCC-XML - dump XML description of C++ source code
2 Summary(pl.UTF-8):      GCC-XML - zrzut opisu XML kodu źródłowego w C++
3 Name:           gccxml
4 Version:        0.9.0
5 %define gitref  3afa8ba5be6866e603dcabe80aff79856b558e24
6 %define snap    20150424
7 %define rel     3
8 Release:        0.%{snap}.%{rel}
9 License:        GPL v2+ (GCC code), BSD-like (GCC-XML)
10 Group:          Development/Tools
11 Source0:        https://github.com/gccxml/gccxml/archive/%{gitref}/%{name}-%{snap}.tar.gz
12 # Source0-md5:  70e4b145feb2a7036c835cf214cae26a
13 Patch0:         %{name}-gcc.patch
14 URL:            http://gccxml.github.io/HTML/Index.html
15 BuildRequires:  cmake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 GCC-XML program dumps an XML description of C++ source code using an
22 extension on the GCC C++ compiler.
23
24 %description -l pl.UTF-8
25 GCC-XML to program zrzucający opis XML kodu źródłowego w C++ przy
26 użyciu rozszerzenia kompulatora C++ GCC.
27
28 %prep
29 %setup -q -n %{name}-%{gitref}
30 %patch0 -p1
31
32 %build
33 install -d build
34 cd build
35 %cmake ..
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} -C build install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 # packaged as %doc
45 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gccxml-0.9
46
47 for ver in 5.1 5.2 ; do
48         ln -sf 4.9 $RPM_BUILD_ROOT%{_datadir}/gccxml-0.9/GCC/$ver
49 done
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc LICENSE.rst README.rst GCC_XML/Copyright.txt build/GCC_XML/doc/gccxml.html
57 %attr(755,root,root) %{_bindir}/gccxml
58 %attr(755,root,root) %{_bindir}/gccxml_cc1plus
59 %dir %{_datadir}/gccxml-0.9
60 %{_datadir}/gccxml-0.9/gccxml_config
61 %{_datadir}/gccxml-0.9/gccxml_identify_compiler.cc
62 %dir %{_datadir}/gccxml-0.9/GCC
63 %{_datadir}/gccxml-0.9/GCC/2.95
64 %{_datadir}/gccxml-0.9/GCC/2.96
65 %{_datadir}/gccxml-0.9/GCC/3.0
66 %{_datadir}/gccxml-0.9/GCC/3.1
67 %{_datadir}/gccxml-0.9/GCC/3.2
68 %{_datadir}/gccxml-0.9/GCC/3.3
69 %{_datadir}/gccxml-0.9/GCC/3.4
70 %{_datadir}/gccxml-0.9/GCC/4.0
71 %{_datadir}/gccxml-0.9/GCC/4.1
72 %{_datadir}/gccxml-0.9/GCC/4.2
73 %{_datadir}/gccxml-0.9/GCC/4.3
74 %{_datadir}/gccxml-0.9/GCC/4.4
75 %{_datadir}/gccxml-0.9/GCC/4.5
76 %{_datadir}/gccxml-0.9/GCC/4.6
77 %{_datadir}/gccxml-0.9/GCC/4.7
78 %{_datadir}/gccxml-0.9/GCC/4.8
79 %{_datadir}/gccxml-0.9/GCC/4.9
80 %{_datadir}/gccxml-0.9/GCC/5.1
81 %{_datadir}/gccxml-0.9/GCC/5.2
82 %dir %{_datadir}/gccxml-0.9/IBM
83 %{_datadir}/gccxml-0.9/IBM/8.0
84 %attr(755,root,root) %{_datadir}/gccxml-0.9/IBM/find_flags
85 %{_datadir}/gccxml-0.9/IBM/find_flags_common
86 %dir %{_datadir}/gccxml-0.9/Intel
87 %attr(755,root,root) %{_datadir}/gccxml-0.9/Intel/find_flags
88 %{_datadir}/gccxml-0.9/Intel/pthread.h
89 %dir %{_datadir}/gccxml-0.9/MIPSpro
90 %{_datadir}/gccxml-0.9/MIPSpro/7.3
91 %attr(755,root,root) %{_datadir}/gccxml-0.9/MIPSpro/find_flags
92 %{_datadir}/gccxml-0.9/MIPSpro/mipspro_defs.cxx
93 %dir %{_datadir}/gccxml-0.9/Sun
94 %{_datadir}/gccxml-0.9/Sun/5.8
95 %attr(755,root,root) %{_datadir}/gccxml-0.9/Sun/find_flags
96 %{_datadir}/gccxml-0.9/Sun/find_flags_common
97 %{_mandir}/man1/gccxml.1*
This page took 0.175377 seconds and 4 git commands to generate.