]> git.pld-linux.org Git - packages/gccxml.git/blob - gccxml.spec
- updated to current master (0.9.0 snap; with improved gcc 4.x support)
[packages/gccxml.git] / gccxml.spec
1 Summary:        GCC-XML - dump XML description of C++ source code
2 Summary(pl.UTF-8):      GCC-XML - zrzut opisu XML kodu źródłowego w C++
3 Name:           gccxml
4 Version:        0.9.0
5 %define gitref  3afa8ba5be6866e603dcabe80aff79856b558e24
6 %define snap    20150424
7 Release:        0.%{snap}.1
8 License:        GPL v2+ (GCC code), BSD-like (GCC-XML)
9 Group:          Development/Tools
10 Source0:        https://github.com/gccxml/gccxml/archive/%{gitref}/%{name}-%{snap}.tar.gz
11 # Source0-md5:  70e4b145feb2a7036c835cf214cae26a
12 URL:            http://gccxml.github.io/HTML/Index.html
13 BuildRequires:  cmake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  rpmbuild(macros) >= 1.605
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 GCC-XML program dumps an XML description of C++ source code using an
20 extension on the GCC C++ compiler.
21
22 %description -l pl.UTF-8
23 GCC-XML to program zrzucający opis XML kodu źródłowego w C++ przy
24 użyciu rozszerzenia kompulatora C++ GCC.
25
26 %prep
27 %setup -q -n %{name}-%{gitref}
28
29 %build
30 install -d build
31 cd build
32 %cmake ..
33 %{__make}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 %{__make} -C build install \
39         DESTDIR=$RPM_BUILD_ROOT
40
41 # packaged as %doc
42 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gccxml-0.9
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc LICENSE.rst README.rst GCC_XML/Copyright.txt build/GCC_XML/doc/gccxml.html
50 %attr(755,root,root) %{_bindir}/gccxml
51 %attr(755,root,root) %{_bindir}/gccxml_cc1plus
52 %dir %{_datadir}/gccxml-0.9
53 %{_datadir}/gccxml-0.9/gccxml_config
54 %{_datadir}/gccxml-0.9/gccxml_identify_compiler.cc
55 %dir %{_datadir}/gccxml-0.9/GCC
56 %{_datadir}/gccxml-0.9/GCC/2.95
57 %{_datadir}/gccxml-0.9/GCC/2.96
58 %{_datadir}/gccxml-0.9/GCC/3.0
59 %{_datadir}/gccxml-0.9/GCC/3.1
60 %{_datadir}/gccxml-0.9/GCC/3.2
61 %{_datadir}/gccxml-0.9/GCC/3.3
62 %{_datadir}/gccxml-0.9/GCC/3.4
63 %{_datadir}/gccxml-0.9/GCC/4.0
64 %{_datadir}/gccxml-0.9/GCC/4.1
65 %{_datadir}/gccxml-0.9/GCC/4.2
66 %{_datadir}/gccxml-0.9/GCC/4.3
67 %{_datadir}/gccxml-0.9/GCC/4.4
68 %{_datadir}/gccxml-0.9/GCC/4.5
69 %{_datadir}/gccxml-0.9/GCC/4.6
70 %{_datadir}/gccxml-0.9/GCC/4.7
71 %{_datadir}/gccxml-0.9/GCC/4.8
72 %{_datadir}/gccxml-0.9/GCC/4.9
73 %dir %{_datadir}/gccxml-0.9/IBM
74 %{_datadir}/gccxml-0.9/IBM/8.0
75 %attr(755,root,root) %{_datadir}/gccxml-0.9/IBM/find_flags
76 %{_datadir}/gccxml-0.9/IBM/find_flags_common
77 %dir %{_datadir}/gccxml-0.9/Intel
78 %attr(755,root,root) %{_datadir}/gccxml-0.9/Intel/find_flags
79 %{_datadir}/gccxml-0.9/Intel/pthread.h
80 %dir %{_datadir}/gccxml-0.9/MIPSpro
81 %{_datadir}/gccxml-0.9/MIPSpro/7.3
82 %attr(755,root,root) %{_datadir}/gccxml-0.9/MIPSpro/find_flags
83 %{_datadir}/gccxml-0.9/MIPSpro/mipspro_defs.cxx
84 %dir %{_datadir}/gccxml-0.9/Sun
85 %{_datadir}/gccxml-0.9/Sun/5.8
86 %attr(755,root,root) %{_datadir}/gccxml-0.9/Sun/find_flags
87 %{_datadir}/gccxml-0.9/Sun/find_flags_common
88 %{_mandir}/man1/gccxml.1*
This page took 0.031749 seconds and 4 git commands to generate.