]> git.pld-linux.org Git - packages/gccxml.git/blob - gccxml.spec
- initial; unfortunately the last release doesn't work properly with gcc 4.9+
[packages/gccxml.git] / gccxml.spec
1 Summary:        GCC-XML - dump XML description of C++ source code
2 Summary(pl.UTF-8):      GCC-XML - zrzut opisu XML kodu źródłowego w C++
3 Name:           gccxml
4 Version:        0.6.0
5 Release:        1
6 License:        GPL v2+ (GCC code), BSD-like (GCC-XML)
7 Group:          Development/Tools
8 Source0:        https://github.com/gccxml/gccxml/archive/v%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  0458765b917dc385d91e0f14156572a8
10 Patch0:         %{name}-includes.patch
11 URL:            http://gccxml.github.io/HTML/Index.html
12 BuildRequires:  cmake
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  rpmbuild(macros) >= 1.605
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 GCC-XML program dumps an XML description of C++ source code using an
19 extension on the GCC C++ compiler.
20
21 %description -l pl.UTF-8
22 GCC-XML to program zrzucający opis XML kodu źródłowego w C++ przy
23 użyciu rozszerzenia kompulatora C++ GCC.
24
25 %prep
26 %setup -q
27 %patch0 -p1
28
29 # replace with new version
30 cp -f /usr/include/obstack.h GCC/include/obstack.h
31
32 %build
33 install -d build
34 cd build
35 %cmake ..
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} -C build install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 # packaged as %doc
45 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gccxml-0.6
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README GCC_XML/Copyright.txt build/bin/doc/gccxml.html
53 %attr(755,root,root) %{_bindir}/gccxml
54 %attr(755,root,root) %{_bindir}/gccxml_cc1plus
55 %dir %{_datadir}/gccxml-0.6
56 %{_datadir}/gccxml-0.6/gccxml_config
57 %attr(755,root,root) %{_datadir}/gccxml-0.6/gccxml_find_flags
58 %dir %{_datadir}/gccxml-0.6/GCC
59 %{_datadir}/gccxml-0.6/GCC/2.95
60 %{_datadir}/gccxml-0.6/GCC/3.3
61 %attr(755,root,root) %{_datadir}/gccxml-0.6/GCC/find_flags
62 %dir %{_datadir}/gccxml-0.6/Intel
63 %attr(755,root,root) %{_datadir}/gccxml-0.6/Intel/find_flags
64 %dir %{_datadir}/gccxml-0.6/MIPSpro
65 %{_datadir}/gccxml-0.6/MIPSpro/7.3
66 %attr(755,root,root) %{_datadir}/gccxml-0.6/MIPSpro/find_flags
67 %{_mandir}/man1/gccxml.1*
This page took 0.069142 seconds and 3 git commands to generate.