]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- fix files section
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 # _without_ada  - build without ADA support
4 # _without_java - build without Java support
5 #
6 %define         DASHED_SNAP     20021111        
7 %define         SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
8 %define         GCC_VERSION     3.2.1
9 %define         KSI_VERSION     pre55
10
11 Summary:        GNU Compiler Collection
12 Summary(pl):    Kolekcja kompilatorów GNU
13 Name:           gcc
14 Version:        %{GCC_VERSION}
15 Release:        0.pre.2
16 License:        GPL
17 Group:          Development/Languages
18 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}-%{SNAP}.tar.bz2
19 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
20 Source2:        %{name}-non-english-man-pages.tar.bz2
21 Patch0:         %{name}-slibdir.patch
22 Patch1:         %{name}-paths.patch
23 Patch2:         %{name}-ada-no-addr2line.patch
24 Patch3:         %{name}-ada-no-prefix.o.patch
25 Patch4:         %{name}-nolocalefiles.patch
26
27 Patch6:         %{name}-info.patch
28 # -- stolen patches from RH --
29 Patch10:        gcc32-ada-link.patch
30 Patch11:        gcc32-attr-visibility.patch
31 Patch12:        gcc32-attr-visibility2.patch
32 Patch13:        gcc32-attr-visibility3.patch
33 Patch14:        gcc32-attr-visibility4.patch
34 Patch15:        gcc32-attr-visibility5.patch
35 Patch16:        gcc32-boehm-gc-libs.patch
36 Patch17:        gcc32-bogus-inline.patch
37 Patch18:        gcc32-c++-nrv-test.patch
38 Patch19:        gcc32-c++-pretty_function.patch
39 Patch20:        gcc32-c++-tsubst-asm.patch
40 Patch21:        gcc32-cfg-eh.patch
41 Patch22:        gcc32-debug-pr7241.patch
42
43 Patch24:        gcc32-duplicate-decl.patch
44 Patch25:        gcc32-dwarf2-pr6381.patch 
45 Patch26:        gcc32-dwarf2-pr6436-test.patch
46 Patch27:        gcc32-fde-merge-compat.patch 
47 Patch28:        gcc32-fold-const-associate.patch
48 Patch29:        gcc32-hard-reg-sharing.patch
49 Patch30:        gcc32-hard-reg-sharing2.patch 
50 Patch31:        gcc32-i386-default-momit-leaf-frame-pointer.patch
51 Patch32:        gcc32-i386-memtest-test.patch 
52 Patch33:        gcc32-i386-no-default-momit-leaf-frame-pointer.patch
53 Patch34:        gcc32-i386-pic-label-thunk.patch
54 Patch35:        gcc32-i386-profile-olfp.patch
55 Patch36:        gcc32-inline-label.patch 
56 Patch37:        gcc32-java-no-rpath.patch
57 Patch38:        gcc32-pr6842.patch 
58 Patch39:        gcc32-sparc-sll1.patch
59 Patch40:        gcc32-test-rh65771.patch 
60 Patch41:        gcc32-test-rotate.patch  
61 Patch42:        gcc32-tls-dwarf2.patch 
62 Patch43:        gcc32-tls.patch      
63 Patch44:        gcc32-tls2.patch 
64 Patch45:        gcc32-tls3.patch
65 Patch46:        gcc32-tls4.patch 
66 Patch47:        gcc32-tls5.patch    
67 BuildRequires:  autoconf
68 BuildRequires:  bison
69 BuildRequires:  fileutils >= 4.0.41
70 BuildRequires:  gcc
71 %{!?_without_ada:BuildRequires: gcc-ada}
72 BuildRequires:  glibc-devel >= 2.2.5-20
73 BuildRequires:  perl-devel
74 BuildRequires:  texinfo >= 4.1
75 BuildRequires:  zlib-devel
76 BuildRequires:  gettext-devel
77 Requires:       binutils >= 2.12.90.0.4
78 Requires:       cpp = %{GCC_VERSION}
79 Requires:       libgcc = %{GCC_VERSION}
80 Conflicts:      glibc-devel < 2.2.5-20
81 URL:            http://gcc.gnu.org/
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _slibdir        /lib
85
86 %description
87 A compiler aimed at integrating all the optimizations and features
88 necessary for a high-performance and stable development environment.
89
90 %description -l pl
91 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
92 wyprodukowania szybkiego i stablinego kodu wynikowego.
93
94 %package -n libgcc
95 Summary:        Shared gcc library
96 Summary(pl):    Biblioteka gcc
97 Group:          Libraries
98 Version:        %{GCC_VERSION}
99
100 %description -n libgcc
101 Shared gcc library.
102
103 %description -n libgcc -l pl
104 Biblioteka dynamiczna gcc.
105
106 %package c++
107 Summary:        C++ support for gcc
108 Summary(pl):    Obs³uga C++ dla gcc
109 Group:          Development/Languages
110 Obsoletes:      egcc-c++
111 Obsoletes:      egcs-c++
112 Requires:       gcc = %{GCC_VERSION}
113
114 %description c++
115 This package adds C++ support to the GNU C compiler. It includes
116 support for most of the current C++ specification, including templates
117 and exception handling. It does not include a standard C++ library,
118 which is available separately.
119
120 %description c++ -l de
121 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
122 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
123 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
124 sie ist getrennt erhältlich.
125
126 %description c++ -l fr
127 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
128 support pour la plupart des spécifications actuelles de C++, dont les
129 modéles et la gestion des exceptions. Il ne comprend pas une
130 bibliothéque C++ standard, qui est disponible séparément.
131
132 %description c++ -l pl
133 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
134 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
135 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
136
137 %description c++ -l tr
138 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
139 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
140 C++ kitaplýðý bu pakette yer almaz.
141
142 %package objc
143 Summary:        Objective C support for gcc
144 Summary(de):    Objektive C-Unterstützung für gcc
145 Summary(fr):    Gestion d'Objective C pour gcc
146 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
147 Summary(tr):    gcc için Objective C desteði
148 Group:          Development/Languages
149 Obsoletes:      egcc-objc
150 Obsoletes:      egcs-objc
151 Requires:       libobjc = %{GCC_VERSION}
152 Requires:       gcc = %{GCC_VERSION}
153
154 %description objc
155 This package adds Objective C support to the GNU C compiler. Objective
156 C is a object oriented derivative of the C language, mainly used on
157 systems running NeXTSTEP. This package does not include the standard
158 objective C object library.
159
160 %description objc -l de
161 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
162 Objective C ist ein objektorientiertes Derivat von C, das zur
163 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
164 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
165
166 %description objc -l fr
167 Ce package ajoute un support Objective C au compilateur C GNU.
168 L'Objective C est un langage orienté objetdérivé du langage C,
169 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
170 pas la bibliothéque Objective C standard.
171
172 %description objc -l pl
173 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
174 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
175 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
176 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
177
178 %description objc -l tr
179 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
180 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
181 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
182 kitaplýðý bu pakette yer almaz.
183
184 %package -n libobjc
185 Summary:        Objective C Libraries
186 Summary(pl):    Biblioteki Obiektowego C
187 Group:          Libraries
188 Version:        %{GCC_VERSION}
189 Epoch:          3
190
191 %description -n libobjc
192 Objective C Libraries.
193
194 %description -n libobjc -l pl
195 Biblioteki Obiektowego C.
196
197 %package -n libobjc-static
198 Summary:        Static Objective C Libraries
199 Summary(pl):    Statyczne Biblioteki Obiektowego C
200 Group:          Development/Libraries
201 Version:        %{GCC_VERSION}
202 Epoch:          4
203 Requires:       libobjc = %{GCC_VERSION}
204
205 %description -n libobjc-static
206 Static Objective C Libraries.
207
208 %description -n libobjc-static -l pl
209 Statyczne biblioteki Obiektowego C.
210
211 %package g77
212 Summary:        Fortran 77 support for gcc
213 Summary(pl):    Obs³uga Fortranu 77 dla gcc
214 Group:          Development/Languages
215 Version:        %{GCC_VERSION}
216 Obsoletes:      egcs-g77
217 Requires:       libg2c = %{GCC_VERSION}
218
219 %description g77
220 This apckage adds support for compiling Fortran 77 programs with the
221 GNU compiler.
222
223 %description g77 -l pl
224 Ten pakiet dodaje obs³ugê Fortranu 77 do kompilatora gcc. Jest
225 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
226
227 %package -n libg2c
228 Summary:        Fortran 77 Libraries
229 Summary(pl):    Biblioteki Fortranu 77
230 Group:          Libraries
231 Version:        %{GCC_VERSION}
232
233 %description -n libg2c
234 Fortran 77 Libraries.
235
236 %description -n libg2c -l pl
237 Biblioteki Fortranu 77.
238
239 %package -n libg2c-static
240 Summary:        Static Fortran 77 Libraries
241 Summary(pl):    Statyczne Biblioteki Fortranu 77
242 Group:          Development/Libraries
243 Version:        %{GCC_VERSION}
244 Epoch:          2
245 Requires:       libg2c = %{GCC_VERSION}
246
247 %description -n libg2c-static
248 Static Fortran 77 Libraries.
249
250 %description -n libg2c-static -l pl
251 Statyczne biblioteki Fortranu 77.
252
253 %package java
254 Summary:        Java support for gcc
255 Summary(pl):    Obs³uga Javy dla gcc
256 Group:          Development/Languages
257 Version:        %{GCC_VERSION}
258 Requires:       %{name} = %{version}
259 Requires:       libgcj >= 3.0.0
260 Provides:       gcj = %{epoch}:%{GCC_VERSION}-%{release}
261 Provides:       jar = %{epoch}:%{GCC_VERSION}-%{release}
262
263 %description java
264 This package adds experimental support for compiling Java(tm) programs
265 and bytecode into native code. To use this you will also need the
266 libgcj package.
267
268 %description -l pl java
269 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
270 do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
271 by³o przeprowadziæ kompilacjê.
272
273 %package -n libgcj
274 Summary:        Java Class Libraries
275 Summary(pl):    Biblioteki Klas Javy
276 Group:          Libraries
277 Version:        %{GCC_VERSION}
278 Epoch:          2
279 Requires:       zlib
280
281 %description -n libgcj
282 Java Class Libraries.
283
284 %description -n libgcj -l pl
285 Biblioteki Klas Javy.
286
287 %package -n libgcj-devel
288 Summary:        Development files for Java Class Libraries
289 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
290 Group:          Development/Libraries
291 Version:        %{GCC_VERSION}
292 Epoch:          2
293 Requires:       libgcj = %{GCC_VERSION}
294 Requires:       %{name}-java
295
296 %description -n libgcj-devel
297 Development files for Java Class Libraries.
298
299 %description -n libgcj-devel -l pl
300 Pliki nag³ówkowe dla Bibliotek Klas Javy.
301
302 %package -n libgcj-static
303 Summary:        Static Java Class Libraries
304 Summary(pl):    Statyczne Biblioteki Klas Javy
305 Group:          Development/Libraries
306 Version:        %{GCC_VERSION}
307 Epoch:          2
308 Requires:       libstdc++-devel = %{GCC_VERSION}
309 Requires:       libgcj-devel = %{GCC_VERSION}
310
311 %description -n libgcj-static
312 Static Java Class Libraries.
313
314 %description -n libgcj-static -l pl
315 Statyczne Biblioteki Klas Javy.
316
317 %package -n libstdc++
318 Summary:        GNU c++ library
319 Summary(pl):    Biblioteki GNU C++ 
320 Group:          Libraries
321 Version:        %{GCC_VERSION}
322 Epoch:          1
323 Obsoletes:      libg++
324
325 %description -n libstdc++
326 This is the GNU implementation of the standard C++ libraries, along
327 with additional GNU tools. This package includes the shared libraries
328 necessary to run C++ applications.
329
330 %description -n libstdc++ -l de
331 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
332 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
333 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
334
335 %description -n libstdc++ -l fr
336 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
337 des outils GNU supplémentaires. Ce package comprend les librairies
338 partagées nécessaires à l'exécution d'application C++.
339
340 %description -n libstdc++ -l pl
341 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
342 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
343 uruchomienia aplikacji napisanych w C++.
344
345 %description -n libstdc++ -l tr
346 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
347 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
348
349 %package -n libstdc++-devel
350 Summary:        Header files and documentatino for C++ development
351 Summary(de):    Header-Dateien zur Entwicklung mit C++
352 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
353 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
354 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
355 Group:          Development/Libraries
356 Version:        %{GCC_VERSION}
357 Epoch:          1
358 Requires:       libstdc++ = %{GCC_VERSION}
359 Requires:       %{name}-c++
360 Obsoletes:      libg++-devel
361
362 %description -n libstdc++-devel
363 This is the GNU implementation of the standard C++ libraries. This
364 package includes the header files needed for C++ development and
365 library documentation.
366
367 %description -n libstdc++-devel -l pl
368 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
369 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
370 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
371
372 %package -n libstdc++-static
373 Summary:        Static C++ standard library
374 Summary(pl):    Statyczna biblioteka standardowa C++
375 Group:          Development/Libraries
376 Version:        %{GCC_VERSION}
377 Epoch:          1
378 Requires:       libstdc++-devel = %{GCC_VERSION}
379
380 %description -n libstdc++-static
381 Static C++ standard library.
382
383 %description -n libstdc++-static -l pl
384 Statycza biblioteka standardowa C++.
385
386 %package ada
387 Summary:        Ada support for gcc
388 Summary(pl):    Obs³uga Ady do gcc
389 Group:          Development/Languages
390 Version:        %{GCC_VERSION}
391 Requires:       libgnat = %{GCC_VERSION}
392 Requires:       gcc = %{GCC_VERSION}
393 Obsoletes:      gcc-gnat
394 Obsoletes:      gnat-devel
395
396 %description ada
397 This package adds experimental support for compiling Ada programs.
398
399 %description -l pl ada
400 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
401 w Adzie.
402
403 %package -n libgnat
404 Summary:        Ada standard libraries
405 Summary(pl):    Biblioteki standardowe dla Ady
406 Group:          Libraries
407 Version:        %{GCC_VERSION}
408 Obsoletes:      gnat
409
410 %description -n libgnat
411 This package contains shared libraries needed to run programs written
412 in Ada.
413
414 %description -n libgnat -l pl
415 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów napisanych
416 w Adzie.
417
418 %package -n libgnat-static
419 Summary:        Static Ada standard libraries
420 Summary(pl):    Statyczne biblioteki standardowe dla Ady
421 Group:          Libraries
422 Version:        %{GCC_VERSION}
423 Obsoletes:      gnat-static
424
425 %description -n libgnat-static
426 This package contains static libraries for programs written in Ada.
427
428 %description -n libgnat-static -l pl
429 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
430 Adzie.
431
432 %package ksi
433 Summary:        Ksi support for gcc
434 Summary(pl):    Obs³uga Ksi dla gcc
435 Version:        %{GCC_VERSION}.%{KSI_VERSION}
436 Group:          Development/Languages
437 Requires:       gcc = %{GCC_VERSION}
438
439 %description ksi
440 This package adds experimental support for compiling Ksi programs
441 into native code. You proabably don't need it, unless your are going
442 to develop a compiler using Ksi as intermediate representation or
443 you are using such compiler (like Gont).
444
445 %description ksi -l pl
446 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
447 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
448 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jako reprezentacji
449 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
450
451 %package -n cpp
452 Summary:        The C Pre Processor
453 Summary(pl):    Preprocesor C
454 Group:          Development/Languages
455 Version:        %{GCC_VERSION}
456 Obsoletes:      egcs-cpp
457 Obsoletes:      gcc-cpp
458
459 %description -n cpp
460 The C preprocessor is a "macro processor" that is used automatically
461 by the C compiler to transform your program before actual compilation.
462 It is called a macro processor because it allows you to define
463 "macros", which are brief abbreviations for longer constructs.
464
465 The C preprocessor provides four separate facilities that you can use
466 as you see fit:
467
468 - Inclusion of header files. These are files of declarations that can
469   be substituted into your program.
470 - Macro expansion. You can define "macros", which are abbreviations
471   for arbitrary fragments of C code, and then the C preprocessor will
472   replace the macros with their definitions throughout the program.
473 - Conditional compilation. Using special preprocessing directives, you
474   can include or exclude parts of the program according to various
475   conditions.
476 - Line control. If you use a program to combine or rearrange source
477   files into an intermediate file which is then compiled, you can use
478   line control to inform the compiler of where each source line
479   originally came from.
480
481 %description -n cpp -l pl
482 Przeprocesor C jest "makro procesorem" który jest automatycznie
483 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
484 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
485 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
486 d³ugich konstrukcji w jêzyku C.
487
488 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
489
490 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
491   deklaracji polecenia do³±czenia innego pliku.
492 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
493   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
494   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
495 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
496   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
497   fragmenty obrabianego strumienia tekstów.
498 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
499   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
500   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
501   odpowiada fragment pliku wynikowego.
502
503 %prep
504 %setup -q -a1 -n %{name}-%{GCC_VERSION}-%{SNAP}
505 mv ksi-%{KSI_VERSION} gcc/ksi
506
507 %patch0 -p1
508 %patch1 -p1
509 %patch2 -p1
510 %patch3 -p1
511 %patch4 -p1
512
513 %patch10 
514 %patch11 
515 %patch12 
516 %patch13 
517 %patch14 
518 %patch15 
519 %patch16 
520 %patch17 
521 %patch18 
522 %patch19 
523 %patch20 
524 %patch21 
525 %patch22 
526
527 %patch24 
528 %patch25 
529 %patch26 
530 %patch27 
531 %patch28 
532 %patch29 
533 %patch30 
534 %patch31 
535 %patch32 
536 %patch33 
537 %patch34 
538 %patch35 
539 %patch36 
540 %patch37 
541 %patch38 
542 %patch39 
543 %patch40 
544 %patch41 
545 %patch42 
546 %patch43
547 %patch44 
548 %patch45 
549 %patch46
550 %patch47
551
552 %patch6 -p1
553
554 %build
555 # cd gcc && autoconf; cd ..
556 # autoconf is not needed!
557 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform}
558
559 CFLAGS="%{rpmcflags}" \
560 CXXFLAGS="%{rpmcflags}" \
561 TEXCONFIG=false ../configure \
562         --prefix=%{_prefix} \
563         --infodir=%{_infodir} \
564         --mandir=%{_mandir} \
565         --enable-shared \
566         --enable-threads=posix \
567         --enable-__cxa_atexit \
568         --enable-languages="c,c++,f77,gcov,objc,ksi%{!?_without_ada:,ada}%{!?_without_java:,java}" \
569         --enable-c99 \
570         --enable-long-long \
571         --enable-multilib \
572         --enable-nls \
573         --with-gnu-as \
574         --with-gnu-ld \
575         --with-system-zlib \
576         --with-slibdir=%{_slibdir} \
577         --without-x \
578         %{_target_platform}
579
580 PATH=$PATH:/sbin:%{_sbindir}
581
582 # this dirty hack is relict of setting, where objdir is subdir of srcdir
583 %if %{!?_without_ada:1}%{?_without_ada:0}
584 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
585         gcc/ada/Makefile > makefile.tmp
586 mv -f makefile.tmp gcc/ada/Makefile
587 %endif
588
589 cd ..
590 %{__make} -C obj-%{_target_platform} bootstrap-lean \
591         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
592         mandir=%{_mandir} \
593         infodir=%{_infodir}
594
595 %if %{!?_without_ada:1}%{?_without_ada:0}
596 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
597         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
598         mandir=%{_mandir} \
599         infodir=%{_infodir}
600
601 # make Gnat Reference Manual
602 %{__make} -C obj-%{_target_platform}/gcc/ada doc
603 %endif
604
605 %install
606 rm -rf $RPM_BUILD_ROOT
607 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_infodir}}
608
609 cd obj-%{_target_platform}
610 PATH=$PATH:/sbin:%{_sbindir}
611
612 %{__make} install \
613         prefix=$RPM_BUILD_ROOT%{_prefix} \
614         mandir=$RPM_BUILD_ROOT%{_mandir} \
615         infodir=$RPM_BUILD_ROOT%{_infodir} \
616         slibdir=$RPM_BUILD_ROOT/lib
617
618 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
619 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
620
621 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
622 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
623
624 %if %{!?_without_ada:1}%{?_without_ada:0}
625 # move ada shared libraries to proper place...
626 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*-*so.1 \
627         $RPM_BUILD_ROOT%{_libdir}
628 rm -f $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so.1
629 (cd $RPM_BUILD_ROOT%{_libdir} && \
630  ln -s libgnat-*so.1 libgnat.so.1 && \
631  ln -s libgnarl-*so.1 libgnarl.so.1)
632 %endif
633
634 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
635
636 cd ..
637
638 %if %{!?_without_ada:1}%{?_without_ada:0}
639 install obj-%{_target_platform}/gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
640 install obj-%{_target_platform}/gcc/ada/gnat_ug_unx.info* $RPM_BUILD_ROOT%{_infodir}
641 %endif
642
643 %if %{!?_without_java:1}%{?_without_java:0}
644 install -d java-doc
645 cp -f libjava/doc/cni.sgml libjava/READ* java-doc
646 cp -f fastjar/README java-doc/README.fastjar
647 cp -f libffi/README java-doc/README.libffi
648 cp -f libffi/LICENSE java-doc/LICENSE.libffi
649
650 cp -f libobjc/README gcc/objc/README.libobjc
651 %endif
652
653 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
654 mv -f $RPM_BUILD_ROOT%{_mandir}/ja/man1/{cccp,cpp}.1
655
656 %find_lang %{name}
657 %find_lang libstdc\+\+
658
659 %clean
660 rm -rf $RPM_BUILD_ROOT
661
662 %post
663 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
664
665 %postun
666 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
667
668 %post g77
669 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
670
671 %postun g77
672 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
673
674 %post java
675 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
676
677 %postun java
678 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
679
680 %post ksi
681 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
682
683 %postun ksi
684 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
685
686 %post -n cpp
687 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
688
689 %postun -n cpp
690 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
691
692 %post   -p /sbin/ldconfig -n libgcc
693 %postun -p /sbin/ldconfig -n libgcc
694 %post   -p /sbin/ldconfig -n libstdc++
695 %postun -p /sbin/ldconfig -n libstdc++
696 %post   -p /sbin/ldconfig -n libobjc
697 %postun -p /sbin/ldconfig -n libobjc
698 %post   -p /sbin/ldconfig -n libg2c
699 %postun -p /sbin/ldconfig -n libg2c
700 %post   -p /sbin/ldconfig -n libgcj
701 %postun -p /sbin/ldconfig -n libgcj
702 %post   -p /sbin/ldconfig -n libgnat
703 %postun -p /sbin/ldconfig -n libgnat
704
705 %files -f %{name}.lang
706 %defattr(644,root,root,755)
707 %doc READ* ChangeLog
708 %dir %{_libdir}/gcc-lib
709 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
710 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
711 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
712 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
713 %attr(755,root,root) %{_bindir}/gcc
714 %attr(755,root,root) %{_bindir}/gccbug
715 %attr(755,root,root) %{_bindir}/gcov
716 %attr(755,root,root) %{_bindir}/cc
717
718 %{_mandir}/man1/gcc.1*
719 %{_mandir}/man1/cc.1*
720 %{_mandir}/man1/gcov.1*
721 %lang(fr) %{_mandir}/fr/man1/gcc.1*
722 %lang(ja) %{_mandir}/ja/man1/gcc.1*
723 %{_infodir}/gcc*
724
725 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
726 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
727 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
728 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
729 %ifarch ppc
730 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ecrt*.o
731 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ncrt*.o
732 %{_libdir}/gcc-lib/%{_target_cpu}*/*/nof
733 %dir %{_libdir}/nof
734 %endif
735 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
736 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
737
738 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
739 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
740 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
741 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
742 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
743 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
744 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
745 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
746 %ifarch %{ix86}
747 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
748 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
749 %endif
750 %ifarch ppc
751 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/altivec.h
752 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/ppc-asm.h
753 %endif
754
755 %files -n libgcc
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_slibdir}/lib*.so*
758
759 %files c++
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_bindir}/g++
762 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
763 %attr(755,root,root) %{_bindir}/c++
764 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
765 %attr(755,root,root) %{_bindir}/c++filt
766 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
767 %attr(755,root,root) %{_libdir}/libsupc++.la
768 %ifarch ppc
769 %attr(755,root,root) %{_libdir}/nof/libsupc++.la
770 %{_libdir}/nof/libsupc++.a
771 %endif
772 %{_libdir}/libsupc++.a
773 %{_mandir}/man1/g++.1*
774 %lang(es) %{_mandir}/es/man1/c++filt.1*
775 %lang(ja) %{_mandir}/ja/man1/g++.1*
776
777 %files -n libstdc++ -f libstdc++.lang
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
780 %ifarch ppc
781 %attr(755,root,root) %{_libdir}/nof/libstdc++.so.*.*.*
782 %endif
783
784 %files -n libstdc++-devel
785 %defattr(644,root,root,755)
786 %doc libstdc++-v3/docs/html
787 %dir %{_includedir}/c++
788 %{_includedir}/c++/%{GCC_VERSION}
789 %attr(755,root,root) %{_libdir}/libstdc++.so
790 %attr(755,root,root) %{_libdir}/libstdc++.la
791 %ifarch ppc
792 %attr(755,root,root) %{_libdir}/nof/libstdc++.so
793 %attr(755,root,root) %{_libdir}/nof/libstdc++.la
794 %endif
795
796 %files -n libstdc++-static
797 %defattr(644,root,root,755)
798 %{_libdir}/libstdc++.a
799 %ifarch ppc
800 %{_libdir}/nof/libstdc++.a
801 %endif
802
803 %files objc
804 %defattr(644,root,root,755)
805 %doc gcc/objc/READ*
806 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
807 %attr(755,root,root) %{_libdir}/libobjc.so
808 %attr(755,root,root) %{_libdir}/libobjc.la
809 %ifarch ppc
810 %attr(755,root,root) %{_libdir}/nof/libobjc.so
811 %attr(755,root,root) %{_libdir}/nof/libobjc.la
812 %endif
813 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
814
815 %files -n libobjc
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
818 %ifarch ppc
819 %attr(755,root,root) %{_libdir}/nof/libobjc.so.*.*.*
820 %endif
821
822 %files -n libobjc-static
823 %defattr(644,root,root,755)
824 %{_libdir}/libobjc.a
825 %ifarch ppc
826 %{_libdir}/nof/libobjc.a
827 %endif
828
829 %files g77
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_bindir}/g77
832 %attr(755,root,root) %{_bindir}/f77
833 %{_infodir}/g77*
834 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
835 %{_libdir}/libfrtbegin.a
836 %attr(755,root,root) %{_libdir}/libg2c.la
837 %attr(755,root,root) %{_libdir}/libg2c.so
838 %ifarch ppc
839 %{_libdir}/nof/libfrtbegin.a
840 %attr(755,root,root) %{_libdir}/nof/libg2c.la
841 %attr(755,root,root) %{_libdir}/nof/libg2c.so
842 %endif
843 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
844 %{_mandir}/man1/g77.1*
845 %{_mandir}/man1/f77.1*
846 %lang(ja) %{_mandir}/ja/man1/g77.1*
847 %lang(ja) %{_mandir}/ja/man1/f77.1*
848
849 %files -n libg2c
850 %defattr(644,root,root,755)
851 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
852 %ifarch ppc
853 %attr(755,root,root) %{_libdir}/nof/libg2c.so.*.*.*
854 %endif
855
856 %files -n libg2c-static
857 %{_libdir}/libg2c.a
858 %ifarch ppc
859 %{_libdir}/nof/libg2c.a
860 %endif
861
862 %if %{!?_without_java:1}%{?_without_java:0}
863 %files java
864 %defattr(644,root,root,755)
865 %doc java-doc/*
866 %attr(755,root,root) %{_bindir}/gcj*
867 %attr(755,root,root) %{_bindir}/gij
868 %attr(755,root,root) %{_bindir}/jcf-dump
869 %attr(755,root,root) %{_bindir}/jv-*
870 %attr(755,root,root) %{_bindir}/rmi*
871 %attr(755,root,root) %{_bindir}/jar
872 %attr(755,root,root) %{_bindir}/grepjar
873 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
874 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
875 %{_infodir}/gcj*
876 %{_mandir}/man1/jcf-*
877 %{_mandir}/man1/jv-*
878 %{_mandir}/man1/gij*
879 %{_mandir}/man1/gcj*
880 %{_mandir}/man1/rmi*
881
882 %files -n libgcj
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_bindir}/addr2name.awk
885 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
886 %ifarch ppc
887 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so.*
888 %endif
889
890 %files -n libgcj-devel
891 %defattr(644,root,root,755)
892 %{_includedir}/java
893 %{_includedir}/javax
894 %{_includedir}/org
895 %{_includedir}/gcj
896 %{_includedir}/j*.h
897 %{_includedir}/gnu/*
898 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/gcj
899 %{_libdir}/security/*
900 %dir %{_datadir}/java
901 %{_datadir}/java/libgcj*.jar
902 %{_libdir}/lib*cj.spec
903 %attr(755,root,root) %{_libdir}/lib*cj*.la
904 %attr(755,root,root) %{_libdir}/lib*cj*.so
905 %ifarch ppc
906 %{_libdir}/nof/lib*cj.spec
907 %attr(755,root,root) %{_libdir}/nof/lib*cj*.la
908 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so
909 %endif
910
911 %files -n libgcj-static
912 %defattr(644,root,root,755)
913 %{_libdir}/lib*cj*.a
914 %ifarch ppc
915 %{_libdir}/nof/lib*cj*.a
916 %endif
917 %endif
918
919 %if %{!?_without_ada:1}%{?_without_ada:0}
920 %files ada
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
923 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
924 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
925 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
926 %ifnarch ppc
927 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
928 %endif
929 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
930 %attr(755,root,root) %{_bindir}/gnat*
931 %{_infodir}/gnat*
932 %attr(755,root,root) %{_libdir}/libgnat.so.1
933 %attr(755,root,root) %{_libdir}/libgnarl.so.1
934
935 %files -n libgnat
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/libgna*-*so.1
938
939 %files -n libgnat-static
940 %defattr(644,root,root,755)
941 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgna*.a
942 %endif
943
944 %files ksi
945 %defattr(644,root,root,755)
946 %doc gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
947 %{_infodir}/ksi*
948 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
949
950 %files -n cpp
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_slibdir}/cpp
953 %attr(755,root,root) %{_bindir}/cpp
954 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
955 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
956 %{_mandir}/man1/cpp.1*
957 %lang(ja) %{_mandir}/ja/man1/cpp.1*
958 %{_infodir}/cpp*
This page took 0.124759 seconds and 4 git commands to generate.