]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- added some missing %attr on executables.
[packages/gcc4.git] / gcc4.spec
1 Summary:     GNU C Compiler
2 Summary(de): GNU-C-Compiler 
3 Summary(fr): Compilateur C de GNU
4 Summary(pl): Kompilator GNU C
5 Summary(tr): GNU C derleyicisi
6 Name:        gcc
7 Version:     2.7.2.3
8 Release:     15
9 Copyright:   GPL
10 Group:       Development/Languages
11 Source:      ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Patch1:      gcc-2.7.2-make.patch
13 Patch2:      gcc-2.7.2.sparc.patch
14 Patch3:      ftp://atheist.tamu.edu/pub/richard/linux/axp/rth-gcc-2.7.2-960814.diff.gz
15 Patch4:      gcc-2.7.2-pg.patch
16 Patch5:      gcc-2.7.2-flow.patch
17 Patch6:      ftp://ftp.redhat.com/pub/alphabits/rth-gcc-2.7.2-961121.diff.gz
18 Patch7:      gcc-2.7.2.sparc.patch2
19 Patch8:      gcc-2.7.2.3-glibc2.patch
20 Patch9:      gcc-2.7.2-alpha-ra.patch
21 Requires:    binutils
22 Prereq:      /sbin/install-info
23 Buildroot:   /tmp/%{name}-%{version}-root
24 Exclusivearch: i386
25
26 %description
27 The GNU C compiler -- a full featured ANSI C compiler, with support
28 for K&R C as well. GCC provides many levels of source code error
29 checking tradionaly provided by other tools (such as lint), produces
30 debugging information, and can perform many different optimizations to
31 the resulting object code.
32
33 %description -l de
34 Der GNU-C-Compiler, ein ANSI-C-Compiler mit komplettem Funktions-
35 umfang sowie Unterstützung für K&R. GCC bietet viele Ebenen der
36 Quell-Code-Fehlerprüfung, wie sie früher durch separate Tools bereitgestellt
37 wurde (etwa lint), produziert Debug-Infos und ist in der Lage, viele
38 verschiedene Optimierungen am resultierenden Objektcode auszuführen. 
39
40 %description -l fr
41 Le compilateur C GNU -- un compilateur C ANSI complet, avec un support
42 pour la norme K&R. GCC fournit de nombreux niveaux d'erreurs donnés par
43 des outils extérieurs (comme lint), produit des informations de débogage,
44 et peut réaliser différentes optimisations sur le code objet produit.
45
46 %description -l pl
47 Kompilator GNU C jest pe³nowartosciowym kompilatorem ANSI C akceptuj±cym
48 tak¿e K&R C. GCC udostêpnia wielopoziomowe sprawdzanie i raportowanie
49 b³êdów na poziomie kodu ¼ród³owego w C jakie udostêpniaj± inne narzêdzia jak
50 np. lint. GCC Umo¿liwia tak¿e wygenerowanie kodu wynikowego z informacjami
51 do debugera, a tak¿e umo¿liwia generowanie zoptymalizowanego kodu
52 wynikowego.
53
54 %description -l tr
55 GNU C derleyicisi, K&R C desteði olan ve ANSI C'nin bütün özelliklerine sahip
56 bir derleyicidir. Normalde baþka araçlarýn (örneðin lint) yaptýðý kaynak kodu
57 düzeyindeki pek çok hata denetimini gerçekleþtirir, hata ayýklama bilgisi
58 üretebilir ve sonuç olarak ortaya çýkan ara kod üzerinde birçok optimizasyon
59 uygulayabilir.
60
61 %prep
62 %setup -q
63 %patch1 -p1 -b .rh
64
65 %ifarch sparc alpha
66 %patch2 -p1
67 %patch3 -p1
68 %patch4 -p0
69 %patch5 -p1
70 %patch6 -p1
71 %patch7 -p1
72 %patch8 -p1 -b .glibc2
73 %patch9 -p0 -b .alphara
74 %endif
75
76 %build
77 ./configure --prefix=/usr \
78         --local-prefix=/usr/local --gxx-include-dir=/usr/include/g++ \
79         ${RPM_ARCH}-pld-linux
80
81 make LANGUAGES=c CFLAGS="-O2"
82 make stage1
83 make CC="stage1/xgcc -Bstage1/" CFLAGS="-O2" LDFLAGS="-s"
84 make stage2
85 make CC="stage2/xgcc -Bstage2/" CFLAGS="-O2" LDFLAGS="-s"
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT/usr/{bin,lib,info,man}
90 make CC="stage2/xgcc -Bstage2/" CFLAGS="-O2" LDFLAGS="-s" install \
91         prefix=$RPM_BUILD_ROOT/usr
92
93 gzip -n -9f $RPM_BUILD_ROOT/usr/info/gcc.info*
94 ln -sf gcc $RPM_BUILD_ROOT/usr/bin/cc
95 rm -rf $RPM_BUILD_ROOT/usr/lib/gcc-lib/${RPM_ARCH}/*/include/objc
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 /sbin/install-info /usr/info/gcc.info.gz /usr/info/dir --entry="* gcc: (gcc).                   The GNU C compiler."
102
103 %preun
104 if [ $1 = 0 ]; then
105     /sbin/install-info --delete /usr/info/gcc.info.gz /usr/info/dir --entry="* gcc: (gcc).                   The GNU C compiler."
106 fi
107
108 %files
109 %defattr(644, root, root, 755)
110 %doc NEWS PROBLEMS
111 %attr(755, root, root) /usr/bin/gcc
112 %attr(755, root, root) /usr/bin/cc
113 %attr(755, root, root) /usr/bin/*-gcc
114 /usr/man/man1/gcc.1
115 /usr/info/gcc.info*
116 %dir /usr/lib/gcc-lib/*/*
117 %dir /usr/lib/gcc-lib/*/*/include
118 /usr/lib/gcc-lib/*/*/SYSCALLS.c.X
119 %attr(755, root, root) /usr/lib/gcc-lib/*/*/cc1
120 %attr(755, root, root) /usr/lib/gcc-lib/*/*/cpp
121 /usr/lib/gcc-lib/*/*/libgcc.a
122 /usr/lib/gcc-lib/*/*/specs
123 /usr/lib/gcc-lib/*/*/include/*
124 /usr/lib/gcc-lib/*/*/*.o
125
126 %changelog
127 * Sun Sep 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
128   [2.7.2.3-15]
129 - added full %attr description in %files,
130 - fiew simplifications in %install and %files.
131
132 * Wed Sep  2 1998 Jeff Johnson <jbj@redhat.com>
133 - eliminate gcc on sparc in RH5.2; sparclinux-2.0-980805 works with egcs.
134
135 * Mon Jul 13 1998 Jeff Johnson <jbj@redhat.com>
136 - sparc gets gcc/cc from egcs. someday ((after RH-5.2) i386 will too.
137
138 * Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
139 - resurrect gcc for sparc kernel compiles.
140
141 * Thu May 07 1998 Prospector System <bugs@redhat.com>
142 - translations modified for de, fr, tr
143
144 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
145 - use extensively CFLAGS="-O2" when building the compiler (this is known to
146   help the fully compatible Cyrix chips (sic!) to run this beast)
147
148 * Mon Apr 20 1998 Cristian Gafton <gafton@redhat.com>
149 - better yet, ExclusiveArch: i386 is in effect
150
151 * Tue Apr 14 1998 Cristian Gafton <gafton@redhat.com>
152 - removed the c++ package as we are switching to egcs-c++
153 - idem for objc
154 - added buildroot
155 - alpha is exlcuded from the build. I don't know about sparc yet, so I leave
156   it for this time
157
158 * Fri Oct 23 1997 Erik Troan <ewt@redhat.com>
159 - use ld-linux.so.2 on the sparc
160
161 * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
162 - build crtbegin* and crtend* on the sparc
163
164 * Mon Sep 29 1997 Erik Troan <ewt@redhat.com>
165 - added patch from rth to fix dump on alpha w/ building libg++
166
167 * Sun Sep 28 1997 Erik Troan <ewt@redhat.com>
168 - djb really made the crtbegin/end stuff in gcc-c-skel conditional on
169   running on an i386 machine, not a !sparc machine; all changed was his
170   comment
171 - added patch to use /lib/ld-linux.so.2 on the alpha
172
173 * Tue Sep 23 1997 Richard Henderson <rth@cygnus.com>
174 - Killed the glibc.patch and added sparc.patch2 to _really_ make
175   libgcc.a be compiled with -fPIC.
176
177 * Fri Sep 19 1997 Donald Barnes <djb@redhat.com>
178 - added the glibc.patch so that libgcc.a is compiled with -fPIC
179 - added %ifarch i386 around crtbegin/end in gcc-c-skel
180
181 * Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
182 - modified to use install-info
183
184 * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
185 - updated to gcc 2.7.2.3
186
187 * Thu Aug 21 1997 Erik Troan <ewt@redhat.com>
188 - fixed /lib/cpp patch to include redhat element
189
190 * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
191 - removed HJ's patch
192 - added patch from Ulrich Drepper to generate crt*.o
This page took 0.086375 seconds and 3 git commands to generate.