]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- release 18
[packages/gcc4.git] / gcc4.spec
1 %define         STDC_VERSION 2.10.0
2 %define         ver 2.95.3
3 Summary:        GNU Compiler Collection
4 Summary(pl):    Kolekcja kompilatorów GNU
5 Name:           gcc
6 Version:        %{ver}
7 Release:        18
8 License:        GPL
9 Group:          Development/Languages
10 Group(de):      Entwicklung/Sprachen
11 Group(pl):      Programowanie/Jêzyki
12 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}-prerelease/%{name}-%{version}.test1.tar.gz
13 Source1:        gcov.1
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-pld-linux.patch
16 Patch2:         %{name}-libstdc++.patch
17 Patch3:         %{name}-bootstrap.patch
18 Patch4:         %{name}-cpp-macro-doc.patch
19 Patch5:         %{name}-default-arch.patch
20 Patch6:         %{name}-cvs-updates-20000826.patch.gz
21 Patch7:         %{name}-libstdc++-out-of-mem.patch
22 Patch8:         %{name}-libstdc++-wstring.patch
23 Patch9:         %{name}-libstdc++-wall3.patch
24 Patch10:        %{name}-libstdc++-bastring.patch
25 Patch11:        %{name}-manpage.patch
26 Patch12:        %{name}-cpp-dos-newlines.patch
27 Patch13:        %{name}-gpc.patch
28 Patch14:        %{name}-arm-config.patch
29 Patch15:        %{name}-m68k-pic.patch
30 Patch16:        %{name}-sparc32-rfi.patch
31 Patch17:        %{name}-builtin-apply.patch
32 Patch18:        %{name}-gcj-backport.patch
33 Patch19:        %{name}-ppc-ice.patch
34 Patch20:        %{name}-ppc-descriptions.patch
35 Patch21:        %{name}-ppc-andrew-dwarf-eh.patch
36
37 Patch22:        %{name}-alpha-complex-float.patch
38 Patch23:        %{name}-emit-rtl.patch
39 Patch24:        %{name}-gcj-vs-iconv.patch
40 Patch25:        %{name}-libobjc.patch
41 Patch26:        %{name}-pointer-arith.patch
42
43 Patch27:        %{name}-glibc-2.2.patch
44 Patch28:        %{name}-O2-bug.patch
45
46 BuildRequires:  bison
47 BuildRequires:  texinfo
48 Requires:       binutils >= 2.9.1.0.25
49 Requires:       cpp = %{version}
50 URL:            http://gcc.gnu.org/
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 A compiler aimed at integrating all the optimizations and features
55 necessary for a high-performance and stable development environment.
56
57 %description -l pl
58 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
59 wyprodukowania szybkiego i stablinego kodu wynikowego.
60
61 %package c++
62 Summary:        C++ support for gcc
63 Summary(fr):    Support C++ pour le compilateur gcc
64 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
65 Summary(tr):    gcc için C++ desteði
66 Group:          Development/Languages
67 Group(de):      Entwicklung/Sprachen
68 Group(pl):      Programowanie/Jêzyki
69 Obsoletes:      egcc-c++
70 Obsoletes:      egcs-c++
71
72 %description c++
73 This package adds C++ support to the GNU C compiler. It includes
74 support for most of the current C++ specification, including templates
75 and exception handling. It does not include a standard C++ library,
76 which is available separately.
77
78 %description -l de c++
79 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
80 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
81 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
82 sie ist getrennt erhältlich.
83
84 %description -l fr c++
85 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
86 support pour la plupart des spécifications actuelles de C++, dont les
87 modéles et la gestion des exceptions. Il ne comprend pas une
88 bibliothéque C++ standard, qui est disponible séparément.
89
90 %description -l pl c++
91 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
92 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
93 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
94
95 %description -l tr c++
96 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
97 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
98 C++ kitaplýðý bu pakette yer almaz.
99
100 %package objc
101 Summary:        Objective C support for gcc
102 Summary(de):    Objektive C-Unterstützung für gcc
103 Summary(fr):    Gestion d'Objective C pour gcc
104 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
105 Summary(tr):    gcc için Objective C desteði
106 Group:          Development/Languages
107 Group(de):      Entwicklung/Sprachen
108 Group(pl):      Programowanie/Jêzyki
109 Obsoletes:      egcc-objc
110 Obsoletes:      egcs-objc
111
112 %description objc
113 This package adds Objective C support to the GNU C compiler. Objective
114 C is a object oriented derivative of the C language, mainly used on
115 systems running NeXTSTEP. This package does not include the standard
116 objective C object library.
117
118 %description -l de objc
119 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
120 Objective C ist ein objektorientiertes Derivat von C, das zur
121 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
122 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
123
124 %description -l fr objc
125 Ce package ajoute un support Objective C au compilateur C GNU.
126 L'Objective C est un langage orienté objetdérivé du langage C,
127 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
128 pas la bibliothéque Objective C standard.
129
130 %description -l pl objc
131 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
132 pakiecie nie ma jeszcze bibliotek C-obj.
133
134 %description -l tr objc
135 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
136 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
137 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
138 kitaplýðý bu pakette yer almaz.
139
140 %package g77
141 Summary:        Fortran 77 support for gcc
142 Summary(pl):    Wspomaganie Fortran 77 dla gcc
143 Group:          Development/Languages
144 Group(de):      Entwicklung/Sprachen
145 Group(pl):      Programowanie/Jêzyki
146 Obsoletes:      egcs-g77
147
148 %description g77
149 This apckage adds support for compiling Fortran 77 programs with the
150 GNU compiler.
151
152 %description -l pl g77
153 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
154 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
155
156 %package chill
157 Summary:        CHILL support for gcc
158 Summary(pl):    Wspomoganie CHILL dla gcc
159 Group:          Development/Languages
160 Group(de):      Entwicklung/Sprachen
161 Group(pl):      Programowanie/Jêzyki
162 Requires:       %{name} = %{version}
163
164 %description chill
165 This package adds support for compiling CHILL programs with the GNU
166 compiler.
167
168 Chill is the "CCITT High-Level Language", where CCITT is the old name
169 for what is now ITU, the International Telecommunications Union. It is
170 is language in the Modula2 family, and targets many of the same
171 applications as Ada (especially large embedded systems). Chill was
172 never used much in the United States, but is still being used in
173 Europe, Brazil, Korea, and other places.
174
175 %package java
176 Summary:        Java support for gcc
177 Summary(pl):    Wspomoganie Java dla gcc
178 Group:          Development/Languages
179 Group(de):      Entwicklung/Sprachen
180 Group(pl):      Programowanie/Jêzyki
181 Requires:       %{name} = %{version}
182 Requires:       libgcj >= 2.95.1
183
184 %description java
185 This package adds experimental support for compiling Java(tm) programs
186 and bytecode into native code. To use this you will also need the
187 libgcj package.
188
189 %package -n libstdc++
190 Summary:        GNU c++ library
191 Summary(pl):    Biblioteki GNU C++ 
192 Group:          Libraries
193 Group(de):      Libraries
194 Group(fr):      Librairies
195 Group(pl):      Biblioteki
196 Version:        %{STDC_VERSION}
197 Obsoletes:      libg++
198
199 %description -n libstdc++
200 This is the GNU implementation of the standard C++ libraries, along
201 with additional GNU tools. This package includes the shared libraries
202 necessary to run C++ applications.
203
204 %description -l de -n libstdc++
205 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
206 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
207 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
208
209 %description -l fr -n libstdc++
210 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
211 des outils GNU supplémentaires. Ce package comprend les librairies
212 partagées nécessaires à l'exécution d'application C++.
213
214 %description -l pl -n libstdc++  
215 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
216 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
217 uruchomienia aplikacji napisanych w C++.
218
219 %description -l tr -n libstdc++
220 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
221 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
222
223 %package -n libstdc++-devel
224 Summary:        Header files and libraries for C++ development
225 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
226 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
227 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
228 Group:          Development/Libraries
229 Group(de):      Entwicklung/Libraries
230 Group(fr):      Development/Librairies
231 Group(pl):      Programowanie/Biblioteki
232 Version:        %{STDC_VERSION}
233 Requires:       libstdc++ = %{STDC_VERSION}
234 Requires:       %{name}-c++
235 Obsoletes:      libg++-devel
236
237 %description -n libstdc++-devel
238 This is the GNU implementation of the standard C++ libraries. This
239 package includes the header files and libraries needed for C++
240 development.
241
242 %description -l pl -n libstdc++-devel
243 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
244 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
245 programowaniu w jêzyku C++.
246
247 %package -n libstdc++-static
248 Summary:        Static c++ standard library
249 Summary(pl):    Biblioeka statyczna c++
250 Group:          Development/Libraries
251 Group(de):      Entwicklung/Libraries
252 Group(fr):      Development/Librairies
253 Group(pl):      Programowanie/Biblioteki
254 Version:        %{STDC_VERSION}
255 Requires:       libstdc++-devel = %{STDC_VERSION}
256
257 %description -n libstdc++-static
258 Static c++ standard library.
259
260 %description -l pl -n libstdc++-static
261 Biblioteka statyczna C++.
262
263 %package -n cpp
264 Summary:        The C Pre Processor
265 Summary(pl):    Preprocesor C
266 Group:          Development/Languages
267 Group(de):      Entwicklung/Sprachen
268 Group(pl):      Programowanie/Jêzyki
269 Obsoletes:      egcs-cpp
270
271 %description -n cpp
272 The C preprocessor is a "macro processor" that is used automatically
273 by the C compiler to transform your program before actual compilation.
274 It is called a macro processor because it allows you to define
275 "macros", which are brief abbreviations for longer constructs.
276
277 The C preprocessor provides four separate facilities that you can use
278 as you see fit:
279
280 - Inclusion of header files. These are files of declarations that can
281   be substituted into your program.
282 - Macro expansion. You can define "macros", which are abbreviations
283   for arbitrary fragments of C code, and then the C preprocessor will
284   replace the macros with their definitions throughout the program.
285 - Conditional compilation. Using special preprocessing directives, you
286   can include or exclude parts of the program according to various
287   conditions.
288 - Line control. If you use a program to combine or rearrange source
289   files into an intermediate file which is then compiled, you can use
290   line control to inform the compiler of where each source line
291   originally came from.
292
293 %description -l pl -n cpp
294 Przeprocesor C jest "makro procesorem" który jest automatycznie
295 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
296 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
297 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
298 d³ugich konstrukcji w jêzyku C.
299
300 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
301
302 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
303   deklaracji polecenia do³±czenia innego pliku.
304 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
305   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
306   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
307 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
308   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
309   fragmenty obrabianego strumienia tekstów.
310 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
311   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
312   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
313   odpowiada fragment pliku wynikowego.
314
315 %prep
316 %setup -q -n %{name}-%{ver}.test1
317 %patch0 -p1
318 %patch1 -p1
319 %patch2 -p1
320 %patch3 -p1
321 %patch4 -p0
322 %patch5 -p0
323 #%patch6 -p1
324 %patch7 -p0
325 %patch8 -p0
326 #%patch9 -p0
327 %patch10 -p0
328 %patch11 -p0
329 %patch12 -p0
330 %patch13 -p1
331 #%ifarch arm
332 #%patch14 -p0
333 #%endif
334 %ifarch m68k
335 %patch15 -p0
336 %endif
337 %ifarch sparc sparc32
338 %patch16 -p0
339 %patch17 -p0
340 %patch18 -p1
341 %endif
342 %ifarch ppc
343 %patch19 -p0
344 %patch20 -p0
345 #%patch21 -p0
346 %endif
347 %ifarch alpha
348 %patch22 -p1
349 %endif
350 #%patch23 -p0
351 %patch24 -p0
352 %patch25 -p0
353 %patch26 -p0
354 #%patch27 -p1
355 #%patch28 -p1
356
357 %build
358 (cd gcc; autoconf)
359 rm -rf obj-%{_target_platform}
360 install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
361
362 CFLAGS="%{?debug:-O -g}%{!?debug:$RPM_OPT_FLAGS}" \
363 CXXFLAGS="%{?debug:-O -g}%{!?debug:$RPM_OPT_FLAGS}" \
364 TEXCONFIG=false ../configure \
365         --prefix=%{_prefix} \
366         --infodir=%{_infodir} \
367         --enable-shared \
368 %ifnarch sparc sparc64
369         --enable-threads \
370         --enable-haifa \
371 %endif
372         --with-gnu-as \
373         --with-gnu-ld \
374         --with-gxx-include-dir="\$\{prefix\}/include/g++" \
375         --disable-nls \
376         %{_target_platform}
377
378 PATH=$PATH:/sbin:%{_sbindir}
379 touch  ../gcc/c-gperf.h
380
381 cd ..
382 %{__make} -C obj-%{_target_platform} bootstrap \
383         LDFLAGS_FOR_TARGET="%{!?debug:-s}" \
384         mandir=%{_mandir} \
385         infodir=%{_infodir}
386
387 %install
388 rm -rf $RPM_BUILD_ROOT
389 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
390
391 cd obj-%{_target_platform}
392 PATH=$PATH:/sbin:%{_sbindir}
393
394 %{__make} install \
395         prefix=$RPM_BUILD_ROOT%{_prefix} \
396         mandir=$RPM_BUILD_ROOT%{_mandir} \
397         infodir=$RPM_BUILD_ROOT%{_infodir}
398
399 %{__make} install \
400         prefix=$RPM_BUILD_ROOT%{_prefix} \
401         mandir=$RPM_BUILD_ROOT%{_mandir} \
402         infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
403
404 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
405
406 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
407 echo .so cccp.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1
408 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
409
410 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
411 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
412 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
413
414 gzip -9nf ../READ* ../ChangeLog ../gcc/ch/chill.brochure
415
416 %post
417 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
418
419 %postun
420 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421
422 %post g77
423 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
424
425 %postun g77
426 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
427
428 %post chill
429 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
430
431 %postun chill
432 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
433
434 %post -n cpp
435 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
436
437 %postun -n cpp
438 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
439
440 %post   -p /sbin/ldconfig -n libstdc++
441 %postun -p /sbin/ldconfig -n libstdc++
442
443 %clean
444 rm -rf $RPM_BUILD_ROOT
445
446 %files
447 %defattr(644,root,root,755)
448 %doc READ* ChangeLog.gz
449
450 %dir %{_libdir}/gcc-lib
451 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
452 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
453 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
454
455 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
456 %attr(755,root,root) %{_bindir}/gcc
457 %attr(755,root,root) %{_bindir}/gcov
458 %attr(755,root,root) %{_bindir}/protoize
459 %attr(755,root,root) %{_bindir}/unprotoize
460 %attr(755,root,root) %{_bindir}/cc
461
462 %{_mandir}/man1/gcc.1*
463 %{_mandir}/man1/gcov.1*
464 %{_infodir}/gcc*
465
466 %{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
467 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
468 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
469 %{_libdir}/gcc-lib/%{_target_cpu}*/*/lib*.map
470 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
471
472 %ifnarch alpha
473 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
474 %endif
475
476 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
477
478 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
479 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
480 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
481 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
482 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
483 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
484 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
485 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
486 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/va-*.h
487 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
488
489 %files c++
490 %defattr(644,root,root,755)
491
492 %{_mandir}/man1/g++.1.gz
493
494 %attr(755,root,root) %{_bindir}/g++
495 %attr(755,root,root) %{_bindir}/c++
496 %attr(755,root,root) %{_bindir}/c++filt
497 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
498
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/exception
500 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new
501 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/typeinfo
502 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new.h
503
504 %files objc
505 %defattr(644,root,root,755)
506
507 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
508
509 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
510 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
511
512 %files g77
513 %defattr(644,root,root,755)
514
515 %attr(755,root,root) %{_bindir}/g77
516 %attr(755,root,root) %{_bindir}/f77
517
518 %{_infodir}/g77*
519
520 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
521 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
522
523 %{_mandir}/man1/g77.1*
524 %{_mandir}/man1/f77.1*
525
526 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
527
528 %files chill
529 %defattr(644,root,root,755)
530 %doc gcc/ch/chill.brochure.gz
531
532 %attr(755,root,root) %{_bindir}/chill
533
534 %{_infodir}/chill*
535
536 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
537 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
538 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
539
540 %files java
541 %defattr(644,root,root,755)
542
543 %attr(755,root,root) %{_bindir}/gcj
544 %attr(755,root,root) %{_bindir}/gcjh
545 %attr(755,root,root) %{_bindir}/jcf-dump
546 %attr(755,root,root) %{_bindir}/jv-scan
547
548 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
549 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
550
551 %files -n libstdc++
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
554
555 %files -n libstdc++-devel
556 %defattr(644,root,root,755)
557 %{_includedir}/g++
558 %attr(755,root,root) %{_libdir}/libstdc++.so
559
560 %files -n libstdc++-static
561 %defattr(644,root,root,755)
562 %attr(644,root,root) %{_libdir}/libstdc++.a
563
564 %files -n cpp
565 %defattr(644,root,root,755)
566 %attr(755,root,root) /lib/cpp
567 %attr(755,root,root) %{_bindir}/cpp
568 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
569
570 %{_mandir}/man1/cpp.1*
571 %{_mandir}/man1/cccp.1*
572 %{_infodir}/cpp.info*.gz
This page took 0.994007 seconds and 3 git commands to generate.