]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- better way of generating ada info
[packages/gcc4.git] / gcc4.spec
1 %define         DASHED_SNAP     2002-04-23
2 %define         SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
3 %define         GCC_VERSION     3.1
4 %define         STDC_VERSION    4.0.0
5 %define         OBJC_VERSION    1.0.0
6 %define         GCJ_VERSION     3.1
7 %define         KSI_VERSION     pre48
8 Summary:        GNU Compiler Collection
9 Summary(pl):    Kolekcja kompilatorów GNU
10 Name:           gcc
11 Version:        %{GCC_VERSION}
12 Release:        0.%{SNAP}.0
13 License:        GPL
14 Group:          Development/Languages
15 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/%{DASHED_SNAP}/%{name}-%{GCC_VERSION}-%{SNAP}.tar.bz2
16 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
17 Patch0:         %{name}-slibdir.patch
18 Patch1:         %{name}-paths.patch
19 Patch2:         %{name}-ada-no-addr2line.patch
20 Patch3:         %{name}-ada-no-prefix.o.patch
21 Patch4:         %{name}-ppc-ada-hack.patch
22 BuildRequires:  bison
23 BuildRequires:  texinfo >= 4.1
24 BuildRequires:  zlib-devel
25 BuildRequires:  fileutils >= 4.0.41
26 BuildRequires:  autoconf
27 BuildRequires:  gcc
28 BuildRequires:  gcc-ada
29 BuildRequires:  perl-devel
30 Requires:       binutils >= 2.12.90.0.1
31 Requires:       cpp = %{version}
32 URL:            http://gcc.gnu.org/
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _slibdir        /lib
36
37 %description
38 A compiler aimed at integrating all the optimizations and features
39 necessary for a high-performance and stable development environment.
40
41 %description -l pl
42 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
43 wyprodukowania szybkiego i stablinego kodu wynikowego.
44
45 %package c++
46 Summary:        C++ support for gcc
47 Group:          Development/Languages
48 Obsoletes:      egcc-c++
49 Obsoletes:      egcs-c++
50 Requires:       gcc = %{GCC_VERSION}
51
52 %description c++
53 This package adds C++ support to the GNU C compiler. It includes
54 support for most of the current C++ specification, including templates
55 and exception handling. It does not include a standard C++ library,
56 which is available separately.
57
58 %description -l de c++
59 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
60 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
61 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
62 sie ist getrennt erhältlich.
63
64 %description -l fr c++
65 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
66 support pour la plupart des spécifications actuelles de C++, dont les
67 modéles et la gestion des exceptions. Il ne comprend pas une
68 bibliothéque C++ standard, qui est disponible séparément.
69
70 %description -l pl c++
71 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
72 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
73 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
74
75 %description -l tr c++
76 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
77 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
78 C++ kitaplýðý bu pakette yer almaz.
79
80 %package objc
81 Summary:        Objective C support for gcc
82 Summary(de):    Objektive C-Unterstützung für gcc
83 Summary(fr):    Gestion d'Objective C pour gcc
84 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
85 Summary(tr):    gcc için Objective C desteði
86 Group:          Development/Languages
87 Obsoletes:      egcc-objc
88 Obsoletes:      egcs-objc
89 Requires:       libobjc = %{OBJC_VERSION}
90 Requires:       gcc = %{GCC_VERSION}
91
92 %description objc
93 This package adds Objective C support to the GNU C compiler. Objective
94 C is a object oriented derivative of the C language, mainly used on
95 systems running NeXTSTEP. This package does not include the standard
96 objective C object library.
97
98 %description -l de objc
99 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
100 Objective C ist ein objektorientiertes Derivat von C, das zur
101 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
102 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
103
104 %description -l fr objc
105 Ce package ajoute un support Objective C au compilateur C GNU.
106 L'Objective C est un langage orienté objetdérivé du langage C,
107 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
108 pas la bibliothéque Objective C standard.
109
110 %description -l pl objc
111 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
112 pakiecie nie ma jeszcze bibliotek C-obj.
113
114 %description -l tr objc
115 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
116 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
117 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
118 kitaplýðý bu pakette yer almaz.
119
120 %package -n libobjc
121 Summary:        Objective C Libraries
122 Summary(pl):    Biblioteki Obiektowego C
123 Group:          Libraries
124 Version:        %{OBJC_VERSION}
125 Epoch:          2
126
127 %description -n libobjc
128 Objective C Libraries
129
130 %description -n libobjc -l pl
131 Biblioteki Obiektowego C
132
133 %package -n libobjc-static
134 Summary:        Static Objective C Libraries
135 Summary(pl):    Statyczne Biblioteki Obiektowego C
136 Group:          Development/Libraries
137 Version:        %{OBJC_VERSION}
138 Epoch:          3
139 Requires:       libobjc = %{OBJC_VERSION}
140
141 %description -n libobjc-static
142 Static Objective C Libraries
143
144 %description -l pl -n libobjc-static
145 Statyczne Obiektowego C
146
147 %package g77
148 Summary:        Fortran 77 support for gcc
149 Summary(pl):    Wspomaganie Fortran 77 dla gcc
150 Group:          Development/Languages
151 Version:        %{GCC_VERSION}
152 Obsoletes:      egcs-g77
153 Requires:       libg2c = %{GCC_VERSION}
154
155 %description g77
156 This apckage adds support for compiling Fortran 77 programs with the
157 GNU compiler.
158
159 %description -l pl g77
160 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
161 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
162
163 %package -n libg2c
164 Summary:        Fortran 77 Libraries
165 Summary(pl):    Biblioteki Fortranu 77
166 Group:          Libraries
167 Version:        %{GCC_VERSION}
168
169 %description -n libg2c
170 Fortran 77 Libraries
171
172 %description -n libg2c -l pl
173 Biblioteki Fortranu 77
174
175 %package -n libg2c-static
176 Summary:        Static Fortran 77 Libraries
177 Summary(pl):    Statyczne Biblioteki Fortranu 77
178 Group:          Development/Libraries
179 Version:        %{GCC_VERSION}
180 Epoch:          2
181 Requires:       libg2c = %{GCC_VERSION}
182
183 %description -n libg2c-static
184 Static Fortran 77 Libraries
185
186 %description -l pl -n libg2c-static
187 Statyczne Fortranu 77
188
189 %package java
190 Summary:        Java support for gcc
191 Summary(pl):    Wspomoganie Java dla gcc
192 Group:          Development/Languages
193 Version:        %{GCC_VERSION}
194 Requires:       %{name} = %{version}
195 Requires:       libgcj >= 3.0.0
196
197 %description java
198 This package adds experimental support for compiling Java(tm) programs
199 and bytecode into native code. To use this you will also need the
200 libgcj package.
201
202 %description -l pl java
203 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
204 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
205 przeprowadziæ kompilacjê.
206
207 %package -n libgcj
208 Summary:        Java Class Libraries
209 Summary(pl):    Biblioteki Klas Javy
210 Group:          Libraries
211 Version:        %{GCJ_VERSION}
212 Epoch:          2
213 Requires:       zlib
214
215 %description -n libgcj
216 Java Class Libraries
217
218 %description -n libgcj -l pl
219 Biblioteki Klass Javy
220
221 %package -n libgcj-devel
222 Summary:        Development files for Java Class Libraries
223 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
224 Group:          Development/Libraries
225 Version:        %{GCJ_VERSION}
226 Epoch:          2
227 Requires:       libgcj = %{GCJ_VERSION}
228 Requires:       %{name}-java
229
230 %description -n libgcj-devel
231 Development files for Java Class Libraries
232
233 %description -n libgcj-devel -l pl
234 Pliki nag³ówkowe dla Bibliotek Klass Javy
235
236 %package -n libgcj-static
237 Summary:        Static Java Class Libraries
238 Summary(pl):    Statyczne Biblioteki Klass Javy
239 Group:          Development/Libraries
240 Version:        %{GCJ_VERSION}
241 Epoch:          2
242 Requires:       libstdc++-devel = %{STDC_VERSION}
243
244 %description -n libgcj-static
245 Static Java Class Libraries
246
247 %description -l pl -n libgcj-static
248 Statyczne Biblioteki Klass Javy
249
250 %package -n libstdc++
251 Summary:        GNU c++ library
252 Summary(pl):    Biblioteki GNU C++ 
253 Group:          Libraries
254 Version:        %{STDC_VERSION}
255 Obsoletes:      libg++
256
257 %description -n libstdc++
258 This is the GNU implementation of the standard C++ libraries, along
259 with additional GNU tools. This package includes the shared libraries
260 necessary to run C++ applications.
261
262 %description -l de -n libstdc++
263 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
264 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
265 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
266
267 %description -l fr -n libstdc++
268 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
269 des outils GNU supplémentaires. Ce package comprend les librairies
270 partagées nécessaires à l'exécution d'application C++.
271
272 %description -l pl -n libstdc++  
273 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
274 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
275 uruchomienia aplikacji napisanych w C++.
276
277 %description -l tr -n libstdc++
278 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
279 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
280
281 %package -n libstdc++-devel
282 Summary:        Header files and libraries for C++ development
283 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
284 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
285 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
286 Group:          Development/Libraries
287 Version:        %{STDC_VERSION}
288 Requires:       libstdc++ = %{STDC_VERSION}
289 Requires:       %{name}-c++
290 Obsoletes:      libg++-devel
291
292 %description -n libstdc++-devel
293 This is the GNU implementation of the standard C++ libraries. This
294 package includes the header files and libraries needed for C++
295 development.
296
297 %description -l pl -n libstdc++-devel
298 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
299 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
300 programowaniu w jêzyku C++.
301
302 %package -n libstdc++-static
303 Summary:        Static c++ standard library
304 Summary(pl):    Biblioteka statyczna c++
305 Group:          Development/Libraries
306 Version:        %{STDC_VERSION}
307 Requires:       libstdc++-devel = %{STDC_VERSION}
308
309 %description -n libstdc++-static
310 Static c++ standard library.
311
312 %description -l pl -n libstdc++-static
313 Biblioteka statyczna C++.
314
315 %package -n libgcc
316 Summary:        Shared gcc library
317 Summary(pl):    Biblioteka gcc
318 Group:          Libraries
319 Version:        %{GCC_VERSION}
320
321 %description -n libgcc
322 Shared gcc library.
323
324 %description -l pl -n libgcc
325 Biblioteka dynamiczna gcc.
326
327 %package -n cpp
328 Summary:        The C Pre Processor
329 Summary(pl):    Preprocesor C
330 Group:          Development/Languages
331 Version:        %{GCC_VERSION}
332 Obsoletes:      egcs-cpp
333 Obsoletes:      gcc-cpp
334
335 %description -n cpp
336 The C preprocessor is a "macro processor" that is used automatically
337 by the C compiler to transform your program before actual compilation.
338 It is called a macro processor because it allows you to define
339 "macros", which are brief abbreviations for longer constructs.
340
341 The C preprocessor provides four separate facilities that you can use
342 as you see fit:
343
344 - Inclusion of header files. These are files of declarations that can
345   be substituted into your program.
346 - Macro expansion. You can define "macros", which are abbreviations
347   for arbitrary fragments of C code, and then the C preprocessor will
348   replace the macros with their definitions throughout the program.
349 - Conditional compilation. Using special preprocessing directives, you
350   can include or exclude parts of the program according to various
351   conditions.
352 - Line control. If you use a program to combine or rearrange source
353   files into an intermediate file which is then compiled, you can use
354   line control to inform the compiler of where each source line
355   originally came from.
356
357 %description -l pl -n cpp
358 Przeprocesor C jest "makro procesorem" który jest automatycznie
359 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
360 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
361 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
362 d³ugich konstrukcji w jêzyku C.
363
364 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
365
366 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
367   deklaracji polecenia do³±czenia innego pliku.
368 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
369   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
370   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
371 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
372   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
373   fragmenty obrabianego strumienia tekstów.
374 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
375   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
376   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
377   odpowiada fragment pliku wynikowego.
378
379 %package ksi
380 Summary:        Ksi support for gcc
381 Summary(pl):    Wspomoganie Ksi dla gcc
382 Version:        %{GCC_VERSION}.%{KSI_VERSION}
383 Group:          Development/Languages
384 Requires:       gcc = %{GCC_VERSION}
385
386 %description ksi
387 This package adds experimental support for compiling Ksi programs
388 into native code. You proabably don't need it, unless your are going
389 to develop a compiler using Ksi as intermediate representation or
390 you are using such compiler (like Gont).
391
392 %description -l pl ksi
393 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
394 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
395 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jakos reprezentacji
396 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
397
398 %package ada
399 Summary:        Ada support for gcc
400 Summary(pl):    Wsparcie dla Ady do gcc
401 Group:          Development/Languages
402 Version:        %{GCC_VERSION}
403 Requires:       libgnat = %{GCC_VERSION}
404 Requires:       gcc = %{GCC_VERSION}
405 Obsoletes:      gnat-devel
406
407 %description ada
408 This package adds experimental support for compiling Ada programs.
409
410 %description -l pl ada
411 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
412 w Adzie.
413
414 %package -n libgnat
415 Summary:        Ada standard libraries
416 Summary(pl):    Biblioteki standardowe dla Ady
417 Group:          Libraries
418 Version:        %{GCC_VERSION}
419 Obsoletes:      gnat
420
421 %description -n libgnat
422 This package contains shared libraries needed to run programs written
423 in Ada.
424
425 %description -l pl -n libgnat
426 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów napisanych
427 w Adzie.
428
429 %package -n libgnat-static
430 Summary:        Static Ada standard libraries
431 Summary(pl):    Statyczne biblioteki standardowe dla Ady
432 Group:          Libraries
433 Version:        %{GCC_VERSION}
434 Obsoletes:      gnat-static
435
436 %description -n libgnat
437 This package contains static libraries needed to run programs written
438 in Ada.
439
440 %description -l pl -n libgnat-static
441 Ten pakiet zawiera biblioteki statyczne potrzebne do uruchamiania
442 programów napisanych w Adzie.
443
444 %prep
445 %setup -q -a1 -n %{name}-%{GCC_VERSION}-%{SNAP}
446 mv ksi-%{KSI_VERSION} gcc/ksi
447 %patch0 -p1
448 %patch1 -p1
449 %patch2 -p1
450 %patch3 -p1
451 %ifarch ppc
452 %patch4 -p1
453 %endif
454
455 %build
456 # cd gcc && autoconf; cd ..
457 # autoconf is not needed!
458 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
459
460 CFLAGS="%{rpmcflags}" \
461 CXXFLAGS="%{rpmcflags}" \
462 TEXCONFIG=false ../configure \
463         --prefix=%{_prefix} \
464         --infodir=%{_infodir} \
465         --mandir=%{_mandir} \
466         --enable-shared \
467         --enable-threads=posix \
468         --enable-languages="c,c++,f77,gcov,java,objc,ksi,ada" \
469         --enable-long-long \
470         --enable-multilib \
471         --with-gnu-as \
472         --with-gnu-ld \
473         --with-system-zlib \
474         --with-slibdir=%{_slibdir} \
475         --without-x \
476         %{_target_platform}
477
478 PATH=$PATH:/sbin:%{_sbindir}
479
480 # this dircty hack is relict of setting, where objdir is subdir of srcdir
481 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
482         gcc/ada/Makefile > makefile.tmp
483 mv -f makefile.tmp gcc/ada/Makefile
484
485 cd ..
486 %{__make} -C obj-%{_target_platform} bootstrap-lean \
487         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
488         mandir=%{_mandir} \
489         infodir=%{_infodir}
490
491 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
492         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
493         mandir=%{_mandir} \
494         infodir=%{_infodir}
495
496 # make Gnat Reference Manual
497 %{__make} -C obj-%{_target_platform}/gcc/ada doc
498
499 %install
500 rm -rf $RPM_BUILD_ROOT
501 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
502
503 cd obj-%{_target_platform}
504 PATH=$PATH:/sbin:%{_sbindir}
505
506 %{__make} install \
507         prefix=$RPM_BUILD_ROOT%{_prefix} \
508         mandir=$RPM_BUILD_ROOT%{_mandir} \
509         infodir=$RPM_BUILD_ROOT%{_infodir} \
510         slibdir=$RPM_BUILD_ROOT/lib
511
512 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
513 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
514
515 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
516 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
517
518 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
519  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
520  ln -sf ../../../${LIBSTDC} libstdc++.so)
521
522 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
523         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
524
525 # move ada shared libraries to proper place...
526 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*-*so \
527         $RPM_BUILD_ROOT%{_libdir}
528 rm -f $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so
529 (cd $RPM_BUILD_ROOT%{_libdir} && \
530  ln -s libgnat-*so libgnat.so && \
531  ln -s libgnarl-*so libgnarl.so)
532
533 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
534
535 cd ..
536
537 install gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
538
539 gzip -9nf READ* ChangeLog
540 gzip -9nf gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
541
542 mkdir java-doc
543 mv -f libjava/doc/cni.sgml libjava/READ* java-doc
544 mv -f fastjar/README java-doc/README.fastjar
545 mv -f libffi/README java-doc/README.libffi
546 mv -f libffi/LICENSE java-doc/LICENSE.libffi
547 gzip -9nf java-doc/*
548
549 mv libobjc/README gcc/objc/README.libobjc
550 gzip -9nf gcc/objc/READ*
551
552 %find_lang %{name}
553
554 %post
555 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
556
557 %postun
558 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
559
560 %post g77
561 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
562
563 %postun g77
564 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
565
566 %post java
567 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
568
569 %postun java
570 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
571
572 %post -n cpp
573 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
574
575 %postun -n cpp
576 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
577
578 %post ksi
579 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
580
581 %postun ksi
582 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
583
584 %post   -p /sbin/ldconfig -n libgcc
585 %postun -p /sbin/ldconfig -n libgcc
586 %post   -p /sbin/ldconfig -n libstdc++
587 %postun -p /sbin/ldconfig -n libstdc++
588 %post   -p /sbin/ldconfig -n libgcj
589 %postun -p /sbin/ldconfig -n libgcj
590 %post   -p /sbin/ldconfig -n libg2c
591 %postun -p /sbin/ldconfig -n libg2c
592 %post   -p /sbin/ldconfig -n libobjc
593 %postun -p /sbin/ldconfig -n libobjc
594 %post   -p /sbin/ldconfig -n libgnat
595 %postun -p /sbin/ldconfig -n libgnat
596
597 %clean
598 rm -rf $RPM_BUILD_ROOT
599
600 %files -f %{name}.lang
601 %defattr(644,root,root,755)
602 %doc READ* ChangeLog.gz
603 %dir %{_libdir}/gcc-lib
604 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
605 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
606 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
607 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
608 %attr(755,root,root) %{_bindir}/gcc
609 %attr(755,root,root) %{_bindir}/gccbug
610 %attr(755,root,root) %{_bindir}/gcov
611 %attr(755,root,root) %{_bindir}/cc
612
613 %{_mandir}/man1/gcc.1*
614 %{_mandir}/man1/cc.1*
615 %{_mandir}/man1/gcov.1*
616 %{_infodir}/gcc*
617
618 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
619 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
620 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
621 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
622 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
623 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
624
625 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
626 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
627 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
628 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
629 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
630 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
631 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
632 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
633 %ifarch %{ix86}
634 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
635 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
636 %endif
637
638 %files c++
639 %defattr(644,root,root,755)
640 %{_mandir}/man1/g++.1.gz
641 %attr(755,root,root) %{_bindir}/g++
642 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
643 %attr(755,root,root) %{_bindir}/c++
644 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
645 %attr(755,root,root) %{_bindir}/c++filt
646 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
647 %attr(755,root,root) %{_libdir}/libsupc++.la
648 %{_libdir}/libsupc++.a
649
650 %files objc
651 %defattr(644,root,root,755)
652 %doc gcc/objc/*.gz
653 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
654 %attr(755,root,root) %{_libdir}/libobjc.so
655 %attr(755,root,root) %{_libdir}/libobjc.la
656 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
657
658 %files -n libobjc
659 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
660
661 %files -n libobjc-static
662 %defattr(644,root,root,755)
663 %{_libdir}/libobjc.a
664
665 %files g77
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/g77
668 %attr(755,root,root) %{_bindir}/f77
669 %{_infodir}/g77*
670 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
671 %attr(755,root,root) %{_libdir}/libg2c.la
672 %attr(755,root,root) %{_libdir}/libg2c.so
673 %{_mandir}/man1/g77.1*
674 %{_mandir}/man1/f77.1*
675 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
676
677 %files -n libg2c
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
680
681 %files -n libg2c-static
682 %{_libdir}/libg2c.a
683
684 %files ksi
685 %defattr(644,root,root,755)
686 %doc gcc/ksi/*.gz gcc/ksi/t/*.gz
687 %{_infodir}/ksi*
688 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
689
690 %files ada
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
693 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
694 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
695 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
696 %ifnarch ppc
697 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
698 %endif
699 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
700 %attr(755,root,root) %{_bindir}/gnat*
701 %{_infodir}/gnat*
702 %attr(755,root,root) %{_libdir}/libgnat.so
703 %attr(755,root,root) %{_libdir}/libgnarl.so
704
705 %files -n libgnat-static
706 %defattr(644,root,root,755)
707 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgna*.a
708
709 %files -n libgnat
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/libgna*-*so
712
713 %files java
714 %defattr(644,root,root,755)
715 %doc java-doc/*.gz
716 %attr(755,root,root) %{_bindir}/gcj*
717 %attr(755,root,root) %{_bindir}/gij
718 %attr(755,root,root) %{_bindir}/jcf-dump
719 %attr(755,root,root) %{_bindir}/jv-*
720 %attr(755,root,root) %{_bindir}/rmi*
721 %attr(755,root,root) %{_bindir}/jar
722 %attr(755,root,root) %{_bindir}/grepjar
723 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
724 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
725 %{_infodir}/gcj*
726 %{_mandir}/man1/jcf-*
727 %{_mandir}/man1/jv-*
728 %{_mandir}/man1/gij*
729 %{_mandir}/man1/gcj*
730
731 %files -n libgcj
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_bindir}/addr2name.awk
734 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
735
736 %files -n libgcj-devel
737 %defattr(644,root,root,755)
738 %{_includedir}/java
739 %{_includedir}/javax
740 %{_includedir}/org
741 %{_includedir}/gcj
742 %{_includedir}/j*.h
743 %{_includedir}/gnu/*
744 %{_libdir}/lib*cj.spec
745 %{_libdir}/security/*
746 %doc %{_datadir}/java
747 %{_datadir}/java/libgcj*.jar
748 %attr(755,root,root) %{_libdir}/lib*cj*.la
749 %attr(755,root,root) %{_libdir}/lib*cj*.so
750
751 %files -n libgcj-static
752 %defattr(644,root,root,755)
753 %{_libdir}/lib*cj*.a
754
755 %files -n libstdc++
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
758
759 %files -n libstdc++-devel
760 %defattr(644,root,root,755)
761 %doc libstdc++-v3/docs/html
762 %{_includedir}/g++*
763 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
764
765 %files -n libstdc++-static
766 %defattr(644,root,root,755)
767 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
768
769 %files -n libgcc
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_slibdir}/lib*.so*
772
773 %files -n cpp
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_slibdir}/cpp
776 %attr(755,root,root) %{_bindir}/cpp
777 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
778 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
779 %{_mandir}/man1/cpp.1*
780 %{_infodir}/cpp*
This page took 0.534155 seconds and 3 git commands to generate.