]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- removed absent include/javax,org, lib/security/* and grepjar (strange, all
[packages/gcc4.git] / gcc4.spec
1 %define         GCC_VERSION     3.0.4
2 %define         STDC_VERSION    3.0.4
3 %define         GCJ_VERSION     3.0.4
4 %define         KSI_VERSION     pre47
5 Summary:        GNU Compiler Collection
6 Summary(pl):    Kolekcja kompilatorów GNU
7 Name:           gcc
8 Version:        %{GCC_VERSION}
9 Release:        2
10 License:        GPL
11 Group:          Development/Languages
12 Group(de):      Entwicklung/Sprachen
13 Group(pl):      Programowanie/Jêzyki
14 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
15 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
16 Patch0:         gcc-DESTDIR.patch
17 Patch1:         gcc-paths.patch
18 BuildRequires:  bison
19 BuildRequires:  texinfo
20 BuildRequires:  zlib-devel
21 BuildRequires:  fileutils >= 4.0.41
22 BuildRequires:  autoconf
23 Requires:       binutils >= 2.9.1.0.25
24 Requires:       cpp = %{version}
25 URL:            http://gcc.gnu.org/
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _slibdir        /lib
29
30 %description
31 A compiler aimed at integrating all the optimizations and features
32 necessary for a high-performance and stable development environment.
33
34 %description -l pl
35 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
36 wyprodukowania szybkiego i stablinego kodu wynikowego.
37
38 %package c++
39 Summary:        C++ support for gcc
40 Summary(fr):    Support C++ pour le compilateur gcc
41 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
42 Summary(tr):    gcc için C++ desteði
43 Group:          Development/Languages
44 Group(de):      Entwicklung/Sprachen
45 Group(pl):      Programowanie/Jêzyki
46 Obsoletes:      egcc-c++
47 Obsoletes:      egcs-c++
48
49 %description c++
50 This package adds C++ support to the GNU C compiler. It includes
51 support for most of the current C++ specification, including templates
52 and exception handling. It does not include a standard C++ library,
53 which is available separately.
54
55 %description -l de c++
56 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
57 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
58 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
59 sie ist getrennt erhältlich.
60
61 %description -l fr c++
62 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
63 support pour la plupart des spécifications actuelles de C++, dont les
64 modéles et la gestion des exceptions. Il ne comprend pas une
65 bibliothéque C++ standard, qui est disponible séparément.
66
67 %description -l pl c++
68 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
69 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
70 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
71
72 %description -l tr c++
73 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
74 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
75 C++ kitaplýðý bu pakette yer almaz.
76
77 %package objc
78 Summary:        Objective C support for gcc
79 Summary(de):    Objektive C-Unterstützung für gcc
80 Summary(fr):    Gestion d'Objective C pour gcc
81 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
82 Summary(tr):    gcc için Objective C desteði
83 Group:          Development/Languages
84 Group(de):      Entwicklung/Sprachen
85 Group(pl):      Programowanie/Jêzyki
86 Requires:       %{name} = %{version}
87 Obsoletes:      egcc-objc
88 Obsoletes:      egcs-objc
89
90 %description objc
91 This package adds Objective C support to the GNU C compiler. Objective
92 C is a object oriented derivative of the C language, mainly used on
93 systems running NeXTSTEP. This package does not include the standard
94 objective C object library.
95
96 %description -l de objc
97 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
98 Objective C ist ein objektorientiertes Derivat von C, das zur
99 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
100 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
101
102 %description -l fr objc
103 Ce package ajoute un support Objective C au compilateur C GNU.
104 L'Objective C est un langage orienté objetdérivé du langage C,
105 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
106 pas la bibliothéque Objective C standard.
107
108 %description -l pl objc
109 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
110 pakiecie nie ma jeszcze bibliotek C-obj.
111
112 %description -l tr objc
113 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
114 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
115 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
116 kitaplýðý bu pakette yer almaz.
117
118 %package g77
119 Summary:        Fortran 77 support for gcc
120 Summary(pl):    Wspomaganie Fortran 77 dla gcc
121 Group:          Development/Languages
122 Group(de):      Entwicklung/Sprachen
123 Group(pl):      Programowanie/Jêzyki
124 Obsoletes:      egcs-g77
125
126 %description g77
127 This apckage adds support for compiling Fortran 77 programs with the
128 GNU compiler.
129
130 %description -l pl g77
131 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
132 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
133
134 %package chill
135 Summary:        CHILL support for gcc
136 Summary(pl):    Wspomoganie CHILL dla gcc
137 Group:          Development/Languages
138 Group(de):      Entwicklung/Sprachen
139 Group(pl):      Programowanie/Jêzyki
140 Requires:       %{name} = %{version}
141
142 %description chill
143 This package adds support for compiling CHILL programs with the GNU
144 compiler.
145
146 Chill is the "CCITT High-Level Language", where CCITT is the old name
147 for what is now ITU, the International Telecommunications Union. It is
148 is language in the Modula2 family, and targets many of the same
149 applications as Ada (especially large embedded systems). Chill was
150 never used much in the United States, but is still being used in
151 Europe, Brazil, Korea, and other places.
152
153 %package java
154 Summary:        Java support for gcc
155 Summary(pl):    Wspomoganie Java dla gcc
156 Group:          Development/Languages
157 Group(de):      Entwicklung/Sprachen
158 Group(pl):      Programowanie/Jêzyki
159 Requires:       %{name} = %{version}
160 Requires:       libgcj >= 3.0.0
161
162 %description java
163 This package adds experimental support for compiling Java(tm) programs
164 and bytecode into native code. To use this you will also need the
165 libgcj package.
166
167 %description -l pl java
168 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
169 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
170 przeprowadziæ kompilacjê.
171
172 %package -n libgcj
173 Summary:        Java Class Libraries
174 Summary(pl):    Biblioteki Klas Javy
175 Group:          Libraries
176 Group(de):      Libraries
177 Group(es):      Bibliotecas
178 Group(fr):      Librairies
179 Group(pl):      Biblioteki
180 Version:        %{GCJ_VERSION}
181 Epoch:          2
182 Requires:       zlib
183
184 %description -n libgcj
185 Java Class Libraries
186
187 %description -n libgcj -l pl
188 Biblioteki Klass Javy
189
190 %package -n libgcj-devel
191 Summary:        Development files for Java Class Libraries
192 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
193 Group:          Development/Libraries
194 Group(de):      Entwicklung/Libraries
195 Group(fr):      Development/Librairies
196 Group(pl):      Programowanie/Biblioteki
197 Version:        %{GCJ_VERSION}
198 Epoch:          2
199 Requires:       libgcj = %{GCJ_VERSION}
200 Requires:       %{name}-java
201
202 %description -n libgcj-devel
203 Development files for Java Class Libraries
204
205 %description -n libgcj-devel -l pl
206 Pliki nag³ówkowe dla Bibliotek Klass Javy
207
208 %package -n libgcj-static
209 Summary:        Static Java Class Libraries
210 Summary(pl):    Statyczne Biblioteki Klass Javy
211 Group:          Development/Libraries
212 Group(de):      Entwicklung/Libraries
213 Group(fr):      Development/Librairies
214 Group(pl):      Programowanie/Biblioteki
215 Version:        %{GCJ_VERSION}
216 Epoch:          2
217 Requires:       libstdc++-devel = %{GCJ_VERSION}
218
219 %description -n libgcj-static
220 Static Java Class Libraries
221
222 %description -l pl -n libgcj-static
223 Statyczne Biblioteki Klass Javy
224
225 %package -n libstdc++
226 Summary:        GNU c++ library
227 Summary(pl):    Biblioteki GNU C++ 
228 Group:          Libraries
229 Group(de):      Libraries
230 Group(es):      Bibliotecas
231 Group(fr):      Librairies
232 Group(pl):      Biblioteki
233 Version:        %{STDC_VERSION}
234 Obsoletes:      libg++
235
236 %description -n libstdc++
237 This is the GNU implementation of the standard C++ libraries, along
238 with additional GNU tools. This package includes the shared libraries
239 necessary to run C++ applications.
240
241 %description -l de -n libstdc++
242 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
243 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
244 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
245
246 %description -l fr -n libstdc++
247 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
248 des outils GNU supplémentaires. Ce package comprend les librairies
249 partagées nécessaires à l'exécution d'application C++.
250
251 %description -l pl -n libstdc++  
252 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
253 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
254 uruchomienia aplikacji napisanych w C++.
255
256 %description -l tr -n libstdc++
257 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
258 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
259
260 %package -n libstdc++-devel
261 Summary:        Header files and libraries for C++ development
262 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
263 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
264 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
265 Group:          Development/Libraries
266 Group(de):      Entwicklung/Libraries
267 Group(fr):      Development/Librairies
268 Group(pl):      Programowanie/Biblioteki
269 Version:        %{STDC_VERSION}
270 Requires:       libstdc++ = %{STDC_VERSION}
271 Requires:       %{name}-c++
272 Obsoletes:      libg++-devel
273
274 %description -n libstdc++-devel
275 This is the GNU implementation of the standard C++ libraries. This
276 package includes the header files and libraries needed for C++
277 development.
278
279 %description -l pl -n libstdc++-devel
280 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
281 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
282 programowaniu w jêzyku C++.
283
284 %package -n libstdc++-static
285 Summary:        Static c++ standard library
286 Summary(pl):    Biblioteka statyczna c++
287 Group:          Development/Libraries
288 Group(de):      Entwicklung/Libraries
289 Group(fr):      Development/Librairies
290 Group(pl):      Programowanie/Biblioteki
291 Version:        %{STDC_VERSION}
292 Requires:       libstdc++-devel = %{STDC_VERSION}
293
294 %description -n libstdc++-static
295 Static c++ standard library.
296
297 %description -l pl -n libstdc++-static
298 Biblioteka statyczna C++.
299
300 %package -n libgcc
301 Summary:        Shared gcc library
302 Summary(pl):    Biblioteka gcc
303 Group:          Libraries
304 Group(de):      Libraries
305 Group(fr):      Librairies
306 Group(pl):      Biblioteki
307 Version:        %{version}
308
309 %description -n libgcc
310 Shared gcc library.
311
312 %description -l pl -n libgcc
313 Biblioteka dynamiczna gcc.
314
315 %package -n cpp
316 Summary:        The C Pre Processor
317 Summary(pl):    Preprocesor C
318 Group:          Development/Languages
319 Group(de):      Entwicklung/Sprachen
320 Group(pl):      Programowanie/Jêzyki
321 Version:        %{version}
322 Obsoletes:      egcs-cpp
323 Obsoletes:      gcc-cpp
324
325 %description -n cpp
326 The C preprocessor is a "macro processor" that is used automatically
327 by the C compiler to transform your program before actual compilation.
328 It is called a macro processor because it allows you to define
329 "macros", which are brief abbreviations for longer constructs.
330
331 The C preprocessor provides four separate facilities that you can use
332 as you see fit:
333
334 - Inclusion of header files. These are files of declarations that can
335   be substituted into your program.
336 - Macro expansion. You can define "macros", which are abbreviations
337   for arbitrary fragments of C code, and then the C preprocessor will
338   replace the macros with their definitions throughout the program.
339 - Conditional compilation. Using special preprocessing directives, you
340   can include or exclude parts of the program according to various
341   conditions.
342 - Line control. If you use a program to combine or rearrange source
343   files into an intermediate file which is then compiled, you can use
344   line control to inform the compiler of where each source line
345   originally came from.
346
347 %description -l pl -n cpp
348 Przeprocesor C jest "makro procesorem" który jest automatycznie
349 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
350 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
351 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
352 d³ugich konstrukcji w jêzyku C.
353
354 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
355
356 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
357   deklaracji polecenia do³±czenia innego pliku.
358 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
359   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
360   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
361 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
362   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
363   fragmenty obrabianego strumienia tekstów.
364 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
365   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
366   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
367   odpowiada fragment pliku wynikowego.
368
369 %package ksi
370 Summary:        Ksi support for gcc
371 Summary(pl):    Wspomoganie Ksi dla gcc
372 Version:        %{GCC_VERSION}.%{KSI_VERSION}
373 Group:          Development/Languages
374 Group(de):      Entwicklung/Sprachen
375 Group(pl):      Programowanie/Jêzyki
376 Requires:       %{name} = %{GCC_VERSION}
377
378 %description ksi
379 This package adds experimental support for compiling Ksi programs
380 into native code. You proabably don't need it, unless your are going
381 to develop a compiler using Ksi as intermediate representation or
382 you are using such compiler (like Gont).
383
384 %description -l pl ksi
385 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
386 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
387 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jakos reprezentacji
388 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
389
390
391 %prep
392 %setup -q -a1 -n %{name}-%{GCC_VERSION}
393 mv ksi-%{KSI_VERSION} gcc/ksi
394 %patch0 -p1
395 %patch1 -p1
396
397 %build
398 # cd gcc && autoconf; cd ..
399 # autoconf is not needed!
400 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
401
402 CFLAGS="%{rpmcflags}" \
403 CXXFLAGS="%{rpmcflags}" \
404 TEXCONFIG=false ../configure \
405         --prefix=%{_prefix} \
406         --infodir=%{_infodir} \
407         --mandir=%{_mandir} \
408         --enable-shared \
409         --enable-threads=posix \
410         --enable-languages="c,c++,f77,gcov,java,objc,ksi" \
411         --enable-long-long \
412         --enable-multilib \
413         --with-gnu-as \
414         --with-gnu-ld \
415         --with-system-zlib \
416         --with-slibdir=%{_slibdir} \
417         --without-x \
418         %{_target_platform}
419
420 PATH=$PATH:/sbin:%{_sbindir}
421
422 cd ..
423 %{__make} -C obj-%{_target_platform} bootstrap-lean \
424         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
425         mandir=%{_mandir} \
426         infodir=%{_infodir}
427
428 %install
429 rm -rf $RPM_BUILD_ROOT
430 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
431
432 cd obj-%{_target_platform}
433 PATH=$PATH:/sbin:%{_sbindir}
434
435 %{__make} install \
436         prefix=$RPM_BUILD_ROOT%{_prefix} \
437         mandir=$RPM_BUILD_ROOT%{_mandir} \
438         infodir=$RPM_BUILD_ROOT%{_infodir} \
439         DESTDIR=$RPM_BUILD_ROOT
440
441 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
442 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
443
444 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
445 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
446
447 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
448  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
449  ln -sf ../../../${LIBSTDC} libstdc++.so)
450
451 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
452         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
453
454 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
455
456 cd ..
457 gzip -9nf READ* ChangeLog
458 gzip -9nf gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
459 gzip -9nf libjava/doc/cni.sgml
460
461 %post
462 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
463
464 %postun
465 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
466
467 %post g77
468 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
469
470 %postun g77
471 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
472
473 %post chill
474 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
475
476 %postun chill
477 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
478
479 %post java
480 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
481
482 %postun java
483 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
484
485 %post -n cpp
486 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
487
488 %postun -n cpp
489 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
490
491 %post ksi
492 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
493
494 %postun ksi
495 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
496
497 %post   -p /sbin/ldconfig -n libgcc
498 %postun -p /sbin/ldconfig -n libgcc
499 %post   -p /sbin/ldconfig -n libstdc++
500 %postun -p /sbin/ldconfig -n libstdc++
501 %post   -p /sbin/ldconfig -n libgcj
502 %postun -p /sbin/ldconfig -n libgcj
503
504 %clean
505 rm -rf $RPM_BUILD_ROOT
506
507 %files
508 %defattr(644,root,root,755)
509 %doc READ* ChangeLog.gz
510 %dir %{_libdir}/gcc-lib
511 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
512 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
513 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
514 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
515 %attr(755,root,root) %{_bindir}/gcc
516 %attr(755,root,root) %{_bindir}/gccbug
517 %attr(755,root,root) %{_bindir}/gcov
518 %attr(755,root,root) %{_bindir}/cc
519
520 %{_mandir}/man1/gcc.1*
521 %{_mandir}/man1/cc.1*
522 %{_mandir}/man1/gcov.1*
523 %{_infodir}/gcc*
524
525 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
526 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
527 #%ifnarch alpha
528 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
529 #%endif
530 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
531 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
532
533 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
534 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
535 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
536 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
537 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
538 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
539 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
540 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
541 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
542
543 %files c++
544 %defattr(644,root,root,755)
545 %{_mandir}/man1/g++.1.gz
546 %attr(755,root,root) %{_bindir}/g++
547 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
548 %attr(755,root,root) %{_bindir}/c++
549 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
550 %attr(755,root,root) %{_bindir}/c++filt
551 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
552 %attr(755,root,root) %{_libdir}/libsupc++.la
553 %{_libdir}/libsupc++.a
554
555 %files objc
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
558 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
559 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
560 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
561 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
562
563 %files g77
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/g77
566 %attr(755,root,root) %{_bindir}/f77
567 %{_infodir}/g77*
568 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
569 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
570 %{_mandir}/man1/g77.1*
571 %{_mandir}/man1/f77.1*
572 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
573
574 %files ksi
575 %doc gcc/ksi/*.gz gcc/ksi/t/*.gz
576 %defattr(644,root,root,755)
577 %{_infodir}/ksi*
578 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
579
580 %ifarch no_longer_supported_by_gcc_team
581 %files chill
582 %defattr(644,root,root,755)
583 %doc gcc/ch/chill.brochure.gz
584
585 %attr(755,root,root) %{_bindir}/chill
586 %{_infodir}/chill*
587 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
588 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
589 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
590 %endif
591
592 %files java
593 %defattr(644,root,root,755)
594 %doc libjava/doc/*gz
595 %attr(755,root,root) %{_bindir}/gcj*
596 %attr(755,root,root) %{_bindir}/gij
597 %attr(755,root,root) %{_bindir}/jcf-dump
598 %attr(755,root,root) %{_bindir}/jv-*
599 %attr(755,root,root) %{_bindir}/jar
600 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
601 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
602 %{_infodir}/gcj*
603
604 %files -n libgcj
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_bindir}/addr2name.awk
607 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
608
609 %files -n libgcj-devel
610 %defattr(644,root,root,755)
611 %{_includedir}/java
612 %{_includedir}/gcj
613 %{_includedir}/j*.h
614 %{_includedir}/gnu/*
615 %{_libdir}/lib*cj.spec
616 %{_datadir}/libgcj.jar
617 %attr(755,root,root) %{_libdir}/lib*cj*.la
618 %attr(755,root,root) %{_libdir}/lib*cj*.so
619
620 %files -n libgcj-static
621 %defattr(644,root,root,755)
622 %{_libdir}/lib*cj*.a
623
624 %files -n libstdc++
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
627
628 %files -n libstdc++-devel
629 %defattr(644,root,root,755)
630 %doc libstdc++-v3/docs/html
631 %{_includedir}/g++*
632 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
633
634 %files -n libstdc++-static
635 %defattr(644,root,root,755)
636 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
637
638 %files -n libgcc
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_slibdir}/lib*.so*
641
642 %files -n cpp
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_slibdir}/cpp
645 %attr(755,root,root) %{_bindir}/cpp
646 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
647 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
648 %{_mandir}/man1/cpp.1*
649 %{_infodir}/cpp*
This page took 0.831888 seconds and 3 git commands to generate.