]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
libsupc++.a moved to gcc package (it should be here!)
[packages/gcc4.git] / gcc4.spec
1 %define         STDC_VERSION    3.0.0
2 %define         GCJ_VERSION     1.0.0
3 %define         ver 3.0
4 Summary:        GNU Compiler Collection
5 Summary(pl):    Kolekcja kompilatorów GNU
6 Name:           gcc
7 Version:        %{ver}
8 Release:        0.20010305
9 License:        GPL
10 Group:          Development/Languages
11 Group(de):      Entwicklung/Sprachen
12 Group(pl):      Programowanie/Jêzyki
13 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/%{release}/%{name}-%{release}.tar.gz
14 BuildRequires:  bison
15 BuildRequires:  texinfo
16 BuildRequires:  zlib-devel
17 BuildRequires:  fileutils >= 4.0.41
18 Requires:       binutils >= 2.9.1.0.25
19 Requires:       cpp = %{version}
20 URL:            http://gcc.gnu.org/
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 A compiler aimed at integrating all the optimizations and features
25 necessary for a high-performance and stable development environment.
26
27 %description -l pl
28 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
29 wyprodukowania szybkiego i stablinego kodu wynikowego.
30
31 %package c++
32 Summary:        C++ support for gcc
33 Summary(fr):    Support C++ pour le compilateur gcc
34 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
35 Summary(tr):    gcc için C++ desteði
36 Group:          Development/Languages
37 Group(de):      Entwicklung/Sprachen
38 Group(pl):      Programowanie/Jêzyki
39 Obsoletes:      egcc-c++
40 Obsoletes:      egcs-c++
41
42 %description c++
43 This package adds C++ support to the GNU C compiler. It includes
44 support for most of the current C++ specification, including templates
45 and exception handling. It does not include a standard C++ library,
46 which is available separately.
47
48 %description -l de c++
49 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
50 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
51 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
52 sie ist getrennt erhältlich.
53
54 %description -l fr c++
55 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
56 support pour la plupart des spécifications actuelles de C++, dont les
57 modéles et la gestion des exceptions. Il ne comprend pas une
58 bibliothéque C++ standard, qui est disponible séparément.
59
60 %description -l pl c++
61 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
62 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
63 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
64
65 %description -l tr c++
66 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
67 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
68 C++ kitaplýðý bu pakette yer almaz.
69
70 %package objc
71 Summary:        Objective C support for gcc
72 Summary(de):    Objektive C-Unterstützung für gcc
73 Summary(fr):    Gestion d'Objective C pour gcc
74 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
75 Summary(tr):    gcc için Objective C desteði
76 Group:          Development/Languages
77 Group(de):      Entwicklung/Sprachen
78 Group(pl):      Programowanie/Jêzyki
79 Obsoletes:      egcc-objc
80 Obsoletes:      egcs-objc
81
82 %description objc
83 This package adds Objective C support to the GNU C compiler. Objective
84 C is a object oriented derivative of the C language, mainly used on
85 systems running NeXTSTEP. This package does not include the standard
86 objective C object library.
87
88 %description -l de objc
89 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
90 Objective C ist ein objektorientiertes Derivat von C, das zur
91 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
92 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
93
94 %description -l fr objc
95 Ce package ajoute un support Objective C au compilateur C GNU.
96 L'Objective C est un langage orienté objetdérivé du langage C,
97 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
98 pas la bibliothéque Objective C standard.
99
100 %description -l pl objc
101 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
102 pakiecie nie ma jeszcze bibliotek C-obj.
103
104 %description -l tr objc
105 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
106 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
107 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
108 kitaplýðý bu pakette yer almaz.
109
110 %package g77
111 Summary:        Fortran 77 support for gcc
112 Summary(pl):    Wspomaganie Fortran 77 dla gcc
113 Group:          Development/Languages
114 Group(de):      Entwicklung/Sprachen
115 Group(pl):      Programowanie/Jêzyki
116 Obsoletes:      egcs-g77
117
118 %description g77
119 This apckage adds support for compiling Fortran 77 programs with the
120 GNU compiler.
121
122 %description -l pl g77
123 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
124 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
125
126 %package chill
127 Summary:        CHILL support for gcc
128 Summary(pl):    Wspomoganie CHILL dla gcc
129 Group:          Development/Languages
130 Group(de):      Entwicklung/Sprachen
131 Group(pl):      Programowanie/Jêzyki
132 Requires:       %{name} = %{version}
133
134 %description chill
135 This package adds support for compiling CHILL programs with the GNU
136 compiler.
137
138 Chill is the "CCITT High-Level Language", where CCITT is the old name
139 for what is now ITU, the International Telecommunications Union. It is
140 is language in the Modula2 family, and targets many of the same
141 applications as Ada (especially large embedded systems). Chill was
142 never used much in the United States, but is still being used in
143 Europe, Brazil, Korea, and other places.
144
145 %package java
146 Summary:        Java support for gcc
147 Summary(pl):    Wspomoganie Java dla gcc
148 Group:          Development/Languages
149 Group(de):      Entwicklung/Sprachen
150 Group(pl):      Programowanie/Jêzyki
151 Requires:       %{name} = %{version}
152 Requires:       libgcj >= 2.95.1
153
154 %description java
155 This package adds experimental support for compiling Java(tm) programs
156 and bytecode into native code. To use this you will also need the
157 libgcj package.
158
159 %description -l pl java
160 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak
161 i do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc przeprowadziæ
162 kompilacjê.
163
164 %package -n libgcj
165 Summary:        Java Class Libraries
166 Summary(pl):    Biblioteki Klas Javy
167 Group:          Libraries
168 Version:        %{GCJ_VERSION}
169
170 %description -n libgcj
171 Java Class Libraries
172
173 %description -n libgcj -l pl
174 Biblioteki Klass Javy
175
176 %package -n libgcj-devel
177 Summary:        Development files for Java Class Libraries
178 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
179 Group:          Development/Libraries
180 Group(de):      Entwicklung/Libraries
181 Group(fr):      Development/Librairies
182 Group(pl):      Programowanie/Biblioteki
183 Version:        %{GCJ_VERSION}
184 Requires:       libgcj = %{GCJ_VERSION}
185 Requires:       %{name}-java
186
187 %description -n libgcj-devel
188 Development files for Java Class Libraries
189
190 %description -n libgcj-devel -l pl
191 Pliki nag³ówkowe dla Bibliotek Klass Javy
192
193 %package -n libgcj-static
194 Summary:        Static Java Class Libraries
195 Summary(pl):    Statyczne Biblioteki Klass Javy
196 Group:          Development/Libraries
197 Group(de):      Entwicklung/Libraries
198 Group(fr):      Development/Librairies
199 Group(pl):      Programowanie/Biblioteki
200 Version:        %{GCJ_VERSION}
201 Requires:       libstdc++-devel = %{GCJ_VERSION}
202
203 %description -n libgcj-static
204 Static Java Class Libraries
205
206 %description -l pl -n libgcj-static
207 Statyczne Biblioteki Klass Javy
208
209 %package -n libstdc++
210 Summary:        GNU c++ library
211 Summary(pl):    Biblioteki GNU C++ 
212 Group:          Libraries
213 Group(de):      Libraries
214 Group(fr):      Librairies
215 Group(pl):      Biblioteki
216 Version:        %{STDC_VERSION}
217 Obsoletes:      libg++
218
219 %description -n libstdc++
220 This is the GNU implementation of the standard C++ libraries, along
221 with additional GNU tools. This package includes the shared libraries
222 necessary to run C++ applications.
223
224 %description -l de -n libstdc++
225 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
226 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
227 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
228
229 %description -l fr -n libstdc++
230 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
231 des outils GNU supplémentaires. Ce package comprend les librairies
232 partagées nécessaires à l'exécution d'application C++.
233
234 %description -l pl -n libstdc++  
235 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
236 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
237 uruchomienia aplikacji napisanych w C++.
238
239 %description -l tr -n libstdc++
240 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
241 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
242
243 %package -n libstdc++-devel
244 Summary:        Header files and libraries for C++ development
245 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
246 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
247 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
248 Group:          Development/Libraries
249 Group(de):      Entwicklung/Libraries
250 Group(fr):      Development/Librairies
251 Group(pl):      Programowanie/Biblioteki
252 Version:        %{STDC_VERSION}
253 Requires:       libstdc++ = %{STDC_VERSION}
254 Requires:       %{name}-c++
255 Obsoletes:      libg++-devel
256
257 %description -n libstdc++-devel
258 This is the GNU implementation of the standard C++ libraries. This
259 package includes the header files and libraries needed for C++
260 development.
261
262 %description -l pl -n libstdc++-devel
263 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
264 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
265 programowaniu w jêzyku C++.
266
267 %package -n libstdc++-static
268 Summary:        Static c++ standard library
269 Summary(pl):    Biblioeka statyczna c++
270 Group:          Development/Libraries
271 Group(de):      Entwicklung/Libraries
272 Group(fr):      Development/Librairies
273 Group(pl):      Programowanie/Biblioteki
274 Version:        %{STDC_VERSION}
275 Requires:       libstdc++-devel = %{STDC_VERSION}
276
277 %description -n libstdc++-static
278 Static c++ standard library.
279
280 %description -l pl -n libstdc++-static
281 Biblioteka statyczna C++.
282
283 %package -n cpp
284 Summary:        The C Pre Processor
285 Summary(pl):    Preprocesor C
286 Group:          Development/Languages
287 Group(de):      Entwicklung/Sprachen
288 Group(pl):      Programowanie/Jêzyki
289 Obsoletes:      egcs-cpp
290
291 %description -n cpp
292 The C preprocessor is a "macro processor" that is used automatically
293 by the C compiler to transform your program before actual compilation.
294 It is called a macro processor because it allows you to define
295 "macros", which are brief abbreviations for longer constructs.
296
297 The C preprocessor provides four separate facilities that you can use
298 as you see fit:
299
300 - Inclusion of header files. These are files of declarations that can
301   be substituted into your program.
302 - Macro expansion. You can define "macros", which are abbreviations
303   for arbitrary fragments of C code, and then the C preprocessor will
304   replace the macros with their definitions throughout the program.
305 - Conditional compilation. Using special preprocessing directives, you
306   can include or exclude parts of the program according to various
307   conditions.
308 - Line control. If you use a program to combine or rearrange source
309   files into an intermediate file which is then compiled, you can use
310   line control to inform the compiler of where each source line
311   originally came from.
312
313 %description -l pl -n cpp
314 Przeprocesor C jest "makro procesorem" który jest automatycznie
315 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
316 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
317 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
318 d³ugich konstrukcji w jêzyku C.
319
320 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
321
322 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
323   deklaracji polecenia do³±czenia innego pliku.
324 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
325   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
326   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
327 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
328   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
329   fragmenty obrabianego strumienia tekstów.
330 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
331   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
332   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
333   odpowiada fragment pliku wynikowego.
334
335 %prep
336 %setup -q -n %{name}-%{release}
337
338 %build
339 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
340
341 CFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
342 CXXFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
343 TEXCONFIG=false ../configure \
344         --prefix=%{_prefix} \
345         --infodir=%{_infodir} \
346         --mandir=%{_mandir} \
347         --enable-shared \
348 %ifarch sparc
349         --with-cpu=sparc \
350 %endif
351 %ifarch sparc64
352         --with-cpu=ultrasparc \
353 %endif
354         --enable-threads=posix \
355         --enable-haifa \
356         --enable-languages="c,gcov,c++,java,f77" \
357         --enable-long-long \
358         --enable-namespaces \
359         --enable-multilib \
360         --with-gnu-as \
361         --with-gnu-ld \
362         --with-system-zlib \
363         --without-x \
364         --disable-nls \
365         %{_target_platform}
366 # --enable-languages=objc
367 # temporary disabled (objc doesn't build right now)
368
369 PATH=$PATH:/sbin:%{_sbindir}
370
371 cd ..
372 %{__make} -C obj-%{_target_platform} bootstrap-lean \
373         LDFLAGS_FOR_TARGET="%{!?debug:-s}" \
374         mandir=%{_mandir} \
375         infodir=%{_infodir}
376
377 %install
378 rm -rf $RPM_BUILD_ROOT
379 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
380
381 cd obj-%{_target_platform}
382 PATH=$PATH:/sbin:%{_sbindir}
383
384 %{__make} install \
385         prefix=$RPM_BUILD_ROOT%{_prefix} \
386         mandir=$RPM_BUILD_ROOT%{_mandir} \
387         infodir=$RPM_BUILD_ROOT%{_infodir}
388
389 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
390
391 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
392
393 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
394
395 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
396
397 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
398
399 gzip -9nf ../READ* ../ChangeLog ../gcc/ch/chill.brochure
400
401 %post
402 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
403
404 %postun
405 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
406
407 %post g77
408 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
409
410 %postun g77
411 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
412
413 %post chill
414 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
415
416 %postun chill
417 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
418
419 %post -n cpp
420 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421
422 %postun -n cpp
423 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
424
425 %post   -p /sbin/ldconfig -n libstdc++
426 %postun -p /sbin/ldconfig -n libstdc++
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %files
432 %defattr(644,root,root,755)
433 %doc READ* ChangeLog.gz
434 %dir %{_libdir}/gcc-lib
435 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
436 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
437 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
438 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
439 %attr(755,root,root) %{_bindir}/gcc
440 %attr(755,root,root) %{_bindir}/gccbug
441 %attr(755,root,root) %{_bindir}/gcov
442 %attr(755,root,root) %{_bindir}/cc
443
444 %{_mandir}/man1/gcc.1*
445 %{_mandir}/man1/gcov.1*
446 %{_infodir}/gcc*
447
448 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
449 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
450 #%ifnarch alpha
451 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
452 #%endif
453 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
454 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
455 %attr(755,root,root) %{_libdir}/libgcc_s.so*
456
457 %attr(755,root,root) %{_libdir}/libsupc++.la
458 %{_libdir}/libsupc++.a
459
460 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
461 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
462 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
463 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
464 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
465 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
466 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
467 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
468 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
469
470 %files c++
471 %defattr(644,root,root,755)
472 %{_mandir}/man1/g++.1.gz
473 %attr(755,root,root) %{_bindir}/g++
474 %attr(755,root,root) %{_bindir}/c++
475 %attr(755,root,root) %{_bindir}/c++filt
476 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
477 %{_infodir}/c-tree*
478 %{_infodir}/g++int*
479
480 %ifarch temporary_disabled_does_not_compile
481 %files objc
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
484 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
485 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
486 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
487 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
488 %endif
489
490 %files g77
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/g77
493 %attr(755,root,root) %{_bindir}/f77
494 %{_infodir}/g77*
495 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
496 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
497 %{_mandir}/man1/g77.1*
498 %{_mandir}/man1/f77.1*
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
500
501 %ifarch no_longer_supported_by_gcc_team
502 %files chill
503 %defattr(644,root,root,755)
504 %doc gcc/ch/chill.brochure.gz
505
506 %attr(755,root,root) %{_bindir}/chill
507 %{_infodir}/chill*
508 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
509 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
510 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
511 %endif
512
513 %files java
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_bindir}/gcj*
516 %attr(755,root,root) %{_bindir}/gij
517 %attr(755,root,root) %{_bindir}/jcf-dump
518 %attr(755,root,root) %{_bindir}/jv-*
519 %attr(755,root,root) %{_bindir}/fastjar
520 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
521 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
522 %{_infodir}/gcj*
523
524 %files -n libgcj
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
527
528 %files -n libgcj-devel
529 %defattr(644,root,root,755)
530 %{_includedir}/java
531 %{_includedir}/gcj
532 %{_includedir}/j*.h
533 %{_includedir}/gnu/*
534 %{_libdir}/lib*cj.spec
535 %{_datadir}/libgcj.jar
536 %attr(755,root,root) %{_libdir}/lib*cj*.la
537 %attr(755,root,root) %{_libdir}/lib*cj*.so
538
539 %files -n libgcj-static
540 %defattr(644,root,root,755)
541 %{_libdir}/lib*cj*.a
542
543 %files -n libstdc++
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
546
547 %files -n libstdc++-devel
548 %defattr(644,root,root,755)
549 %{_includedir}/g++*
550 %{_prefix}/{_target_cpu}*
551 %attr(755,root,root) %{_libdir}/libstdc++.so
552
553 %files -n libstdc++-static
554 %defattr(644,root,root,755)
555 %attr(644,root,root) %{_libdir}/libstdc++.a
556
557 %files -n cpp
558 %defattr(644,root,root,755)
559 %attr(755,root,root) /lib/cpp
560 %attr(755,root,root) %{_bindir}/cpp
561 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
562 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
563 %{_mandir}/man1/cpp.1*
564 %{_infodir}/cpp*
This page took 0.183748 seconds and 3 git commands to generate.