]> git.pld-linux.org Git - packages/gcc2.git/blob - gcc2.spec
- fix libstdc++.so here, too
[packages/gcc2.git] / gcc2.spec
1 %define         rname           gcc
2 %define         rver            2.95.3
3 %define         STDC_VERSION    2.10.0
4 Summary:        GNU Compiler Collection
5 Summary(pl):    Kolekcja kompilatorów GNU
6 Name:           %{rname}2
7 Version:        %{rver}
8 Release:        1
9 License:        GPL
10 Group:          Development/Languages
11 Group(de):      Entwicklung/Sprachen
12 Group(pl):      Programowanie/Jêzyki
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{rname}-%{version}.tar.gz
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-pld-linux.patch
16 Patch2:         %{name}-libstdc++.patch
17 Patch3:         %{name}-bootstrap.patch
18 Patch4:         %{name}-cpp-macro-doc.patch
19 Patch5:         %{name}-default-arch.patch
20 Patch6:         %{name}-libstdc++-out-of-mem.patch
21 Patch7:         %{name}-libstdc++-wstring.patch
22 Patch8:         %{name}-libstdc++-bastring.patch
23 Patch9:         %{name}-manpage.patch
24 Patch10:        %{name}-cpp-dos-newlines.patch
25 Patch11:        %{name}-gpc.patch
26 Patch12:        %{name}-m68k-pic.patch
27 Patch13:        %{name}-sparc32-rfi.patch
28 Patch14:        %{name}-builtin-apply.patch
29 Patch15:        %{name}-ppc-ice.patch
30 Patch16:        %{name}-ppc-descriptions.patch
31 Patch17:        %{name}-alpha-complex-float.patch
32 Patch18:        %{name}-gcj-vs-iconv.patch
33 Patch19:        %{name}-libobjc.patch
34 Patch20:        %{name}-pointer-arith.patch
35 Patch21:        %{name}-crtendS.patch
36 Patch22:        %{name}-suffix.patch
37 BuildRequires:  bison
38 BuildRequires:  texinfo
39 Requires:       binutils >= 2.9.1.0.25
40 Requires:       cpp2 = %{version}
41 URL:            http://gcc.gnu.org/
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A compiler aimed at integrating all the optimizations and features
46 necessary for a high-performance and stable development environment.
47
48 %description -l pl
49 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
50 wyprodukowania szybkiego i stablinego kodu wynikowego.
51
52 %package c++
53 Summary:        C++ support for gcc
54 Summary(fr):    Support C++ pour le compilateur gcc
55 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
56 Summary(tr):    gcc için C++ desteði
57 Group:          Development/Languages
58 Group(de):      Entwicklung/Sprachen
59 Group(pl):      Programowanie/Jêzyki
60 Obsoletes:      egcc-c++
61 Obsoletes:      egcs-c++
62
63 %description c++
64 This package adds C++ support to the GNU C compiler. It includes
65 support for most of the current C++ specification, including templates
66 and exception handling. It does not include a standard C++ library,
67 which is available separately.
68
69 %description -l de c++
70 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
71 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
72 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
73 sie ist getrennt erhältlich.
74
75 %description -l fr c++
76 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
77 support pour la plupart des spécifications actuelles de C++, dont les
78 modéles et la gestion des exceptions. Il ne comprend pas une
79 bibliothéque C++ standard, qui est disponible séparément.
80
81 %description -l pl c++
82 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
83 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
84 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
85
86 %description -l tr c++
87 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
88 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
89 C++ kitaplýðý bu pakette yer almaz.
90
91 %package objc
92 Summary:        Objective C support for gcc
93 Summary(de):    Objektive C-Unterstützung für gcc
94 Summary(fr):    Gestion d'Objective C pour gcc
95 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
96 Summary(tr):    gcc için Objective C desteði
97 Group:          Development/Languages
98 Group(de):      Entwicklung/Sprachen
99 Group(pl):      Programowanie/Jêzyki
100 Obsoletes:      egcc-objc
101 Obsoletes:      egcs-objc
102
103 %description objc
104 This package adds Objective C support to the GNU C compiler. Objective
105 C is a object oriented derivative of the C language, mainly used on
106 systems running NeXTSTEP. This package does not include the standard
107 objective C object library.
108
109 %description -l de objc
110 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
111 Objective C ist ein objektorientiertes Derivat von C, das zur
112 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
113 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
114
115 %description -l fr objc
116 Ce package ajoute un support Objective C au compilateur C GNU.
117 L'Objective C est un langage orienté objetdérivé du langage C,
118 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
119 pas la bibliothéque Objective C standard.
120
121 %description -l pl objc
122 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
123 pakiecie nie ma jeszcze bibliotek C-obj.
124
125 %description -l tr objc
126 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
127 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
128 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
129 kitaplýðý bu pakette yer almaz.
130
131 %package g77
132 Summary:        Fortran 77 support for gcc
133 Summary(pl):    Wspomaganie Fortran 77 dla gcc
134 Group:          Development/Languages
135 Group(de):      Entwicklung/Sprachen
136 Group(pl):      Programowanie/Jêzyki
137 Obsoletes:      egcs-g77
138
139 %description g77
140 This apckage adds support for compiling Fortran 77 programs with the
141 GNU compiler.
142
143 %description -l pl g77
144 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
145 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
146
147 %package chill
148 Summary:        CHILL support for gcc
149 Summary(pl):    Wspomoganie CHILL dla gcc
150 Group:          Development/Languages
151 Group(de):      Entwicklung/Sprachen
152 Group(pl):      Programowanie/Jêzyki
153 Requires:       %{name} = %{version}
154
155 %description chill
156 This package adds support for compiling CHILL programs with the GNU
157 compiler.
158
159 Chill is the "CCITT High-Level Language", where CCITT is the old name
160 for what is now ITU, the International Telecommunications Union. It is
161 is language in the Modula2 family, and targets many of the same
162 applications as Ada (especially large embedded systems). Chill was
163 never used much in the United States, but is still being used in
164 Europe, Brazil, Korea, and other places.
165
166 %description -l pl chill
167 Ten pakiet dodaje do gcc mo¿liwo¶æ kompilowania programów w jêzyku
168 CHILL.
169
170 %package java
171 Summary:        Java support for gcc
172 Summary(pl):    Wspomoganie Java dla gcc
173 Group:          Development/Languages
174 Group(de):      Entwicklung/Sprachen
175 Group(pl):      Programowanie/Jêzyki
176 Requires:       %{name} = %{version}
177 Requires:       libgcj2 >= 2.95.1
178
179 %description java
180 This package adds experimental support for compiling Java(tm) programs
181 and bytecode into native code. To use this you will also need the
182 libgcj package.
183
184 %description -l pl java
185 Ten pakiet dodaje do gcc (eksperymentaln±) mo¿liwo¶æ kompilowania
186 programów w Javie(tm) i bytecode do kodu procesora. Wymaga pakietu
187 libgcj.
188
189 %package -n libstdc++2
190 Summary:        GNU c++ library
191 Summary(pl):    Biblioteki GNU C++
192 Group:          Libraries
193 Group(de):      Libraries
194 Group(fr):      Librairies
195 Group(pl):      Biblioteki
196 Version:        %{STDC_VERSION}
197 Obsoletes:      libg++
198 Provides:       libstdc++ = %{STDC_VERSION}
199
200 %description -n libstdc++2
201 This is the GNU implementation of the standard C++ libraries, along
202 with additional GNU tools. This package includes the shared libraries
203 necessary to run C++ applications.
204
205 %description -l de -n libstdc++2
206 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
207 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
208 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
209
210 %description -l fr -n libstdc++2
211 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
212 des outils GNU supplémentaires. Ce package comprend les librairies
213 partagées nécessaires à l'exécution d'application C++.
214
215 %description -l pl -n libstdc++2 
216 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
217 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
218 uruchomienia aplikacji napisanych w C++.
219
220 %description -l tr -n libstdc++2
221 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
222 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
223
224 %package -n libstdc++2-devel
225 Summary:        Header files and libraries for C++ development
226 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
227 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++
228 Summary(pl):    Pliki nag³ówkowe do programowania z u¿yciem bibliotek C++
229 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
230 Group:          Development/Libraries
231 Group(de):      Entwicklung/Libraries
232 Group(fr):      Development/Librairies
233 Group(pl):      Programowanie/Biblioteki
234 Version:        %{STDC_VERSION}
235 Requires:       libstdc++2 = %{STDC_VERSION}
236 Requires:       %{name}-c++
237 Obsoletes:      libg++-devel
238
239 %description -n libstdc++2-devel
240 This is the GNU implementation of the standard C++ libraries. This
241 package includes the header files and libraries needed for C++
242 development.
243
244 %description -l pl -n libstdc++2-devel
245 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
246 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
247 programowaniu w jêzyku C++.
248
249 %package -n libstdc++2-static
250 Summary:        Static c++ standard library
251 Summary(pl):    Biblioteka statyczna c++
252 Group:          Development/Libraries
253 Group(de):      Entwicklung/Libraries
254 Group(fr):      Development/Librairies
255 Group(pl):      Programowanie/Biblioteki
256 Version:        %{STDC_VERSION}
257 Requires:       libstdc++2-devel = %{STDC_VERSION}
258
259 %description -n libstdc++2-static
260 Static c++ standard library.
261
262 %description -l pl -n libstdc++2-static
263 Biblioteka statyczna C++.
264
265 %package -n cpp2
266 Summary:        The C Pre Processor
267 Summary(pl):    Preprocesor C
268 Group:          Development/Languages
269 Group(de):      Entwicklung/Sprachen
270 Group(pl):      Programowanie/Jêzyki
271 Obsoletes:      egcs-cpp
272
273 %description -n cpp2
274 The C preprocessor is a "macro processor" that is used automatically
275 by the C compiler to transform your program before actual compilation.
276 It is called a macro processor because it allows you to define
277 "macros", which are brief abbreviations for longer constructs.
278
279 The C preprocessor provides four separate facilities that you can use
280 as you see fit:
281
282 - Inclusion of header files. These are files of declarations that can
283   be substituted into your program.
284 - Macro expansion. You can define "macros", which are abbreviations
285   for arbitrary fragments of C code, and then the C preprocessor will
286   replace the macros with their definitions throughout the program.
287 - Conditional compilation. Using special preprocessing directives, you
288   can include or exclude parts of the program according to various
289   conditions.
290 - Line control. If you use a program to combine or rearrange source
291   files into an intermediate file which is then compiled, you can use
292   line control to inform the compiler of where each source line
293   originally came from.
294
295 %description -l pl -n cpp2
296 Preprocesor C jest "makro procesorem" który jest automatycznie
297 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
298 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
299 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
300 d³ugich konstrukcji w jêzyku C.
301
302 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
303
304 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
305   deklaracji polecenia do³±czenia innego pliku.
306 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
307   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
308   identyfikatora deklarowan± wcze¶niej warto¶ci±.
309 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
310   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
311   fragmenty obrabianego strumienia tekstów.
312 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
313   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
314   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
315   odpowiada fragment pliku wynikowego.
316
317 %prep
318 %setup -q -n %{rname}-%{rver}
319 %patch0 -p1
320 %patch1 -p1
321 %patch2 -p1
322 %patch3 -p1
323 %patch4 -p0
324 %patch5 -p0
325 %patch6 -p0
326 %patch7 -p0
327 %patch8 -p0
328 %patch9 -p0
329 %patch10 -p0
330 %patch11 -p1
331 %ifarch m68k
332 %patch12 -p0
333 %endif
334 %ifarch sparc sparc32
335 %patch13 -p0
336 %patch14 -p0
337 %endif
338 %ifarch ppc
339 %patch15 -p0
340 %patch16 -p0
341 %endif
342 %ifarch alpha
343 %patch17 -p1
344 %endif
345 %patch18 -p0
346 %patch19 -p0
347 %patch20 -p0
348 %patch21 -p1
349 %patch22 -p1
350
351 %build
352 (cd gcc; autoconf)
353 rm -rf obj-%{_target_platform}
354 install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
355
356 CFLAGS="%{rpmcflags}" \
357 CXXFLAGS="%{rpmcflags}" \
358 TEXCONFIG=false ../configure \
359         --host=%{_target_platform} \
360         --prefix=%{_prefix} \
361         --infodir=%{_infodir} \
362         --enable-shared \
363 %ifnarch sparc sparc64
364         --enable-threads=posix \
365         --enable-haifa \
366 %endif
367         --with-gnu-as \
368         --with-gnu-ld \
369         --with-gxx-include-dir="\$\{prefix\}/include/g++" \
370         --disable-nls \
371         --program-suffix="2"
372
373 PATH=$PATH:/sbin:%{_sbindir}
374 touch  ../gcc/c-gperf.h
375
376 cd ..
377 %{__make} -C obj-%{_target_platform} bootstrap \
378         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
379         mandir=%{_mandir} \
380         infodir=%{_infodir}
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
385
386 cd obj-%{_target_platform}
387 PATH=$PATH:/sbin:%{_sbindir}
388
389 %{__make} install \
390         prefix=$RPM_BUILD_ROOT%{_prefix} \
391         mandir=$RPM_BUILD_ROOT%{_mandir} \
392         infodir=$RPM_BUILD_ROOT%{_infodir}
393
394 %{__make} install \
395         prefix=$RPM_BUILD_ROOT%{_prefix} \
396         mandir=$RPM_BUILD_ROOT%{_mandir} \
397         infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
398
399 ln -sf gcc2 $RPM_BUILD_ROOT%{_bindir}/cc2
400
401 ln -sf g772 $RPM_BUILD_ROOT%{_bindir}/f772
402
403 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
404  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/* ; \
405  ln -sf %{_libdir}/${LIBSTDC} libstdc++.so)
406
407 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
408         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
409
410 ln -sf %{_bindir}/cpp2 $RPM_BUILD_ROOT/lib/cpp2
411
412 gzip -9nf ../READ* ../ChangeLog ../gcc/ch/chill.brochure
413
414 cd $RPM_BUILD_ROOT%{_bindir}
415 mv chill chill2
416 mv %{_target_platform}-gcc %{_target_platform}-gcc2 
417 mv jcf-dump jcf-dump2
418 mv jv-scan jv-scan2
419 mv gcjh gcjh2
420
421 %post
422 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
423
424 %postun
425 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
426
427 %post g77
428 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
429
430 %postun g77
431 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
432
433 %post chill
434 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
435
436 %postun chill
437 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
438
439 %post -n cpp2
440 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
441
442 %postun -n cpp2
443 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
444
445 %post   -p /sbin/ldconfig -n libstdc++2
446 %postun -p /sbin/ldconfig -n libstdc++2
447
448 %clean
449 rm -rf $RPM_BUILD_ROOT
450
451 %files
452 %defattr(644,root,root,755)
453 %doc READ* ChangeLog.gz
454
455 %dir %{_libdir}/gcc-lib
456 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
457 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
458 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
459
460 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc2
461 %attr(755,root,root) %{_bindir}/gcc2
462 %attr(755,root,root) %{_bindir}/gcov2
463 %attr(755,root,root) %{_bindir}/protoize2
464 %attr(755,root,root) %{_bindir}/unprotoize2
465 %attr(755,root,root) %{_bindir}/cc2
466
467 %{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
468 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
469 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
470 %{_libdir}/gcc-lib/%{_target_cpu}*/*/lib*.map
471 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
472
473 %ifnarch alpha
474 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
475 %endif
476
477 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
478
479 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
480 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
481 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
482 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
483 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
484 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
485 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
486 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
487 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/va-*.h
488 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
489
490 %files c++
491 %defattr(644,root,root,755)
492
493 %attr(755,root,root) %{_bindir}/g++2
494 %attr(755,root,root) %{_bindir}/c++2
495 %attr(755,root,root) %{_bindir}/c++filt2
496 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
497
498 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/exception
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new
500 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/typeinfo
501 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new.h
502
503 %files objc
504 %defattr(644,root,root,755)
505
506 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
507
508 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
509 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
510
511 %files g77
512 %defattr(644,root,root,755)
513
514 %attr(755,root,root) %{_bindir}/g772
515 %attr(755,root,root) %{_bindir}/f772
516
517 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
518 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
519
520 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
521
522 %files chill
523 %defattr(644,root,root,755)
524 %doc gcc/ch/chill.brochure.gz
525
526 %attr(755,root,root) %{_bindir}/chill2
527
528 %{_infodir}/chill*
529
530 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
531 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
532 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
533
534 %files java
535 %defattr(644,root,root,755)
536
537 %attr(755,root,root) %{_bindir}/gcj2
538 %attr(755,root,root) %{_bindir}/gcjh2
539 %attr(755,root,root) %{_bindir}/jcf-dump2
540 %attr(755,root,root) %{_bindir}/jv-scan2
541
542 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
543 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
544
545 %files -n libstdc++2
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
548
549 %files -n libstdc++2-devel
550 %defattr(644,root,root,755)
551 %{_includedir}/g++
552 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
553
554 %files -n libstdc++2-static
555 %defattr(644,root,root,755)
556 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
557
558 %files -n cpp2
559 %defattr(644,root,root,755)
560 %attr(755,root,root) /lib/cpp2
561 %attr(755,root,root) %{_bindir}/cpp2
562 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
This page took 0.176578 seconds and 3 git commands to generate.