]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- up to 4.9.1; unfortunately 'as' hangs while processing ada stuff on x86_64 here
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 16 Jul 2014 20:59:01 +0000 (22:59 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 16 Jul 2014 20:59:01 +0000 (22:59 +0200)
gcc-ada-link.patch
gcc.spec

index 7583d8c95d4c092ac839d1b444a2033f10c0ee11..fe11acd55df3fe25f4295030413d9e257375b77e 100644 (file)
  shext  =
  hyphen = -
  
-@@ -193,7 +193,7 @@
+@@ -210,7 +210,7 @@
  # Link flags used to build gnat tools.  By default we prefer to statically
  # link with libgcc to avoid a dependency on shared libgcc (which is tricky
  # to deal with as it may conflict with the libgcc provided by the system).
--GCC_LINK_FLAGS=-static-libgcc
-+GCC_LINK_FLAGS=
+-GCC_LINK_FLAGS=-static-libstdc++ -static-libgcc
++GCC_LINK_FLAGS=-static-libstdc++
  
  # End of variables for you to override.
  
@@ -55,9 +55,9 @@
        cd $(RTSDIR); $(LN_S) libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
                libgnat$(soext)
        cd $(RTSDIR); $(LN_S) libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
---- a/gcc/ada/gcc-interface/Makefile.in~       2011-03-27 13:01:06.697666231 +0200
-+++ b/gcc/ada/gcc-interface/Makefile.in        2011-03-27 13:08:55.725801177 +0200
-@@ -2612,14 +2612,14 @@
+--- a/gcc/ada/gcc-interface/Makefile.in~       2014-07-16 18:43:51.000000000 +0200
++++ b/gcc/ada/gcc-interface/Makefile.in        2014-07-16 18:46:09.555516586 +0200
+@@ -2811,14 +2811,14 @@
               gnatlib
        $(RM) $(RTSDIR)/libgna*$(soext)
        cd $(RTSDIR); `echo "$(GCC_FOR_TARGET)" \
@@ -74,4 +74,3 @@
                $(PICFLAG_FOR_TARGET) \
                -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(GNATRTL_TASKING_OBJS) \
-
index 3d40741600d5544766a21b03a8d9886bd5c1494b..2c4f6ce75e6866b89f2e28a5776ebab896829246 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -85,8 +85,8 @@
 %undefine      with_ada
 %endif
 
-%define                major_ver       4.8
-%define                minor_ver       3
+%define                major_ver       4.9
+%define                minor_ver       1
 %define                major_ecj_ver   4.5
 # class data version seen with file(1) that this jvm is able to load
 %define                _classdataversion 50.0
@@ -98,20 +98,20 @@ Summary(pl.UTF-8):  Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       1
+Release:       0.1
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 7c60f24fab389f77af203d2516ee110f
+# Source0-md5: fddf71348546af523353bd43d34919c1
 Source1:       %{name}-optimize-la.pl
 Source2:       ftp://sourceware.org/pub/java/ecj-%{major_ecj_ver}.jar
 # Source2-md5: d7cd6a27c8801e66cbaa964a039ecfdb
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
-# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_8_3_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_8-branch > gcc-branch.diff
+# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_9_1_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_9-branch > gcc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        d319158cb79ab67a3f0e6005f7c2b1f7
+# Patch100-md5:        15a183f399428683132fe283a444d6ef
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-cloog.patch
 Patch2:                %{name}-nodebug.patch
This page took 0.205727 seconds and 4 git commands to generate.