]> git.pld-linux.org Git - packages/gcc.git/commitdiff
start update to 13.1.0
authorJan Palus <atler@pld-linux.org>
Fri, 28 Apr 2023 16:11:14 +0000 (18:11 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 28 Apr 2023 16:11:50 +0000 (18:11 +0200)
- new libgo soname
- add todo item for modula-2 frontend

branch.sh
gcc-ada-link.patch
gcc-info.patch
gcc-moresparcs.patch
gcc-nodebug.patch
gcc.spec

index 79cac910294a6d488326cab4e83d090ac35a7e23..f3296d475044629a7e65acdf1ce958510e220471 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,8 +2,8 @@
 set -e
 url=git://gcc.gnu.org/git/gcc.git
 package=gcc
-tag=releases/gcc-12.2.0
-branch=releases/gcc-12
+tag=releases/gcc-13.1.0
+branch=releases/gcc-13
 out=$package-branch.diff
 repo=$package.git
 
index acb31939e1db9700bb046aaf0050382af157e85d..f59ce30af8251d07d40338316f362c628649e5da 100644 (file)
@@ -19,20 +19,19 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gcc-interface/Makefile.in gcc-10.2
  
  # End of variables for you to override.
  
-@@ -657,19 +657,20 @@ gnatlib-shared-default:
+@@ -670,18 +670,19 @@
+            LN_S="$(LN_S)" \
               gnatlib
        $(RM) $(RTSDIR)/libgna*$(soext)
-       cd $(RTSDIR); `echo "$(GCC_FOR_TARGET)" \
--                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared $(GNATLIBCFLAGS) \
-+                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared -shared-libgcc $(GNATLIBCFLAGS) \
+-      cd $(RTSDIR); $(GCC_FOR_ADA_RTS) -shared $(GNATLIBCFLAGS) \
++      cd $(RTSDIR); $(GCC_FOR_ADA_RTS) -shared -shared-libgcc $(GNATLIBCFLAGS) \
                $(PICFLAG_FOR_TARGET) \
                -o libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(GNATRTL_NONTASKING_OBJS) $(LIBGNAT_OBJS) \
                $(SO_OPTS)libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(MISCLIB) -lm
-       cd $(RTSDIR); `echo "$(GCC_FOR_TARGET)" \
--                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared $(GNATLIBCFLAGS) \
-+                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared -shared-libgcc $(GNATLIBCFLAGS) \
+-      cd $(RTSDIR); $(GCC_FOR_ADA_RTS) -shared $(GNATLIBCFLAGS) \
++      cd $(RTSDIR); $(GCC_FOR_ADA_RTS) -shared -shared-libgcc $(GNATLIBCFLAGS) \
                $(PICFLAG_FOR_TARGET) \
                -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(GNATRTL_TASKING_OBJS) \
index 49712bb3eda1d28c3ab405887a4eee48d1497273..de668808387c5a550875b3e12823babd40ed4e10 100644 (file)
@@ -12,7 +12,7 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gnat_rm.texi gcc-10.2.0/gcc/ada/gn
 +* gnat_rm: (gnat_rm.info).            gnat_rm
  @end direntry
  
- @definfoenclose strong,`,'
+ @c %**end of header
 diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gnat_ugn.texi gcc-10.2.0/gcc/ada/gnat_ugn.texi
 --- gcc-10.2.0.org/gcc/ada/gnat_ugn.texi       2020-07-23 08:35:17.136382261 +0200
 +++ gcc-10.2.0/gcc/ada/gnat_ugn.texi   2021-03-21 01:21:39.489335808 +0100
@@ -27,7 +27,7 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gnat_ugn.texi gcc-10.2.0/gcc/ada/g
 +* gnat_ugn: (gnat_ugn.info).          gnat_ugn
  @end direntry
  
- @definfoenclose strong,`,'
+ @c %**end of header
 diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/cpp.texi gcc-10.2.0/gcc/doc/cpp.texi
 --- gcc-10.2.0.org/gcc/doc/cpp.texi    2021-03-21 01:21:06.752335808 +0100
 +++ gcc-10.2.0/gcc/doc/cpp.texi        2021-03-21 01:21:39.480335808 +0100
@@ -62,7 +62,7 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/gcc.texi gcc-10.2.0/gcc/doc/gcc.te
 --- gcc-10.2.0.org/gcc/doc/gcc.texi    2020-07-23 08:35:17.564386975 +0200
 +++ gcc-10.2.0/gcc/doc/gcc.texi        2021-03-21 01:21:39.481335808 +0100
 @@ -61,15 +61,14 @@ Texts being (a) (see below), and with th
-      funds for GNU development.
+ @end quotation
  @end copying
  @ifnottex
 -@dircategory Software development
@@ -82,8 +82,8 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/gcc.texi gcc-10.2.0/gcc/doc/gcc.te
 +* gcov-dump: (gcc) Gcov-dump.         @command{gcov-dump}---an offline gcda and gcno profile dump tool
 +* lto-dump: (gcc) lto-dump.            @command{lto-dump}---Tool for dumping LTO object files.
  @end direntry
- This file documents the use of the GNU compilers.
  @sp 1
+ @insertcopying
 diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/gccint.texi gcc-10.2.0/gcc/doc/gccint.texi
 --- gcc-10.2.0.org/gcc/doc/gccint.texi 2020-07-23 08:35:17.564386975 +0200
 +++ gcc-10.2.0/gcc/doc/gccint.texi     2021-03-21 01:21:39.481335808 +0100
index f75ab778530a7461e859fb14078dd5903e10f2e2..b9c0662ad61acaa47fe2e220912a80ddfa70e6a7 100644 (file)
@@ -2,12 +2,12 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/config.gcc gcc-10.2.0/gcc/config.gcc
 --- gcc-10.2.0.org/gcc/config.gcc      2021-03-21 11:32:24.611515690 +0100
 +++ gcc-10.2.0/gcc/config.gcc  2021-03-21 11:32:46.784515690 +0100
 @@ -3289,7 +3289,7 @@ sparc-*-rtems*)
-       tm_file="${tm_file} dbxelf.h elfos.h sparc/sysv4.h sparc/sp-elf.h sparc/rtemself.h rtems.h newlib-stdint.h"
+       tm_file="${tm_file} elfos.h sparc/sysv4.h sparc/sp-elf.h sparc/rtemself.h rtems.h newlib-stdint.h"
        tmake_file="${tmake_file} sparc/t-sparc sparc/t-rtems"
        ;;
 -sparc-*-linux*)
 +sparc-*-linux* | sparcv[789]*-*-linux*)
-       tm_file="${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/tso.h"
+       tm_file="${tm_file} elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/tso.h"
        extra_options="${extra_options} sparc/long-double-switch.opt"
        case ${target} in
 @@ -3343,7 +3343,7 @@ sparc64-*-rtems*)
@@ -16,7 +16,7 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/config.gcc gcc-10.2.0/gcc/config.gcc
        ;;
 -sparc64-*-linux*)
 +sparc64*-*-linux*)
-       tm_file="sparc/biarch64.h ${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/default64.h sparc/linux64.h sparc/tso.h"
+       tm_file="sparc/biarch64.h ${tm_file} elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/default64.h sparc/linux64.h sparc/tso.h"
        extra_options="${extra_options} sparc/long-double-switch.opt"
        tmake_file="${tmake_file} sparc/t-sparc sparc/t-linux64"
 diff -urNp -x '*.orig' gcc-10.2.0.org/libgcc/config.host gcc-10.2.0/libgcc/config.host
index 4db00f13ca5d739523a1425892da00ac1c2e49bc..7cca63616cbdff2b69cbd5a55548e09427849561 100644 (file)
@@ -10,12 +10,14 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/Makefile.in gcc-10.2.0/Makefile.in
  BOOT_LDFLAGS=
  BOOT_ADAFLAGS= -gnatpg
  
-@@ -619,8 +619,8 @@ CXXFLAGS_FOR_TARGET = @CXXFLAGS_FOR_TARG
+@@ -619,9 +619,9 @@ CXXFLAGS_FOR_TARGET = @CXXFLAGS_FOR_TARG
  LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
  LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
  LDFLAGS_FOR_TARGET = @LDFLAGS_FOR_TARGET@
+-GM2FLAGS_FOR_TARGET = -O2 -g
 -GOCFLAGS_FOR_TARGET = -O2 -g
 -GDCFLAGS_FOR_TARGET = -O2 -g
++GM2FLAGS_FOR_TARGET = -O2
 +GOCFLAGS_FOR_TARGET = -O2
 +GDCFLAGS_FOR_TARGET = -O2
  
@@ -125,8 +127,8 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/libstdc++-v3/include/Makefile.am gcc-10.2.
 -      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch3_source} -o $@
 +      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 ${pch3_source} -o $@
  
- # For robustness sake (in light of junk files or in-source
- # configuration), copy from the build or source tree to the install
+ # The real deal.
+ install-data-local: install-headers
 diff -urNp -x '*.orig' gcc-10.2.0.org/libstdc++-v3/include/Makefile.in gcc-10.2.0/libstdc++-v3/include/Makefile.in
 --- gcc-10.2.0.org/libstdc++-v3/include/Makefile.in    2021-03-21 01:22:56.854335808 +0100
 +++ gcc-10.2.0/libstdc++-v3/include/Makefile.in        2021-03-21 01:23:21.861335808 +0100
@@ -155,5 +157,5 @@ diff -urNp -x '*.orig' gcc-10.2.0.org/libstdc++-v3/include/Makefile.in gcc-10.2.
 -      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch3_source} -o $@
 +      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 ${pch3_source} -o $@
  
- # For robustness sake (in light of junk files or in-source
- # configuration), copy from the build or source tree to the install
+ # The real deal.
+ install-data-local: install-headers
index c70d40cf7c271ccd54ac77adeee0ba54226b8655..bc3565dab8242c0c9491b6a5766d65b2feeca7f3 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -4,6 +4,8 @@
 # - when adding new subpackages with external libraries (like libffi)
 #   or having own Version, do not use epoch 6 there, reset them to 0!
 #
+# TODO:
+# - package Modula-2 frontend
 #
 # Conditional build:
 # - languages:
 
 # Stable is: any major_ver and minor_ver >= 1.0
 # For PLD we usually use gcc when minor_ver >= 2.0 (first bugfix release or later)
-%define                major_ver       12
-%define                minor_ver       2.0
+%define                major_ver       13
+%define                minor_ver       1.0
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es.UTF-8):     Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -107,19 +109,19 @@ Summary(pl.UTF-8):        Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       1
+Release:       0.1
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       https://gcc.gnu.org/pub/gcc/releases/%{name}-%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 73bafd0af874439dcdb9fc063b6fb069
+# Source0-md5: 43e4de77f2218c83ca675257ea1af9ef
 Source1:       %{name}-optimize-la.pl
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
 Source4:       branch.sh
 # use branch.sh to update gcc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        ce6d7b53545d1186658e22854c729d1b
+# Patch100-md5:        40315733777031b2fc4351230ccba55b
 Patch0:                %{name}-info.patch
 Patch1:                all-library-paths.patch
 Patch2:                %{name}-nodebug.patch
@@ -2929,7 +2931,6 @@ done
 %endif
 
 cp -p $RPM_BUILD_ROOT%{gcclibdir}/install-tools/include/*.h $RPM_BUILD_ROOT%{gcclibdir}/include
-cp -p $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/syslimits.h $RPM_BUILD_ROOT%{gcclibdir}/include
 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
 
@@ -3986,7 +3987,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc libgo/{LICENSE,PATENTS,README}
 %attr(755,root,root) %{_libdir}/libgo.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgo.so.21
+%attr(755,root,root) %ghost %{_libdir}/libgo.so.22
 
 %files -n libgo-devel
 %defattr(644,root,root,755)
@@ -4003,7 +4004,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n libgo-multilib-32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir32}/libgo.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir32}/libgo.so.21
+%attr(755,root,root) %ghost %{_libdir32}/libgo.so.22
 
 %files -n libgo-multilib-32-devel
 %defattr(644,root,root,755)
@@ -4021,7 +4022,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n libgo-multilib-%{multilib2}
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdirm2}/libgo.so.*.*.*
-%attr(755,root,root) %ghost %{_libdirm2}/libgo.so.21
+%attr(755,root,root) %ghost %{_libdirm2}/libgo.so.22
 
 %files -n libgo-multilib-%{multilib2}-devel
 %defattr(644,root,root,755)
This page took 0.13035 seconds and 4 git commands to generate.