]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- fix libgo -Werror breakage
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 8 Oct 2012 14:07:29 +0000 (16:07 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 8 Oct 2012 14:07:29 +0000 (16:07 +0200)
- test if libgo builds on i486

gcc.spec
libgo-werror.patch [new file with mode: 0644]

index 46ff96c55925c2f58999dee3bb888d5fd0ef2081..8700d2d27337c8b9c2edcdafb628df0e8b7531f8 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
 %undefine      with_multilib
 %endif
 
-%ifarch i386 i486
+#ifarch i386 i486
 # __i686.get_pc_thunk.bx undefined in libgo (TODO: recheck on gcc updates)
-%undefine      with_go
-%endif
+#undefine      with_go
+#endif
 
 %ifarch sparc64
 %undefine      with_ada
@@ -120,6 +120,7 @@ Patch6:             %{name}-ppc64-m32-m64-multilib-only.patch
 Patch7:                %{name}-libjava-multilib.patch
 Patch8:                %{name}-enable-java-awt-qt.patch
 Patch10:       %{name}-moresparcs.patch
+Patch11:       libgo-werror.patch
 Patch13:       issue4664051.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf >= 2.64
@@ -1511,6 +1512,7 @@ Statyczna biblioteka języka Go - wersja 32-bitowa.
 %patch8 -p1
 %endif
 %patch10 -p1
+%patch11 -p1
 
 %patch13 -p0
 
diff --git a/libgo-werror.patch b/libgo-werror.patch
new file mode 100644 (file)
index 0000000..880be95
--- /dev/null
@@ -0,0 +1,12 @@
+--- gcc-4.7.1/libgo/runtime/print.c
++++ gcc-4.7.1/libgo/runtime/print.c
+@@ -17,7 +17,8 @@
+       G* g = runtime_g();
+       if(g == nil || g->writebuf == nil) {
+-              runtime_write(2, v, n);
++              ssize_t bytesWritten = runtime_write(2, v, n);
++              (void)bytesWritten;
+               return;
+       }
+       
This page took 0.043483 seconds and 4 git commands to generate.