]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- started update to 4.8.0
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 22 May 2013 21:19:58 +0000 (23:19 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 22 May 2013 21:19:58 +0000 (23:19 +0200)
- updated branch diff to 4.8 branch
- gcc-ppc64-m32-m64-multilib-only.patch looks unneeded, remnoved from spec

gcc-cloog.patch
gcc-info.patch
gcc-sparc64-ada_fix.patch
gcc.spec

index 0f3f39c5e8c12aabe1daf96eeaecd07b920049e9..a14f4718bf66ef423d192084995f9307aca40a51 100644 (file)
  main ()
  {
  #if CLOOG_VERSION_MAJOR != 0 \
--    || CLOOG_VERSION_MINOR != 16 \
--    || CLOOG_VERSION_REVISION < 1
-+    || CLOOG_VERSION_MINOR < 16 \
-+    || (CLOOG_VERSION_MINOR == 16 && CLOOG_VERSION_REVISION < 1)
+-    || CLOOG_VERSION_MINOR != 17 \
+-    || CLOOG_VERSION_REVISION < 0
++    || CLOOG_VERSION_MINOR < 17 \
++    || (CLOOG_VERSION_MINOR == 17 && CLOOG_VERSION_REVISION < 0)
      choke me
     #endif
    ;
index b848a1389c6bb8b45c621b7a9731a83b64c95ed3..476f4d4ad4d8f4669ef63f5650525a1472937ab7 100644 (file)
@@ -39,9 +39,9 @@
 -* g++: (gcc).                  The GNU C++ compiler.
 +* gcc: (gcc).                         The GNU Compiler Collection
 +* g++: (gcc).                         The GNU C++ compiler
+ * gcov: (gcc) Gcov.            @command{gcov}---a test coverage program.
  @end direntry
  This file documents the use of the GNU compilers.
- @sp 1
 --- a/gcc/doc/gccint.texi      2004-05-24 00:54:29.000000000 +0200
 +++ b/gcc/doc/gccint.texi      2004-09-26 10:58:58.222712920 +0200
 @@ -46,9 +46,9 @@
@@ -73,9 +73,9 @@
 --- a/gcc/ada/gnat_ugn.texi    2005-12-06 23:45:52.983574000 +0100
 +++ b/gcc/ada/gnat_ugn.texi    2005-12-11 02:35:45.580878360 +0100
 @@ -109,9 +109,9 @@
- @end macro
  
- @settitle @value{EDITION} User's Guide @value{PLATFORM}
+ @settitle @value{EDITION} User's Guide @value{TITLESUFFIX}
 -@dircategory GNU Ada tools
 +@dircategory Programming Languages:
  @direntry
index f595965762d2fdcefd8f8b35376c76cf334bd865..dd2d33ed4fe1f3b2d15c0e7120f243b19eb93a82 100644 (file)
@@ -29,9 +29,9 @@
 +  LIBRARY_VERSION := $(LIB_VERSION)
 +endif
 +
+ # HP/PA Linux
  ifeq ($(strip $(filter-out hppa% linux%,$(arch) $(osys))),)
    LIBGNAT_TARGET_PAIRS = \
-   a-intnam.ads<a-intnam-linux.ads \
 --- a/gcc/ada/system-linux-sparc64.ads 1970-01-01 00:00:00.000000000 +0000
 +++ b/gcc/ada/system-linux-sparc64.ads 2005-05-21 18:34:52.000000000 +0000
 @@ -0,0 +1,151 @@
index 6756c0ecce840f5f3b2a1ecfaef12e998435e288..c262815905b1564ece8dda81cbcbafaee8467a74 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,6 +1,8 @@
 # NOTE: despite lower soname, libffi is newer than standalone 3.0.9
 #
 # TODO:
+# - update files
+# - update issue4664051.patch
 # - gconf peer? (but libgcj needs split anyway)
 # - package?
 #   /usr/bin/gjdoc [BR: antlr.jar] (but see gjdoc package, there are some additional jars?)
@@ -33,7 +35,6 @@
 %bcond_without x               # don't build libgcj Xlib-dependent AWTs (incl. GTK/Qt)
 # - other:
 %bcond_without bootstrap       # omit 3-stage bootstrap
-%bcond_with    ppc64_nof       # "nof" multilib target in ppc64 compiler
 %bcond_with    tests           # torture gcc
 %bcond_with    symvers         # enable versioned symbols in libstdc++ (WARNING: changes soname from .so.6 to so.7)
 
 %endif
 %endif
 
-%define                major_ver       4.7
-%define                minor_ver       3
+%define                major_ver       4.8
+%define                minor_ver       0
 %define                major_ecj_ver   4.5
 # class data version seen with file(1) that this jvm is able to load
 %define                _classdataversion 50.0
-%define                gcj_soname_ver  13
+%define                gcj_soname_ver  14
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es.UTF-8):     Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -93,29 +94,29 @@ Summary(pl.UTF-8):  Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       2
+Release:       0.1
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 86f428a30379bdee0224e353ee2f999e
+# Source0-md5: e6040024eb9e761c3bea348d1fa5abb0
 Source1:       %{name}-optimize-la.pl
 Source2:       ftp://sourceware.org/pub/java/ecj-%{major_ecj_ver}.jar
 # Source2-md5: d7cd6a27c8801e66cbaa964a039ecfdb
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
-# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_7_3_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_7-branch > gcc-branch.diff
+# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_8_0_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_8-branch > gcc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        ed71b602ecff35de8f4678e27dd9c2ef
+# Patch100-md5:        ac423abd2e4312e1117296711359a42b
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-cloog.patch
 Patch2:                %{name}-nodebug.patch
 Patch3:                %{name}-ada-link.patch
 Patch4:                %{name}-sparc64-ada_fix.patch
-Patch6:                %{name}-ppc64-m32-m64-multilib-only.patch
 Patch7:                %{name}-libjava-multilib.patch
 Patch8:                %{name}-enable-java-awt-qt.patch
 Patch10:       %{name}-moresparcs.patch
+Patch11:       %{name}-install-libffi.patch
 Patch13:       issue4664051.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf >= 2.64
@@ -1501,14 +1502,14 @@ Statyczna biblioteka języka Go - wersja 32-bitowa.
 %patch3 -p1
 %patch4 -p1
 
-%{!?with_ppc64_nof:%patch6 -p1}
 %patch7 -p0
 %if %{with qt}
 %patch8 -p1
 %endif
 %patch10 -p1
+%patch11 -p0
 
-%patch13 -p0
+#patch13 -p0
 
 mv ChangeLog ChangeLog.general
 
@@ -2688,13 +2689,13 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc libgo/{LICENSE,PATENTS,README}
 %attr(755,root,root) %{_libdir}/libgo.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgo.so.0
+%attr(755,root,root) %ghost %{_libdir}/libgo.so.3
 
 %if %{with multilib}
 %files -n libgo-multilib
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir32}/libgo.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir32}/libgo.so.0
+%attr(755,root,root) %ghost %{_libdir32}/libgo.so.3
 %endif
 
 %files -n libgo-devel
This page took 0.233111 seconds and 4 git commands to generate.