]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- ksi compiler added
authorMichal Moskal <michal@moskal.me>
Thu, 17 Jan 2002 15:47:43 +0000 (15:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- rel 3

Changed files:
    gcc.spec -> 1.81.2.45

gcc.spec

index 04c0b81847f57135012a53851a3b9729e6f0c608..02a1891d51451c3ac5a103aaa1aff5dd580fa5dd 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,16 +1,18 @@
 %define                GCC_VERSION     3.0.3
 %define                STDC_VERSION    3.0.3
 %define                GCJ_VERSION     3.0.3
+%define                KSI_VERSION     pre42
 Summary:       GNU Compiler Collection
 Summary(pl):   Kolekcja kompilatorów GNU
 Name:          gcc
 Version:       %{GCC_VERSION}
-Release:       2
+Release:       3
 License:       GPL
 Group:         Development/Languages
 Group(de):     Entwicklung/Sprachen
 Group(pl):     Programowanie/Jêzyki
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
+Source1:       ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
 Patch0:                gcc-DESTDIR.patch
 Patch1:                gcc-paths.patch
 BuildRequires: bison
@@ -363,8 +365,31 @@ Preprocesor C umo
   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
   odpowiada fragment pliku wynikowego.
 
+%package ksi
+Summary:       Ksi support for gcc
+Summary(pl):   Wspomoganie Ksi dla gcc
+Group:         Development/Languages
+Group(de):     Entwicklung/Sprachen
+Group(pl):     Programowanie/Jêzyki
+Requires:      %{name} = %{version}
+
+%description ksi
+This package adds experimental support for compiling Ksi programs
+into native code. You proabably don't need it, unless your are going
+to develop a compiler using Ksi as intermediate representation or
+you are using such compiler (like Gont).
+
+%description -l pl ksi
+Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
+w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
+¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jakos reprezentacji
+po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
+
+
 %prep
 %setup -q -n %{name}-%{GCC_VERSION}
+%setup -q -a1
+mv ksi-%{KSI_VERSION} gcc/ksi
 %patch0 -p1
 %patch1 -p1
 
@@ -382,7 +407,7 @@ TEXCONFIG=false ../configure \
        --enable-shared \
        --enable-threads=posix \
        --enable-haifa \
-        --enable-languages="c,c++,f77,gcov,java,objc" \
+        --enable-languages="c,c++,f77,gcov,java,objc,ksi" \
        --enable-long-long \
        --enable-namespaces \
        --enable-multilib \
@@ -429,7 +454,7 @@ mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
 
 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
 
-gzip -9nf ../READ* ../ChangeLog
+gzip -9nf ../READ* ../ChangeLog ../gcc/ksi/README ../gcc/ksi/NEWS
 
 %post
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
@@ -455,6 +480,12 @@ gzip -9nf ../READ* ../ChangeLog
 %postun -n cpp
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
+%post ksi
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+
+%postun ksi
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+
 %post   -p /sbin/ldconfig -n libgcc
 %postun -p /sbin/ldconfig -n libgcc
 %post   -p /sbin/ldconfig -n libstdc++
@@ -531,6 +562,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/f77.1*
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
 
+%files ksi
+%doc gcc/ksi/*.gz
+%defattr(644,root,root,755)
+%{_infodir}/ksi*
+%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
+
 %ifarch no_longer_supported_by_gcc_team
 %files chill
 %defattr(644,root,root,755)
This page took 0.176701 seconds and 4 git commands to generate.