]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- don't remove symvers entirely, put it under bcond if we ever decide to try again
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 18 Jun 2012 09:30:16 +0000 (09:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc-symvers.patch -> 1.3
    gcc.spec -> 1.696

gcc-symvers.patch [new file with mode: 0644]
gcc.spec

diff --git a/gcc-symvers.patch b/gcc-symvers.patch
new file mode 100644 (file)
index 0000000..94053c0
--- /dev/null
@@ -0,0 +1,22 @@
+--- libstdc++-v3/configure.orig        2012-03-02 08:13:55.000000000 +0100
++++ libstdc++-v3/configure     2012-03-25 12:31:53.278684698 +0200
+@@ -64773,7 +64773,7 @@
+                       esac
+ else
+-  enable_symvers=yes
++  enable_symvers=gnu-versioned-namespace
+ fi
+--- libstdc++-v3/configure.ac.orig     2012-03-25 12:31:14.966921062 +0200
++++ libstdc++-v3/configure.ac  2012-03-25 12:30:07.363809031 +0200
+@@ -308,7 +308,7 @@
+ GCC_HEADER_STDINT(include/gstdint.h)
+-GLIBCXX_ENABLE_SYMVERS([yes])
++GLIBCXX_ENABLE_SYMVERS([gnu-versioned-namespace])
+ AC_SUBST(libtool_VERSION)
+ GLIBCXX_ENABLE_LIBSTDCXX_VISIBILITY([yes])
index 3053d272e7a8b9e1ef9ef8b25ced03a3205b90aa..f6972667413cabab59b84113bccae6b99773cfa7 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
 # - other:
 %bcond_without bootstrap       # omit 3-stage bootstrap
 %bcond_with    tests           # torture gcc
+%bcond_with    symvers         # enable versioned symbols in libstdc++ (WARNING: changes soname from .so.6 to so.7)
+
+%if %{with symvers}
+%define                cxx_sover       7
+%else
+%define                cxx_sover       6
+%endif
 
 %if %{without cxx}
 %undefine      with_go
@@ -135,6 +142,7 @@ BuildRequires:      glibc-devel(sparcv9)
 %endif
 %endif
 BuildRequires: gmp-devel >= 4.1
+BuildRequires: gmp-c++-devel >= 4.1
 BuildRequires: libmpc-devel
 BuildRequires: mpfr-devel >= 2.3.0
 BuildRequires: ppl-devel
@@ -1476,6 +1484,9 @@ Statyczna biblioteka języka Go - wersja 32-bitowa.
 %if %{with qt}
 %patch8 -p1
 %endif
+%if %{with symvers}
+%patch9 -p0
+%endif
 # update if you need it
 #%patch10 -p1
 
@@ -2238,13 +2249,13 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc libstdc++-v3/{ChangeLog,README}
 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libstdc++.so.7
+%attr(755,root,root) %ghost %{_libdir}/libstdc++.so.%{cxx_sover}
 
 %if %{with multilib}
 %files -n libstdc++-multilib
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir32}/libstdc++.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir32}/libstdc++.so.7
+%attr(755,root,root) %ghost %{_libdir32}/libstdc++.so.%{cxx_sover}
 %endif
 
 %if %{with python}
@@ -2254,7 +2265,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitescriptdir}/libstdcxx/*.py[co]
 %dir %{py_sitescriptdir}/libstdcxx/v6
 %{py_sitescriptdir}/libstdcxx/v6/*.py[co]
-%{_datadir}/gdb/auto-load/usr/lib*/libstdc++.so.7.0.0-gdb.py
+%{_datadir}/gdb/auto-load/usr/lib*/libstdc++.so.%{cxx_sover}.*.*-gdb.py
 %endif
 
 %files -n libstdc++-devel
This page took 0.053405 seconds and 4 git commands to generate.