]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- fix for optimization/12965 (dar.spec on alpha)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 6 Dec 2003 15:37:36 +0000 (15:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc-pr12965.patch -> 1.1

gcc-pr12965.patch [new file with mode: 0644]

diff --git a/gcc-pr12965.patch b/gcc-pr12965.patch
new file mode 100644 (file)
index 0000000..67c3b65
--- /dev/null
@@ -0,0 +1,18 @@
+(http://gcc.gnu.org/ml/gcc-patches/2003-12/msg00630.html)
+2003-12-06  Eric Botcazou  <ebotcazou@libertysurf.fr>
+
+        PR optimization/12965
+        * caller-save.c (save_call_clobbered_regs): Do not save/restore
+        registers around no-return calls.
+
+--- gcc-3.3.2/gcc/caller-save.c.orig   2002-06-13 12:24:00.000000000 +0000
++++ gcc-3.3.2/gcc/caller-save.c        2003-12-06 15:29:08.000000000 +0000
+@@ -407,7 +407,7 @@
+                 regno += insert_restore (chain, 1, regno, MOVE_MAX_WORDS, save_mode);
+           }
+-        if (code == CALL_INSN)
++        if (code == CALL_INSN && ! find_reg_note (insn, REG_NORETURN, NULL))
+           {
+             int regno;
+             HARD_REG_SET hard_regs_to_save;
This page took 0.053631 seconds and 4 git commands to generate.