]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- up to 9.3.0
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 12 Mar 2020 13:59:16 +0000 (14:59 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 12 Mar 2020 13:59:16 +0000 (14:59 +0100)
branch.sh
gcc.spec

index 786711f3f7d2e32b0078baf51c52c819831e52a9..11806e05816d46ef173d0a67582193e30e9f9f3e 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -1,25 +1,25 @@
 #!/bin/sh
 set -e
+url=git://gcc.gnu.org/git/gcc.git
 package=gcc
-svn=svn://gcc.gnu.org/svn/$package
-branch=branches/$package-9-branch
-tag=tags/${package}_9_2_0_release
+tag=releases/gcc-9.3.0
+branch=releases/gcc-9
 out=$package-branch.diff
+repo=$package.git
 
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
-       # remove revno's for smaller diffs
-       # replace svn nonexistend with '0' date, so patch will know that file needs to be removed from disk
-       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,' | \
-       sed -e 's,^\([-+]\{3\} .*\t\)(nonexistent)$,\11970-01-01 01:00:00.000000000 +0100,'
+       cat
 }
 
-old=$svn/$tag
-new=$svn/$branch
-echo >&2 "Running diff: $old -> $new"
-LC_ALL=C svn diff -x --ignore-eol-style --force --old=$old --new=$new > $out.svn.tmp
-filter < $out.svn.tmp > $out.tmp
-rm -f $out.svn.tmp
+if [ ! -d $repo ]; then
+       git clone --bare $url -b $branch $repo
+fi
+
+cd $repo
+       git fetch origin +$branch:$branch +refs/tags/$tag:refs/tags/$tag
+       git log -p --reverse $tag..$branch ":(exclude)doc/doc-*" ":(exclude)test" ":(exclude).*" | filter > ../$out.tmp
+cd ..
 
 if cmp -s $out{,.tmp}; then
        echo >&2 "No new diffs..."
index 2457980ae032657f8f692b0b27ec9a360f3efb3c..c133c820e727529e2a0395f58556ca2581f98fe8 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -93,7 +93,7 @@
 # Stable is: any major_ver and minor_ver >= 1.0
 # For PLD we usually use gcc when minor_ver >= 2.0 (first bugfix release or later)
 %define                major_ver       9
-%define                minor_ver       2.0
+%define                minor_ver       3.0
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es.UTF-8):     Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -101,19 +101,19 @@ Summary(pl.UTF-8):        Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       3
+Release:       1
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       https://ftp.gnu.org/pub/gnu/gcc/gcc-%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 3818ad8600447f05349098232c2ddc78
+# Source0-md5: d00a144b771ddeb021b61aa205b7e345
 Source1:       %{name}-optimize-la.pl
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
 Source4:       branch.sh
 # use branch.sh to update gcc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        3003bd5671e4add292a634bf5e2b153a
+# Patch100-md5:        148b328424d483a06050a4624bad1d2e
 Patch0:                %{name}-info.patch
 Patch2:                %{name}-nodebug.patch
 Patch3:                %{name}-ada-link.patch
@@ -2521,7 +2521,7 @@ więc wtyczki muszą być przebudowywane przy każdej aktualizacji GCC.
 
 %prep
 %setup -q
-%patch100 -p0
+%patch100 -p1
 %patch0 -p1
 %patch2 -p1
 %patch3 -p1
This page took 0.050548 seconds and 4 git commands to generate.