]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- link with just built libgnat (really needed when libgnat.so is broken)
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 7 Mar 2003 15:06:34 +0000 (15:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc-ada-link-new-libgnat.patch -> 1.1

gcc-ada-link-new-libgnat.patch [new file with mode: 0644]

diff --git a/gcc-ada-link-new-libgnat.patch b/gcc-ada-link-new-libgnat.patch
new file mode 100644 (file)
index 0000000..de5039c
--- /dev/null
@@ -0,0 +1,42 @@
+--- gcc-3.2.2/gcc/ada/Makefile.in.orig Fri Mar  7 11:02:33 2003
++++ gcc-3.2.2/gcc/ada/Makefile.in      Fri Mar  7 13:13:08 2003
+@@ -2420,33 +2420,33 @@
+ treeprs.ads : treeprs.adt sinfo.ads xtreeprs.adb
+       -$(MKDIR) bldtools
+       $(CP) $^ bldtools
+-      (cd bldtools; gnatmake -q xtreeprs ; ./xtreeprs ../treeprs.ads )
++      (cd bldtools; gnatmake -q xtreeprs -aO../rts ; ./xtreeprs ../treeprs.ads )
+ einfo.h : einfo.ads einfo.adb xeinfo.adb
+       -$(MKDIR) bldtools
+       $(CP) $^ bldtools
+-      (cd bldtools; gnatmake -q xeinfo ; ./xeinfo ../einfo.h )
++      (cd bldtools; gnatmake -q xeinfo -aO../rts ; ./xeinfo ../einfo.h )
+ sinfo.h : sinfo.ads xsinfo.adb
+       -$(MKDIR) bldtools
+       $(CP) $^ bldtools
+-      (cd bldtools; gnatmake -q xsinfo ; ./xsinfo ../sinfo.h )
++      (cd bldtools; gnatmake -q xsinfo -aO../rts ; ./xsinfo ../sinfo.h )
+ nmake.adb : sinfo.ads nmake.adt xnmake.adb
+       -$(MKDIR) bldtools
+       $(CP) $^ bldtools
+-      (cd bldtools; gnatmake -q xnmake ; ./xnmake -b ../nmake.adb )
++      (cd bldtools; gnatmake -q xnmake -aO../rts ; ./xnmake -b ../nmake.adb )
+ nmake.ads :  sinfo.ads nmake.adt xnmake.adb
+       -$(MKDIR) bldtools
+       $(CP) $^ bldtools
+-      (cd bldtools; gnatmake -q xnmake ; ./xnmake -s ../nmake.ads )
++      (cd bldtools; gnatmake -q xnmake -aO../rts ; ./xnmake -s ../nmake.ads )
+ # We remove the generated .texi files to force regeneration.
+ doctools/xgnatug : xgnatug.adb
+       -$(MKDIR) doctools
+       $(CP) $^ doctools
+-      (cd doctools ; gnatmake -q xgnatug)
++      (cd doctools ; gnatmake -q xgnatug -aO../rts)
+       -rm gnat_ug_*.texi
+ # We cannot list the dependency on the xgnatug binary here because we
This page took 0.055478 seconds and 4 git commands to generate.