]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc-ada-link.patch
- updated info and nodebug patches to 5.1
[packages/gcc.git] / gcc-ada-link.patch
index dc2fca456edb66bd813f53f284c8572a6e0c2d11..240790ad474bb6000d076441070696e12534c37a 100644 (file)
@@ -1,9 +1,9 @@
 --- a/gcc/ada/link.c   2004-09-13 12:18:40.000000000 +0200
 +++ b/gcc/ada/link.c   2004-09-26 12:24:29.079704096 +0200
-@@ -213,10 +213,10 @@
+@@ -157,10 +157,10 @@
  
  #elif defined (linux) || defined(__GLIBC__)
- const char *__gnat_object_file_option = "";
+ const char *__gnat_object_file_option = "-Wl,@";
 -const char *__gnat_run_path_option = "-Wl,-rpath,";
 +const char *__gnat_run_path_option = "";
  char __gnat_shared_libgnat_default = STATIC;
 +char __gnat_shared_libgcc_default = SHARED;
 +int __gnat_link_max = 131072;
  unsigned char __gnat_objlist_file_supported = 1;
- unsigned char __gnat_using_gnu_linker = 1;
  const char *__gnat_object_library_extension = ".a";
---- a/gcc/ada/gcc-interface/Make-lang.in       2004-09-01 12:46:47.000000000 +0200
-+++ b/gcc/ada/gcc-interface/Make-lang.in       2004-09-26 12:21:15.135188144 +0200
-@@ -378,7 +378,7 @@
- ada/doctools/xgnatugn$(build_exeext): ada/xgnatugn.adb
-       -$(MKDIR) ada/doctools
-       $(CP) $^ ada/doctools
--      cd ada/doctools && $(GNATMAKE) -q xgnatugn
-+      cd ada/doctools && $(GNATMAKE) -q xgnatugn -a0../rts
- # Note that gnat_ugn_unw.texi does not depend on xgnatugn 
- # being built so we can distribute a pregenerated gnat_ugn_unw.info
+ unsigned char __gnat_separate_run_path_options = 0;
 --- a/gcc/ada/gcc-interface/Makefile.in        2005-05-26 10:48:40.000000000 +0000
 +++ b/gcc/ada/gcc-interface/Makefile.in        2005-05-26 10:59:25.000000000 +0000
 @@ -126,7 +126,7 @@
  shext  =
  hyphen = -
  
-@@ -193,7 +193,7 @@
+@@ -210,7 +210,7 @@
  # Link flags used to build gnat tools.  By default we prefer to statically
  # link with libgcc to avoid a dependency on shared libgcc (which is tricky
  # to deal with as it may conflict with the libgcc provided by the system).
--GCC_LINK_FLAGS=-static-libgcc
-+GCC_LINK_FLAGS=
+-GCC_LINK_FLAGS=-static-libstdc++ -static-libgcc
++GCC_LINK_FLAGS=-static-libstdc++
  
  # End of variables for you to override.
  
        cd $(RTSDIR); $(LN_S) libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
                libgnat$(soext)
        cd $(RTSDIR); $(LN_S) libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
---- a/gcc/ada/gcc-interface/Makefile.in~       2011-03-27 13:01:06.697666231 +0200
-+++ b/gcc/ada/gcc-interface/Makefile.in        2011-03-27 13:08:55.725801177 +0200
-@@ -2500,7 +2500,7 @@
-            THREAD_KIND="$(THREAD_KIND)" \
+--- a/gcc/ada/gcc-interface/Makefile.in~       2014-07-16 18:43:51.000000000 +0200
++++ b/gcc/ada/gcc-interface/Makefile.in        2014-07-16 18:46:09.555516586 +0200
+@@ -2811,14 +2811,14 @@
               gnatlib
        $(RM) $(RTSDIR)/libgna*$(soext)
--      cd $(RTSDIR); ../../xgcc -B../../ -shared $(GNATLIBCFLAGS) \
-+      cd $(RTSDIR); ../../xgcc -B../../ -shared -shared-libgcc $(GNATLIBCFLAGS) \
-               $(TARGET_LIBGCC2_CFLAGS) \
+       cd $(RTSDIR); `echo "$(GCC_FOR_TARGET)" \
+-                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared $(GNATLIBCFLAGS) \
++                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared -shared-libgcc $(GNATLIBCFLAGS) \
+               $(PICFLAG_FOR_TARGET) \
                -o libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(GNATRTL_NONTASKING_OBJS) $(LIBGNAT_OBJS) \
-
+               $(SO_OPTS)libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
+               $(MISCLIB) -lm
+       cd $(RTSDIR); `echo "$(GCC_FOR_TARGET)" \
+-                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared $(GNATLIBCFLAGS) \
++                | sed -e 's,\./xgcc,../../xgcc,' -e 's,-B\./,-B../../,'` -shared -shared-libgcc $(GNATLIBCFLAGS) \
+               $(PICFLAG_FOR_TARGET) \
+               -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
+               $(GNATRTL_TASKING_OBJS) \
This page took 0.181392 seconds and 4 git commands to generate.