]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc-ada-link.patch
- updated info and nodebug patches to 5.1
[packages/gcc.git] / gcc-ada-link.patch
index 82cf03f0a16aaab420979c3c565ac1d5d805fc9d..240790ad474bb6000d076441070696e12534c37a 100644 (file)
  unsigned char __gnat_objlist_file_supported = 1;
  const char *__gnat_object_library_extension = ".a";
  unsigned char __gnat_separate_run_path_options = 0;
---- a/gcc/ada/gcc-interface/Make-lang.in       2004-09-01 12:46:47.000000000 +0200
-+++ b/gcc/ada/gcc-interface/Make-lang.in       2004-09-26 12:21:15.135188144 +0200
-@@ -378,7 +378,7 @@
- ada/doctools/xgnatugn$(build_exeext): ada/xgnatugn.adb
-       -$(MKDIR) ada/doctools
-       $(CP) $^ ada/doctools
--      cd ada/doctools && $(GNATMAKE) -q xgnatugn
-+      cd ada/doctools && $(GNATMAKE) -q xgnatugn -aO../rts
- # Note that gnat_ugn_unw.texi does not depend on xgnatugn 
- # being built so we can distribute a pregenerated gnat_ugn_unw.info
 --- a/gcc/ada/gcc-interface/Makefile.in        2005-05-26 10:48:40.000000000 +0000
 +++ b/gcc/ada/gcc-interface/Makefile.in        2005-05-26 10:59:25.000000000 +0000
 @@ -126,7 +126,7 @@
  shext  =
  hyphen = -
  
-@@ -193,7 +193,7 @@
+@@ -210,7 +210,7 @@
  # Link flags used to build gnat tools.  By default we prefer to statically
  # link with libgcc to avoid a dependency on shared libgcc (which is tricky
  # to deal with as it may conflict with the libgcc provided by the system).
--GCC_LINK_FLAGS=-static-libgcc
-+GCC_LINK_FLAGS=
+-GCC_LINK_FLAGS=-static-libstdc++ -static-libgcc
++GCC_LINK_FLAGS=-static-libstdc++
  
  # End of variables for you to override.
  
@@ -55,9 +44,9 @@
        cd $(RTSDIR); $(LN_S) libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
                libgnat$(soext)
        cd $(RTSDIR); $(LN_S) libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
---- a/gcc/ada/gcc-interface/Makefile.in~       2011-03-27 13:01:06.697666231 +0200
-+++ b/gcc/ada/gcc-interface/Makefile.in        2011-03-27 13:08:55.725801177 +0200
-@@ -2612,14 +2612,14 @@
+--- a/gcc/ada/gcc-interface/Makefile.in~       2014-07-16 18:43:51.000000000 +0200
++++ b/gcc/ada/gcc-interface/Makefile.in        2014-07-16 18:46:09.555516586 +0200
+@@ -2811,14 +2811,14 @@
               gnatlib
        $(RM) $(RTSDIR)/libgna*$(soext)
        cd $(RTSDIR); `echo "$(GCC_FOR_TARGET)" \
@@ -74,4 +63,3 @@
                $(PICFLAG_FOR_TARGET) \
                -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(GNATRTL_TASKING_OBJS) \
-
This page took 0.055466 seconds and 4 git commands to generate.