]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
dd479877a5d1328333f05b1025acf63e559a09c7
[packages/gcc.git] / gcc.spec
1 %define         GCC_VERSION     3.0
2 %define         STDC_VERSION    3.0.0
3 %define         GCJ_VERSION     3.0.0
4 Summary:        GNU Compiler Collection
5 Summary(pl):    Kolekcja kompilatorów GNU
6 Name:           gcc
7 Version:        3.0.0
8 Release:        0.85
9 License:        GPL
10 Group:          Development/Languages
11 Group(de):      Entwicklung/Sprachen
12 Group(pl):      Programowanie/Jêzyki
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
14 Patch0:         gcc-DESTDIR.patch
15 BuildRequires:  bison
16 BuildRequires:  texinfo
17 BuildRequires:  zlib-devel
18 BuildRequires:  fileutils >= 4.0.41
19 BuildRequires:  autoconf
20 Requires:       binutils >= 2.9.1.0.25
21 Requires:       cpp = %{version}
22 URL:            http://gcc.gnu.org/
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _slibdir        /lib
26
27 %description
28 A compiler aimed at integrating all the optimizations and features
29 necessary for a high-performance and stable development environment.
30
31 %description -l pl
32 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
33 wyprodukowania szybkiego i stablinego kodu wynikowego.
34
35 %package c++
36 Summary:        C++ support for gcc
37 Summary(fr):    Support C++ pour le compilateur gcc
38 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
39 Summary(tr):    gcc için C++ desteði
40 Group:          Development/Languages
41 Group(de):      Entwicklung/Sprachen
42 Group(pl):      Programowanie/Jêzyki
43 Obsoletes:      egcc-c++
44 Obsoletes:      egcs-c++
45
46 %description c++
47 This package adds C++ support to the GNU C compiler. It includes
48 support for most of the current C++ specification, including templates
49 and exception handling. It does not include a standard C++ library,
50 which is available separately.
51
52 %description -l de c++
53 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
54 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
55 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
56 sie ist getrennt erhältlich.
57
58 %description -l fr c++
59 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
60 support pour la plupart des spécifications actuelles de C++, dont les
61 modéles et la gestion des exceptions. Il ne comprend pas une
62 bibliothéque C++ standard, qui est disponible séparément.
63
64 %description -l pl c++
65 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
66 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
67 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
68
69 %description -l tr c++
70 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
71 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
72 C++ kitaplýðý bu pakette yer almaz.
73
74 %package objc
75 Summary:        Objective C support for gcc
76 Summary(de):    Objektive C-Unterstützung für gcc
77 Summary(fr):    Gestion d'Objective C pour gcc
78 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
79 Summary(tr):    gcc için Objective C desteði
80 Group:          Development/Languages
81 Group(de):      Entwicklung/Sprachen
82 Group(pl):      Programowanie/Jêzyki
83 Obsoletes:      egcc-objc
84 Obsoletes:      egcs-objc
85
86 %description objc
87 This package adds Objective C support to the GNU C compiler. Objective
88 C is a object oriented derivative of the C language, mainly used on
89 systems running NeXTSTEP. This package does not include the standard
90 objective C object library.
91
92 %description -l de objc
93 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
94 Objective C ist ein objektorientiertes Derivat von C, das zur
95 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
96 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
97
98 %description -l fr objc
99 Ce package ajoute un support Objective C au compilateur C GNU.
100 L'Objective C est un langage orienté objetdérivé du langage C,
101 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
102 pas la bibliothéque Objective C standard.
103
104 %description -l pl objc
105 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
106 pakiecie nie ma jeszcze bibliotek C-obj.
107
108 %description -l tr objc
109 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
110 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
111 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
112 kitaplýðý bu pakette yer almaz.
113
114 %package g77
115 Summary:        Fortran 77 support for gcc
116 Summary(pl):    Wspomaganie Fortran 77 dla gcc
117 Group:          Development/Languages
118 Group(de):      Entwicklung/Sprachen
119 Group(pl):      Programowanie/Jêzyki
120 Obsoletes:      egcs-g77
121
122 %description g77
123 This apckage adds support for compiling Fortran 77 programs with the
124 GNU compiler.
125
126 %description -l pl g77
127 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
128 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
129
130 %package chill
131 Summary:        CHILL support for gcc
132 Summary(pl):    Wspomoganie CHILL dla gcc
133 Group:          Development/Languages
134 Group(de):      Entwicklung/Sprachen
135 Group(pl):      Programowanie/Jêzyki
136 Requires:       %{name} = %{version}
137
138 %description chill
139 This package adds support for compiling CHILL programs with the GNU
140 compiler.
141
142 Chill is the "CCITT High-Level Language", where CCITT is the old name
143 for what is now ITU, the International Telecommunications Union. It is
144 is language in the Modula2 family, and targets many of the same
145 applications as Ada (especially large embedded systems). Chill was
146 never used much in the United States, but is still being used in
147 Europe, Brazil, Korea, and other places.
148
149 %package java
150 Summary:        Java support for gcc
151 Summary(pl):    Wspomoganie Java dla gcc
152 Group:          Development/Languages
153 Group(de):      Entwicklung/Sprachen
154 Group(pl):      Programowanie/Jêzyki
155 Requires:       %{name} = %{version}
156 Requires:       libgcj >= 2.95.1
157
158 %description java
159 This package adds experimental support for compiling Java(tm) programs
160 and bytecode into native code. To use this you will also need the
161 libgcj package.
162
163 %description -l pl java
164 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
165 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
166 przeprowadziæ kompilacjê.
167
168 %package -n libgcj
169 Summary:        Java Class Libraries
170 Summary(pl):    Biblioteki Klas Javy
171 Group:          Libraries
172 Group(de):      Libraries
173 Group(es):      Bibliotecas
174 Group(fr):      Librairies
175 Group(pl):      Biblioteki
176 Version:        %{GCJ_VERSION}
177 Requires:       zlib
178
179 %description -n libgcj
180 Java Class Libraries
181
182 %description -n libgcj -l pl
183 Biblioteki Klass Javy
184
185 %package -n libgcj-devel
186 Summary:        Development files for Java Class Libraries
187 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
188 Group:          Development/Libraries
189 Group(de):      Entwicklung/Libraries
190 Group(fr):      Development/Librairies
191 Group(pl):      Programowanie/Biblioteki
192 Version:        %{GCJ_VERSION}
193 Requires:       libgcj = %{GCJ_VERSION}
194 Requires:       %{name}-java
195
196 %description -n libgcj-devel
197 Development files for Java Class Libraries
198
199 %description -n libgcj-devel -l pl
200 Pliki nag³ówkowe dla Bibliotek Klass Javy
201
202 %package -n libgcj-static
203 Summary:        Static Java Class Libraries
204 Summary(pl):    Statyczne Biblioteki Klass Javy
205 Group:          Development/Libraries
206 Group(de):      Entwicklung/Libraries
207 Group(fr):      Development/Librairies
208 Group(pl):      Programowanie/Biblioteki
209 Version:        %{GCJ_VERSION}
210 Requires:       libstdc++-devel = %{GCJ_VERSION}
211
212 %description -n libgcj-static
213 Static Java Class Libraries
214
215 %description -l pl -n libgcj-static
216 Statyczne Biblioteki Klass Javy
217
218 %package -n libstdc++
219 Summary:        GNU c++ library
220 Summary(pl):    Biblioteki GNU C++ 
221 Group:          Libraries
222 Group(de):      Libraries
223 Group(es):      Bibliotecas
224 Group(fr):      Librairies
225 Group(pl):      Biblioteki
226 Version:        %{STDC_VERSION}
227 Obsoletes:      libg++
228
229 %description -n libstdc++
230 This is the GNU implementation of the standard C++ libraries, along
231 with additional GNU tools. This package includes the shared libraries
232 necessary to run C++ applications.
233
234 %description -l de -n libstdc++
235 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
236 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
237 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
238
239 %description -l fr -n libstdc++
240 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
241 des outils GNU supplémentaires. Ce package comprend les librairies
242 partagées nécessaires à l'exécution d'application C++.
243
244 %description -l pl -n libstdc++  
245 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
246 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
247 uruchomienia aplikacji napisanych w C++.
248
249 %description -l tr -n libstdc++
250 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
251 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
252
253 %package -n libstdc++-devel
254 Summary:        Header files and libraries for C++ development
255 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
256 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
257 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
258 Group:          Development/Libraries
259 Group(de):      Entwicklung/Libraries
260 Group(fr):      Development/Librairies
261 Group(pl):      Programowanie/Biblioteki
262 Version:        %{STDC_VERSION}
263 Requires:       libstdc++ = %{STDC_VERSION}
264 Requires:       %{name}-c++
265 Obsoletes:      libg++-devel
266
267 %description -n libstdc++-devel
268 This is the GNU implementation of the standard C++ libraries. This
269 package includes the header files and libraries needed for C++
270 development.
271
272 %description -l pl -n libstdc++-devel
273 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
274 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
275 programowaniu w jêzyku C++.
276
277 %package -n libstdc++-static
278 Summary:        Static c++ standard library
279 Summary(pl):    Biblioteka statyczna c++
280 Group:          Development/Libraries
281 Group(de):      Entwicklung/Libraries
282 Group(fr):      Development/Librairies
283 Group(pl):      Programowanie/Biblioteki
284 Version:        %{STDC_VERSION}
285 Requires:       libstdc++-devel = %{STDC_VERSION}
286
287 %description -n libstdc++-static
288 Static c++ standard library.
289
290 %description -l pl -n libstdc++-static
291 Biblioteka statyczna C++.
292
293 %package -n libgcc
294 Summary:        Shared gcc library
295 Summary(pl):    Biblioteka gcc
296 Group:          Libraries
297 Group(de):      Libraries
298 Group(fr):      Librairies
299 Group(pl):      Biblioteki
300 Version:        %{version}
301
302 %description -n libgcc
303 Shared gcc library.
304
305 %description -l pl -n libgcc
306 Biblioteka dynamiczna gcc.
307
308 %package -n cpp
309 Summary:        The C Pre Processor
310 Summary(pl):    Preprocesor C
311 Group:          Development/Languages
312 Group(de):      Entwicklung/Sprachen
313 Group(pl):      Programowanie/Jêzyki
314 Version:        %{version}
315 Obsoletes:      egcs-cpp
316 Obsoletes:      gcc-cpp
317
318 %description -n cpp
319 The C preprocessor is a "macro processor" that is used automatically
320 by the C compiler to transform your program before actual compilation.
321 It is called a macro processor because it allows you to define
322 "macros", which are brief abbreviations for longer constructs.
323
324 The C preprocessor provides four separate facilities that you can use
325 as you see fit:
326
327 - Inclusion of header files. These are files of declarations that can
328   be substituted into your program.
329 - Macro expansion. You can define "macros", which are abbreviations
330   for arbitrary fragments of C code, and then the C preprocessor will
331   replace the macros with their definitions throughout the program.
332 - Conditional compilation. Using special preprocessing directives, you
333   can include or exclude parts of the program according to various
334   conditions.
335 - Line control. If you use a program to combine or rearrange source
336   files into an intermediate file which is then compiled, you can use
337   line control to inform the compiler of where each source line
338   originally came from.
339
340 %description -l pl -n cpp
341 Przeprocesor C jest "makro procesorem" który jest automatycznie
342 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
343 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
344 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
345 d³ugich konstrukcji w jêzyku C.
346
347 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
348
349 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
350   deklaracji polecenia do³±czenia innego pliku.
351 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
352   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
353   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
354 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
355   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
356   fragmenty obrabianego strumienia tekstów.
357 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
358   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
359   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
360   odpowiada fragment pliku wynikowego.
361
362 %prep
363 %setup -q -n %{name}-%{GCC_VERSION}
364 %patch0 -p1
365
366 %build
367 cd gcc && autoconf; cd ..
368 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
369
370 CFLAGS="%{rpmcflags}" \
371 CXXFLAGS="%{rpmcflags}" \
372 TEXCONFIG=false ../configure \
373         --prefix=%{_prefix} \
374         --infodir=%{_infodir} \
375         --mandir=%{_mandir} \
376         --enable-shared \
377 %ifarch sparc
378         --with-cpu=sparc \
379 %endif
380 %ifarch sparc64
381         --with-cpu=ultrasparc \
382 %endif
383         --enable-threads=posix \
384         --enable-haifa \
385         --enable-languages="c,c++,f77,gcov,java,objc" \
386         --enable-long-long \
387         --enable-namespaces \
388         --enable-multilib \
389         --with-gnu-as \
390         --with-gnu-ld \
391         --with-system-zlib \
392         --with-slibdir=%{_slibdir} \
393         --without-x \
394         %{_target_platform}
395
396 PATH=$PATH:/sbin:%{_sbindir}
397
398 cd ..
399 %{__make} -C obj-%{_target_platform} bootstrap-lean \
400         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
401         mandir=%{_mandir} \
402         infodir=%{_infodir}
403
404 %install
405 rm -rf $RPM_BUILD_ROOT
406 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
407
408 cd obj-%{_target_platform}
409 PATH=$PATH:/sbin:%{_sbindir}
410
411 %{__make} install \
412         prefix=$RPM_BUILD_ROOT%{_prefix} \
413         mandir=$RPM_BUILD_ROOT%{_mandir} \
414         infodir=$RPM_BUILD_ROOT%{_infodir} \
415         DESTDIR=$RPM_BUILD_ROOT
416
417 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
418
419 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
420
421 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
422
423 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* \
424         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so)
425 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
426         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
427
428 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
429
430 gzip -9nf ../READ* ../ChangeLog
431
432 %post
433 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
434
435 %postun
436 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
437
438 %post g77
439 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
440
441 %postun g77
442 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
443
444 %post chill
445 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
446
447 %postun chill
448 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
449
450 %post -n cpp
451 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
452
453 %postun -n cpp
454 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
455
456 %post   -p /sbin/ldconfig -n libgcc
457 %postun -p /sbin/ldconfig -n libgcc
458 %post   -p /sbin/ldconfig -n libstdc++
459 %postun -p /sbin/ldconfig -n libstdc++
460 %post   -p /sbin/ldconfig -n libgcj
461 %postun -p /sbin/ldconfig -n libgcj
462
463 %clean
464 rm -rf $RPM_BUILD_ROOT
465
466 %files
467 %defattr(644,root,root,755)
468 %doc READ* ChangeLog.gz
469 %dir %{_libdir}/gcc-lib
470 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
471 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
472 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
473 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
474 %attr(755,root,root) %{_bindir}/gcc
475 %attr(755,root,root) %{_bindir}/gccbug
476 %attr(755,root,root) %{_bindir}/gcov
477 %attr(755,root,root) %{_bindir}/cc
478
479 %{_mandir}/man1/gcc.1*
480 %{_mandir}/man1/gcov.1*
481 %{_infodir}/gcc*
482
483 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
484 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
485 #%ifnarch alpha
486 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
487 #%endif
488 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
489 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
490
491 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
492 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
493 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
494 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
495 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
496 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
497 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
498 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
500
501 %files c++
502 %defattr(644,root,root,755)
503 %{_mandir}/man1/g++.1.gz
504 %attr(755,root,root) %{_bindir}/g++
505 %attr(755,root,root) %{_bindir}/c++
506 %attr(755,root,root) %{_bindir}/c++filt
507 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
508 %attr(755,root,root) %{_libdir}/libsupc++.la
509 %{_libdir}/libsupc++.a
510
511 %files objc
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
514 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
515 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
516 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
517 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
518
519 %files g77
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_bindir}/g77
522 %attr(755,root,root) %{_bindir}/f77
523 %{_infodir}/g77*
524 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
525 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
526 %{_mandir}/man1/g77.1*
527 %{_mandir}/man1/f77.1*
528 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
529
530 %ifarch no_longer_supported_by_gcc_team
531 %files chill
532 %defattr(644,root,root,755)
533 %doc gcc/ch/chill.brochure.gz
534
535 %attr(755,root,root) %{_bindir}/chill
536 %{_infodir}/chill*
537 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
538 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
539 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
540 %endif
541
542 %files java
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/gcj*
545 %attr(755,root,root) %{_bindir}/gij
546 %attr(755,root,root) %{_bindir}/jcf-dump
547 %attr(755,root,root) %{_bindir}/jv-*
548 %attr(755,root,root) %{_bindir}/jar
549 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
550 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
551 %{_infodir}/gcj*
552
553 %files -n libgcj
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
556
557 %files -n libgcj-devel
558 %defattr(644,root,root,755)
559 %{_includedir}/java
560 %{_includedir}/gcj
561 %{_includedir}/j*.h
562 %{_includedir}/gnu/*
563 %{_libdir}/lib*cj.spec
564 %{_datadir}/libgcj.jar
565 %attr(755,root,root) %{_libdir}/lib*cj*.la
566 %attr(755,root,root) %{_libdir}/lib*cj*.so
567
568 %files -n libgcj-static
569 %defattr(644,root,root,755)
570 %{_libdir}/lib*cj*.a
571
572 %files -n libstdc++
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
575
576 %files -n libstdc++-devel
577 %defattr(644,root,root,755)
578 %{_includedir}/g++*
579 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
580
581 %files -n libstdc++-static
582 %defattr(644,root,root,755)
583 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
584
585 %files -n libgcc
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_slibdir}/lib*.so*
588
589 %files -n cpp
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_slibdir}/cpp
592 %attr(755,root,root) %{_bindir}/cpp
593 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
594 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
595 %{_mandir}/man1/cpp.1*
596 %{_infodir}/cpp*
This page took 0.083129 seconds and 2 git commands to generate.