]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
4627a4905c4c32974ead5bb6ac76e28390b0e0b2
[packages/gcc.git] / gcc.spec
1 %define         STDC_VERSION 2.10.0
2 Summary:        GNU Compiler Collection
3 Summary(pl):    Kolekcja kompilatorów GNU
4 Name:           gcc
5 Version:        2.95.3
6 Release:        29
7 License:        GPL
8 Group:          Development/Languages
9 Group(de):      Entwicklung/Sprachen
10 Group(pl):      Programowanie/Jêzyki
11 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.gz
12 Source1:        gcov.1
13 Patch0:         %{name}-info.patch
14 Patch1:         %{name}-pld-linux.patch
15 Patch2:         %{name}-libstdc++.patch
16 Patch3:         %{name}-bootstrap.patch
17 Patch4:         %{name}-cpp-macro-doc.patch
18 Patch5:         %{name}-default-arch.patch
19 Patch6:         %{name}-libstdc++-out-of-mem.patch
20 Patch7:         %{name}-libstdc++-wstring.patch
21 Patch8:         %{name}-libstdc++-bastring.patch
22 Patch9:         %{name}-manpage.patch
23 Patch10:        %{name}-cpp-dos-newlines.patch
24 Patch11:        %{name}-gpc.patch
25 Patch12:        %{name}-m68k-pic.patch
26 Patch13:        %{name}-sparc32-rfi.patch
27 Patch14:        %{name}-builtin-apply.patch
28 Patch15:        %{name}-ppc-ice.patch
29 Patch16:        %{name}-ppc-descriptions.patch
30 Patch17:        %{name}-alpha-complex-float.patch
31 Patch18:        %{name}-gcj-vs-iconv.patch
32 Patch19:        %{name}-libobjc.patch
33 Patch20:        %{name}-pointer-arith.patch
34 Patch21:        %{name}-crtendS.patch
35
36 BuildRequires:  bison
37 BuildRequires:  texinfo
38 Requires:       binutils >= 2.9.1.0.25
39 Requires:       cpp = %{version}
40 URL:            http://gcc.gnu.org/
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 A compiler aimed at integrating all the optimizations and features
45 necessary for a high-performance and stable development environment.
46
47 %description -l pl
48 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
49 wyprodukowania szybkiego i stabilnego kodu wynikowego.
50
51 %package c++
52 Summary:        C++ support for gcc
53 Summary(fr):    Support C++ pour le compilateur gcc
54 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
55 Summary(tr):    gcc için C++ desteði
56 Group:          Development/Languages
57 Group(de):      Entwicklung/Sprachen
58 Group(pl):      Programowanie/Jêzyki
59 Obsoletes:      egcc-c++
60 Obsoletes:      egcs-c++
61 Requires:       %{name} = %{version}
62
63 %description c++
64 This package adds C++ support to the GNU C compiler. It includes
65 support for most of the current C++ specification, including templates
66 and exception handling. It does not include a standard C++ library,
67 which is available separately.
68
69 %description -l de c++
70 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
71 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
72 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
73 sie ist getrennt erhältlich.
74
75 %description -l fr c++
76 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
77 support pour la plupart des spécifications actuelles de C++, dont les
78 modéles et la gestion des exceptions. Il ne comprend pas une
79 bibliothéque C++ standard, qui est disponible séparément.
80
81 %description -l pl c++
82 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
83 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
84 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
85
86 %description -l tr c++
87 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
88 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
89 C++ kitaplýðý bu pakette yer almaz.
90
91 %package objc
92 Summary:        Objective C support for gcc
93 Summary(de):    Objektive C-Unterstützung für gcc
94 Summary(fr):    Gestion d'Objective C pour gcc
95 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
96 Summary(tr):    gcc için Objective C desteði
97 Group:          Development/Languages
98 Group(de):      Entwicklung/Sprachen
99 Group(pl):      Programowanie/Jêzyki
100 Obsoletes:      egcc-objc
101 Obsoletes:      egcs-objc
102 Requires:       %{name} = %{version}
103
104 %description objc
105 This package adds Objective C support to the GNU C compiler. Objective
106 C is a object oriented derivative of the C language, mainly used on
107 systems running NeXTSTEP. This package does not include the standard
108 objective C object library.
109
110 %description -l de objc
111 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
112 Objective C ist ein objektorientiertes Derivat von C, das zur
113 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
114 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
115
116 %description -l fr objc
117 Ce package ajoute un support Objective C au compilateur C GNU.
118 L'Objective C est un langage orienté objetdérivé du langage C,
119 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
120 pas la bibliothéque Objective C standard.
121
122 %description -l pl objc
123 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
124 pakiecie nie ma jeszcze bibliotek C-obj.
125
126 %description -l tr objc
127 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
128 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
129 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
130 kitaplýðý bu pakette yer almaz.
131
132 %package g77
133 Summary:        Fortran 77 support for gcc
134 Summary(pl):    Wspomaganie Fortran 77 dla gcc
135 Group:          Development/Languages
136 Group(de):      Entwicklung/Sprachen
137 Group(pl):      Programowanie/Jêzyki
138 Obsoletes:      egcs-g77
139
140 %description g77
141 This apckage adds support for compiling Fortran 77 programs with the
142 GNU compiler.
143
144 %description -l pl g77
145 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
146 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
147
148 %package chill
149 Summary:        CHILL support for gcc
150 Summary(pl):    Wspomoganie CHILL dla gcc
151 Group:          Development/Languages
152 Group(de):      Entwicklung/Sprachen
153 Group(pl):      Programowanie/Jêzyki
154 Requires:       %{name} = %{version}
155
156 %description chill
157 This package adds support for compiling CHILL programs with the GNU
158 compiler.
159
160 Chill is the "CCITT High-Level Language", where CCITT is the old name
161 for what is now ITU, the International Telecommunications Union. It is
162 is language in the Modula2 family, and targets many of the same
163 applications as Ada (especially large embedded systems). Chill was
164 never used much in the United States, but is still being used in
165 Europe, Brazil, Korea, and other places.
166
167 %description -l pl chill
168 Ten pakiet dodaje do gcc mo¿liwo¶æ kompilowania programów w jêzyku
169 CHILL.
170
171 %package java
172 Summary:        Java support for gcc
173 Summary(pl):    Wspomoganie Java dla gcc
174 Group:          Development/Languages
175 Group(de):      Entwicklung/Sprachen
176 Group(pl):      Programowanie/Jêzyki
177 Requires:       %{name} = %{version}
178 Requires:       libgcj >= 2.95.1
179
180 %description java
181 This package adds experimental support for compiling Java(tm) programs
182 and bytecode into native code. To use this you will also need the
183 libgcj package.
184
185 %description -l pl java
186 Ten pakiet dodaje do gcc (eksperymentaln±) mo¿liwo¶æ kompilowania
187 programów w Javie(tm) i bytecode do kodu procesora. Wymaga pakietu
188 libgcj.
189
190 %package -n libstdc++
191 Summary:        GNU c++ library
192 Summary(pl):    Biblioteki GNU C++
193 Group:          Libraries
194 Group(de):      Libraries
195 Group(fr):      Librairies
196 Group(pl):      Biblioteki
197 Version:        %{STDC_VERSION}
198 Obsoletes:      libg++
199
200 %description -n libstdc++
201 This is the GNU implementation of the standard C++ libraries, along
202 with additional GNU tools. This package includes the shared libraries
203 necessary to run C++ applications.
204
205 %description -l de -n libstdc++
206 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
207 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
208 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
209
210 %description -l fr -n libstdc++
211 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
212 des outils GNU supplémentaires. Ce package comprend les librairies
213 partagées nécessaires à l'exécution d'application C++.
214
215 %description -l pl -n libstdc++  
216 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
217 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
218 uruchomienia aplikacji napisanych w C++.
219
220 %description -l tr -n libstdc++
221 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
222 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
223
224 %package -n libstdc++-devel
225 Summary:        Header files and libraries for C++ development
226 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
227 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++
228 Summary(pl):    Pliki nag³ówkowe do programowania z u¿yciem bibliotek C++
229 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
230 Group:          Development/Libraries
231 Group(de):      Entwicklung/Libraries
232 Group(fr):      Development/Librairies
233 Group(pl):      Programowanie/Biblioteki
234 Version:        %{STDC_VERSION}
235 Requires:       libstdc++ = %{STDC_VERSION}
236 Requires:       %{name}-c++
237 Obsoletes:      libg++-devel
238
239 %description -n libstdc++-devel
240 This is the GNU implementation of the standard C++ libraries. This
241 package includes the header files and libraries needed for C++
242 development.
243
244 %description -l pl -n libstdc++-devel
245 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
246 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
247 programowaniu w jêzyku C++.
248
249 %package -n libstdc++-static
250 Summary:        Static c++ standard library
251 Summary(pl):    Biblioteka statyczna c++
252 Group:          Development/Libraries
253 Group(de):      Entwicklung/Libraries
254 Group(fr):      Development/Librairies
255 Group(pl):      Programowanie/Biblioteki
256 Version:        %{STDC_VERSION}
257 Requires:       libstdc++-devel = %{STDC_VERSION}
258
259 %description -n libstdc++-static
260 Static c++ standard library.
261
262 %description -l pl -n libstdc++-static
263 Biblioteka statyczna C++.
264
265 %package -n cpp
266 Summary:        The C Pre Processor
267 Summary(pl):    Preprocesor C
268 Group:          Development/Languages
269 Group(de):      Entwicklung/Sprachen
270 Group(pl):      Programowanie/Jêzyki
271 Obsoletes:      egcs-cpp
272 Obsoletes:      gcc-cpp
273
274 %description -n cpp
275 The C preprocessor is a "macro processor" that is used automatically
276 by the C compiler to transform your program before actual compilation.
277 It is called a macro processor because it allows you to define
278 "macros", which are brief abbreviations for longer constructs.
279
280 The C preprocessor provides four separate facilities that you can use
281 as you see fit:
282
283 - Inclusion of header files. These are files of declarations that can
284   be substituted into your program.
285 - Macro expansion. You can define "macros", which are abbreviations
286   for arbitrary fragments of C code, and then the C preprocessor will
287   replace the macros with their definitions throughout the program.
288 - Conditional compilation. Using special preprocessing directives, you
289   can include or exclude parts of the program according to various
290   conditions.
291 - Line control. If you use a program to combine or rearrange source
292   files into an intermediate file which is then compiled, you can use
293   line control to inform the compiler of where each source line
294   originally came from.
295
296 %description -l pl -n cpp
297 Preprocesor C jest "makro procesorem" który jest automatycznie
298 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
299 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
300 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
301 d³ugich konstrukcji w jêzyku C.
302
303 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
304
305 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
306   deklaracji polecenia do³±czenia innego pliku.
307 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
308   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
309   identyfikatora deklarowan± wcze¶niej warto¶ci±.
310 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
311   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
312   fragmenty obrabianego strumienia tekstów.
313 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
314   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
315   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
316   odpowiada fragment pliku wynikowego.
317
318 %prep
319 %setup -q
320 %patch0 -p1
321 %patch1 -p1
322 %patch2 -p1
323 %patch3 -p1
324 %patch4 -p0
325 %patch5 -p0
326 %patch6 -p0
327 %patch7 -p0
328 %patch8 -p0
329 %patch9 -p0
330 %patch10 -p0
331 %patch11 -p1
332 %ifarch m68k
333 %patch12 -p0
334 %endif
335 %ifarch sparc sparc32
336 %patch13 -p0
337 %patch14 -p0
338 %endif
339 %ifarch ppc
340 %patch15 -p0
341 %patch16 -p0
342 %endif
343 %ifarch alpha
344 %patch17 -p1
345 %endif
346 %patch18 -p0
347 %patch19 -p0
348 %patch20 -p0
349 %patch21 -p1
350
351 %build
352 (cd gcc; autoconf)
353 rm -rf obj-%{_target_platform}
354 install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
355
356 CFLAGS="%{rpmcflags}" \
357 CXXFLAGS="%{rpmcflags}" \
358 TEXCONFIG=false ../configure \
359         --prefix=%{_prefix} \
360         --infodir=%{_infodir} \
361         --enable-shared \
362 %ifnarch sparc sparc64
363         --enable-threads=posix \
364         --enable-haifa \
365 %endif
366         --with-gnu-as \
367         --with-gnu-ld \
368         --with-gxx-include-dir="\$\{prefix\}/include/g++" \
369         --disable-nls \
370         %{_target_platform}
371
372 PATH=$PATH:/sbin:%{_sbindir}
373 touch  ../gcc/c-gperf.h
374
375 cd ..
376 %{__make} -C obj-%{_target_platform} bootstrap \
377         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
378         mandir=%{_mandir} \
379         infodir=%{_infodir}
380
381 %install
382 rm -rf $RPM_BUILD_ROOT
383 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
384
385 cd obj-%{_target_platform}
386 PATH=$PATH:/sbin:%{_sbindir}
387
388 %{__make} install \
389         prefix=$RPM_BUILD_ROOT%{_prefix} \
390         mandir=$RPM_BUILD_ROOT%{_mandir} \
391         infodir=$RPM_BUILD_ROOT%{_infodir}
392
393 %{__make} install \
394         prefix=$RPM_BUILD_ROOT%{_prefix} \
395         mandir=$RPM_BUILD_ROOT%{_mandir} \
396         infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
397
398 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
399
400 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
401 echo .so cccp.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1
402 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
403
404 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
405 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
406 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
407
408 gzip -9nf ../READ* ../ChangeLog ../gcc/ch/chill.brochure
409
410 %post
411 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
412
413 %postun
414 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
415
416 %post g77
417 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
418
419 %postun g77
420 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421
422 %post chill
423 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
424
425 %postun chill
426 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
427
428 %post -n cpp
429 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
430
431 %postun -n cpp
432 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
433
434 %post   -p /sbin/ldconfig -n libstdc++
435 %postun -p /sbin/ldconfig -n libstdc++
436
437 %clean
438 rm -rf $RPM_BUILD_ROOT
439
440 %files
441 %defattr(644,root,root,755)
442 %doc READ* ChangeLog.gz
443
444 %dir %{_libdir}/gcc-lib
445 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
446 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
447 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
448
449 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
450 %attr(755,root,root) %{_bindir}/gcc
451 %attr(755,root,root) %{_bindir}/gcov
452 %attr(755,root,root) %{_bindir}/protoize
453 %attr(755,root,root) %{_bindir}/unprotoize
454 %attr(755,root,root) %{_bindir}/cc
455
456 %{_mandir}/man1/gcc.1*
457 %{_mandir}/man1/gcov.1*
458 %{_infodir}/gcc*
459
460 %{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
461 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
462 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
463 %{_libdir}/gcc-lib/%{_target_cpu}*/*/lib*.map
464 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
465
466 %ifnarch alpha
467 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
468 %endif
469
470 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
471
472 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
473 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
474 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
475 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
476 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
477 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
478 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
479 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
480 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/va-*.h
481 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
482
483 %files c++
484 %defattr(644,root,root,755)
485
486 %{_mandir}/man1/g++.1.gz
487
488 %attr(755,root,root) %{_bindir}/g++
489 %attr(755,root,root) %{_bindir}/c++
490 %attr(755,root,root) %{_bindir}/c++filt
491 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
492
493 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/exception
494 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new
495 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/typeinfo
496 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new.h
497
498 %files objc
499 %defattr(644,root,root,755)
500
501 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
502
503 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
504 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
505
506 %files g77
507 %defattr(644,root,root,755)
508
509 %attr(755,root,root) %{_bindir}/g77
510 %attr(755,root,root) %{_bindir}/f77
511
512 %{_infodir}/g77*
513
514 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
515 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
516
517 %{_mandir}/man1/g77.1*
518 %{_mandir}/man1/f77.1*
519
520 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
521
522 %files chill
523 %defattr(644,root,root,755)
524 %doc gcc/ch/chill.brochure.gz
525
526 %attr(755,root,root) %{_bindir}/chill
527
528 %{_infodir}/chill*
529
530 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
531 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
532 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
533
534 %files java
535 %defattr(644,root,root,755)
536
537 %attr(755,root,root) %{_bindir}/gcj
538 %attr(755,root,root) %{_bindir}/gcjh
539 %attr(755,root,root) %{_bindir}/jcf-dump
540 %attr(755,root,root) %{_bindir}/jv-scan
541
542 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
543 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
544
545 %files -n libstdc++
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
548
549 %files -n libstdc++-devel
550 %defattr(644,root,root,755)
551 %{_includedir}/g++
552 %attr(755,root,root) %{_libdir}/libstdc++.so
553
554 %files -n libstdc++-static
555 %defattr(644,root,root,755)
556 %attr(644,root,root) %{_libdir}/libstdc++.a
557
558 %files -n cpp
559 %defattr(644,root,root,755)
560 %attr(755,root,root) /lib/cpp
561 %attr(755,root,root) %{_bindir}/cpp
562 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
563
564 %{_mandir}/man1/cpp.1*
565 %{_mandir}/man1/cccp.1*
566 %{_infodir}/cpp.info*.gz
This page took 0.081377 seconds and 2 git commands to generate.