]> git.pld-linux.org Git - packages/gc.git/commitdiff
- updated to 7.2 auto/th/gc-7_2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 23 May 2012 08:04:21 +0000 (08:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete sparc patch
- added C++ interface (as -c++-* subpackages)
- needs newer libatomic_ops (with pkg-config file)

Changed files:
    gc-sparc.patch -> 1.4
    gc.spec -> 1.44

gc-sparc.patch [deleted file]
gc.spec

diff --git a/gc-sparc.patch b/gc-sparc.patch
deleted file mode 100644 (file)
index 6899d65..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- gc-7.0/configure.ac.orig   2008-01-28 13:43:25.000000000 +0000
-+++ gc-7.0/configure.ac        2008-01-28 13:44:30.000000000 +0000
-@@ -392,6 +392,9 @@
-     dnl This is now redundant, but it is also important for incremental GC
-     dnl performance under Irix.
-     ;;
-+ sparc*-*-linux*) 
-+    machdep="mach_dep.lo sparc_mach_dep.lo"
-+    ;; 
-  sparc-*-netbsd*)
-     machdep="mach_dep.lo sparc_netbsd_mach_dep.lo"
-     ;;
---- gc-7.1/mach_dep.c.orig     2007-08-13 23:49:11.000000000 +0200
-+++ gc-7.1/mach_dep.c  2008-05-28 23:35:02.259767061 +0200
-@@ -175,7 +175,7 @@
- #   if defined(HAVE_PUSH_REGS)
-       GC_push_regs();
- #   elif defined(UNIX_LIKE) && !defined(DARWIN) && !defined(ARM32) && \
--       !defined(HURD)
-+       !defined(HURD) && !(defined(SPARC) && !defined(__arch64__))
-       /* Older versions of Darwin seem to lack getcontext(). */
-       /* ARM Linux often doesn't support a real getcontext(). */
-       ucontext_t ctxt;
diff --git a/gc.spec b/gc.spec
index a421eb16b31a0374c0ead877e7a53ec05f4c0636..5d4cd383edba47104617ffe4588322c8e2f78e5e 100644 (file)
--- a/gc.spec
+++ b/gc.spec
@@ -1,18 +1,18 @@
 Summary:       The Boehm-Demers-Weiser conservative garbage collector
 Summary(pl.UTF-8):     Konserwatywny odśmiecacz pamięci Boehma-Demersa-Weisera
 Name:          gc
-Version:       7.1
-Release:       2
+Version:       7.2
+Release:       1
 License:       BSD-like
 Group:         Libraries
 Source0:       http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}-%{version}.tar.gz
-# Source0-md5: 2ff9924c7249ef7f736ecfe6f08f3f9b
-Patch0:                %{name}-sparc.patch
+# Source0-md5: d17aecedef3d73e75387fb63558fa4eb
 URL:           http://www.hpl.hp.com/personal/Hans_Boehm/gc/
-BuildRequires: autoconf >= 2.53
+BuildRequires: autoconf >= 2.64
 BuildRequires: automake
-BuildRequires: libatomic_ops
-BuildRequires: libtool
+BuildRequires: libatomic_ops >= 7.2
+BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:1.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -51,13 +51,48 @@ Static version of gc library
 %description static -l pl.UTF-8
 Statyczna wersja biblioteki gc
 
+%package c++
+Summary:       C++ interface to GC library
+Summary(pl.UTF-8):     Interfejs C++ do biblioteki GC
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description c++
+C++ interface to GC library.
+
+%description c++ -l pl.UTF-8
+Interfejs C++ do biblioteki GC.
+
+%package c++-devel
+Summary:       Header files for C++ interface for GC library
+Summary(pl.UTF-8):     Pliki nagłówkowe interfejsu C++ do biblioteki GC
+Group:         Development/Libraries
+Requires:      %{name}-c++ = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      libstdc++-devel
+
+%description c++-devel
+Header files for C++ interface for GC library.
+
+%description c++-devel -l pl.UTF-8
+Pliki nagłówkowe interfejsu C++ do biblioteki GC.
+
+%package c++-static
+Summary:       C++ interface to GC library - static library
+Summary(pl.UTF-8):     Interfejs C++ do biblioteki GC - biblioteka statyczna
+Group:         Development/Libraries
+Requires:      %{name}-c++-devel = %{version}-%{release}
+
+%description c++-static
+C++ interface to GC library - static library.
+
+%description c++-static -l pl.UTF-8
+Interfejs C++ do biblioteki GC - biblioteka statyczna.
+
 %prep
 %setup -q
-%patch0 -p1
-
-# kill libtool.m4 inclusion
-%{__perl} -pi -e 's/^sinclude.*//' acinclude.m4
 
+# don't install docs to %{_datadir}/%{name}
 %{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/doc.am
 
 %build
@@ -69,6 +104,7 @@ Statyczna wersja biblioteki gc
 %ifnarch sparc64
        CPPFLAGS="-DUSE_LIBC_PRIVATES" \
 %endif
+       --enable-cplusplus \
        --enable-threads=posix
 %{__make}
 
@@ -89,10 +125,12 @@ rm -rf $RPM_BUILD_ROOT
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%post   c++ -p /sbin/ldconfig
+%postun c++ -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
-%doc doc/*.html
+%doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}} doc/*.html
 %attr(755,root,root) %{_libdir}/libcord.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libcord.so.1
 %attr(755,root,root) %{_libdir}/libgc.so.*.*.*
@@ -104,7 +142,25 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libgc.so
 %{_libdir}/libcord.la
 %{_libdir}/libgc.la
-%{_includedir}/gc
+%dir %{_includedir}/gc
+%{_includedir}/gc/private
+%{_includedir}/gc/cord.h
+%{_includedir}/gc/gc.h
+%{_includedir}/gc/gc_allocator.h
+%{_includedir}/gc/gc_amiga_redirects.h
+%{_includedir}/gc/gc_backptr.h
+%{_includedir}/gc/gc_config_macros.h
+%{_includedir}/gc/gc_gcj.h
+%{_includedir}/gc/gc_inline.h
+%{_includedir}/gc/gc_mark.h
+%{_includedir}/gc/gc_pthread_redirects.h
+%{_includedir}/gc/gc_tiny_fl.h
+%{_includedir}/gc/gc_typed.h
+%{_includedir}/gc/gc_version.h
+%{_includedir}/gc/leak_detector.h
+%{_includedir}/gc/new_gc_alloc.h
+%{_includedir}/gc/weakpointer.h
+%{_includedir}/gc.h
 %{_pkgconfigdir}/bdw-gc.pc
 %{_mandir}/man3/gc.3*
 
@@ -112,3 +168,19 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libcord.a
 %{_libdir}/libgc.a
+
+%files c++
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgccpp.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgccpp.so.1
+
+%files c++-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgccpp.so
+%{_libdir}/libgccpp.la
+%{_includedir}/gc/gc_cpp.h
+%{_includedir}/gc_cpp.h
+
+%files c++-static
+%defattr(644,root,root,755)
+%{_libdir}/libgccpp.a
This page took 0.127373 seconds and 4 git commands to generate.