]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
b9dd63146604aca3ea935008597b51eedf2aee21
[packages/gc.git] / gc.spec
1 Summary:        The Boehm-Demers-Weiser conservative garbage collector
2 Summary(pl.UTF-8):      Konserwatywny odśmiecacz pamięci Boehma-Demersa-Weisera
3 Name:           gc
4 Version:        7.2d
5 Release:        1
6 License:        BSD-like
7 Group:          Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}-%{version}.tar.gz
9 # Source0-md5:  91340b28c61753a789eb6077675d87d2
10 Patch0:         %{name}-ac.patch
11 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
12 BuildRequires:  autoconf >= 2.64
13 BuildRequires:  automake
14 BuildRequires:  libatomic_ops >= 7.2
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Gc is a conservative garbage collector for C and C++. It is used as a
21 replacement for standard malloc() and free(). GC_malloc will attempt
22 to reclaim inaccessible space automatically by invoking a conservative
23 garbage collector at appropriate points.
24
25 %description -l pl.UTF-8
26 Gc jest konserwatywnym odśmiecaczem pamięci dla C i C++. Jest używany
27 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
28 próbuje odzyskać niedostępna pamięć automatycznie przez wywoływanie
29 konserwatywnego odśmiecacza pamięci w odpowiednich miejscach.
30
31 %package devel
32 Summary:        Headers for conservative garbage collector
33 Summary(pl.UTF-8):      Nagłówki dla konserwatywnego odśmiecacza pamięci
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       libatomic_ops >= 7.2
37
38 %description devel
39 Headers for conservative garbage collector
40
41 %description devel -l pl.UTF-8
42 Nagłówki dla konserwatywnego odśmiecacza pamięci
43
44 %package static
45 Summary:        Static version of gc library
46 Summary(pl.UTF-8):      Statyczna wersja biblioteki gc
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static version of gc library
52
53 %description static -l pl.UTF-8
54 Statyczna wersja biblioteki gc
55
56 %package c++
57 Summary:        C++ interface to GC library
58 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC
59 Group:          Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description c++
63 C++ interface to GC library.
64
65 %description c++ -l pl.UTF-8
66 Interfejs C++ do biblioteki GC.
67
68 %package c++-devel
69 Summary:        Header files for C++ interface for GC library
70 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki GC
71 Group:          Development/Libraries
72 Requires:       %{name}-c++ = %{version}-%{release}
73 Requires:       %{name}-devel = %{version}-%{release}
74 Requires:       libstdc++-devel
75
76 %description c++-devel
77 Header files for C++ interface for GC library.
78
79 %description c++-devel -l pl.UTF-8
80 Pliki nagłówkowe interfejsu C++ do biblioteki GC.
81
82 %package c++-static
83 Summary:        C++ interface to GC library - static library
84 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC - biblioteka statyczna
85 Group:          Development/Libraries
86 Requires:       %{name}-c++-devel = %{version}-%{release}
87
88 %description c++-static
89 C++ interface to GC library - static library.
90
91 %description c++-static -l pl.UTF-8
92 Interfejs C++ do biblioteki GC - biblioteka statyczna.
93
94 %prep
95 %setup -q -n %{name}-7.2
96 %patch0 -p0
97
98 # don't install docs to %{_datadir}/%{name}
99 %{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/doc.am
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__automake}
106 %configure \
107 %ifnarch sparc64
108         CPPFLAGS="-DUSE_LIBC_PRIVATES" \
109 %endif
110         --enable-cplusplus \
111         --enable-threads=posix
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
121 install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
122 # are these still needed? (what is ecls?)
123 install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %post   c++ -p /sbin/ldconfig
132 %postun c++ -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}} doc/*.html
137 %attr(755,root,root) %{_libdir}/libcord.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libcord.so.1
139 %attr(755,root,root) %{_libdir}/libgc.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libgc.so.1
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libcord.so
145 %attr(755,root,root) %{_libdir}/libgc.so
146 %{_libdir}/libcord.la
147 %{_libdir}/libgc.la
148 %dir %{_includedir}/gc
149 %{_includedir}/gc/private
150 %{_includedir}/gc/cord.h
151 %{_includedir}/gc/gc.h
152 %{_includedir}/gc/gc_allocator.h
153 %{_includedir}/gc/gc_amiga_redirects.h
154 %{_includedir}/gc/gc_backptr.h
155 %{_includedir}/gc/gc_config_macros.h
156 %{_includedir}/gc/gc_gcj.h
157 %{_includedir}/gc/gc_inline.h
158 %{_includedir}/gc/gc_mark.h
159 %{_includedir}/gc/gc_pthread_redirects.h
160 %{_includedir}/gc/gc_tiny_fl.h
161 %{_includedir}/gc/gc_typed.h
162 %{_includedir}/gc/gc_version.h
163 %{_includedir}/gc/leak_detector.h
164 %{_includedir}/gc/new_gc_alloc.h
165 %{_includedir}/gc/weakpointer.h
166 %{_includedir}/gc.h
167 %{_pkgconfigdir}/bdw-gc.pc
168 %{_mandir}/man3/gc.3*
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libcord.a
173 %{_libdir}/libgc.a
174
175 %files c++
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libgccpp.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libgccpp.so.1
179
180 %files c++-devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libgccpp.so
183 %{_libdir}/libgccpp.la
184 %{_includedir}/gc/gc_cpp.h
185 %{_includedir}/gc_cpp.h
186
187 %files c++-static
188 %defattr(644,root,root,755)
189 %{_libdir}/libgccpp.a
This page took 0.08031 seconds and 2 git commands to generate.