]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
- release 2 -- rebuild on nest builders
[packages/gc.git] / gc.spec
1 Summary:        Conservative garbage collector
2 Summary(pl):    Konserwatywny od¶miecacz pamiêci
3 Name:           gc
4 Version:        6.1
5 Release:        2
6 License:        BSD-like
7 Group:          Development/Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}%{version}.tar.gz
9 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
10 BuildRequires:  automake
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Gc is a conservative garbage collector for C and C++. It is used as a
15 replacement for standard malloc() and free(). GC_malloc will attempt
16 to reclaim inaccessible space automatically by invoking a conservative
17 garbage collector at appropriate points.
18
19 %description -l pl
20 Gc jest konserwatywnym od¶miecaczem pamiêci dla C i C++. Jest u¿ywany
21 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
22 próbuje odzyskaæ niedostêpna pamiêc automatycznie przez wywo³ywanie
23 konserwatywnego od¶miecacza pamiêci w odpowiednich miejscach.
24
25 %package devel
26 Summary:        Headers for conservative garbage collector
27 Summary(pl):    Nag³ówki dla konserwatywnego od¶miecacza pamiêci
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}
30
31 %description devel
32 Headers for conservative garbage collector
33
34 %description devel -l pl
35 Nag³ówki dla konserwatywnego od¶miecacza pamiêci
36
37 %package static
38 Summary:        Static version of gc library
39 Summary(pl):    Statyczna wersja biblioteki gc
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}
42
43 %description static
44 Static version of gc library
45
46 %description static -l pl
47 Statyczna wersja biblioteki gc
48
49 %prep
50 %setup -q -n %{name}%{version}
51
52 %build
53 cp -f /usr/share/automake/config.* .
54 %configure2_13
55 sed -e 's/-lpthread/& -ldl/' Makefile > Makefile.tmp
56 mv -f Makefile.tmp Makefile
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{_includedir}/gc
65 cp -ar include/* $RPM_BUILD_ROOT%{_includedir}/gc
66
67 install -d $RPM_BUILD_ROOT%{_mandir}/man3
68 install doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
79 %doc doc/*.html
80 %attr(755,root,root) %{_libdir}/*.so.*.*
81
82 %files devel
83 %defattr(644,root,root,755)
84 %{_includedir}/gc
85 %{_libdir}/*.so
86 %{_libdir}/*.la
87 %{_mandir}/*/*
88
89 %files static
90 %defattr(644,root,root,755)
91 %{_libdir}/*.a
This page took 0.063437 seconds and 3 git commands to generate.