]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
- don't install Makefiles
[packages/gc.git] / gc.spec
1 Summary:        Conservative garbage collector
2 Summary(pl):    Konserwatywny od¶miecacz pamiêci
3 Name:           gc
4 Version:        6.2
5 Release:        2
6 License:        BSD-like
7 Group:          Development/Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}%{version}.tar.gz
9 # Source0-md5:  15492b14ca7b9a9e035238611e9cd1e3
10 Patch0:         %{name}-ac_libdl_fix.patch
11 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Gc is a conservative garbage collector for C and C++. It is used as a
19 replacement for standard malloc() and free(). GC_malloc will attempt
20 to reclaim inaccessible space automatically by invoking a conservative
21 garbage collector at appropriate points.
22
23 %description -l pl
24 Gc jest konserwatywnym od¶miecaczem pamiêci dla C i C++. Jest u¿ywany
25 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
26 próbuje odzyskaæ niedostêpna pamiêc automatycznie przez wywo³ywanie
27 konserwatywnego od¶miecacza pamiêci w odpowiednich miejscach.
28
29 %package devel
30 Summary:        Headers for conservative garbage collector
31 Summary(pl):    Nag³ówki dla konserwatywnego od¶miecacza pamiêci
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}
34
35 %description devel
36 Headers for conservative garbage collector
37
38 %description devel -l pl
39 Nag³ówki dla konserwatywnego od¶miecacza pamiêci
40
41 %package static
42 Summary:        Static version of gc library
43 Summary(pl):    Statyczna wersja biblioteki gc
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}
46
47 %description static
48 Static version of gc library
49
50 %description static -l pl
51 Statyczna wersja biblioteki gc
52
53 %prep
54 %setup -q -n %{name}%{version}
55 %patch0 -p1
56
57 %build
58 rm -f acinclude.m4
59 %{__libtoolize}
60 %{__aclocal}
61 %{__autoconf}
62 %{__automake}
63 %configure \
64         --enable-threads=posix
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_includedir}/gc,%{_mandir}/man3}
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 rm -f include/Makefile*
75 cp -ar include/* $RPM_BUILD_ROOT%{_includedir}/gc
76 install doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
87 %doc doc/*.html
88 %attr(755,root,root) %{_libdir}/*.so.*.*
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/gc
93 %{_libdir}/*.so
94 %{_libdir}/*.la
95 %{_mandir}/*/*
96
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/*.a
This page took 0.053336 seconds and 3 git commands to generate.