]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
1af687d0454e7ecbe370935acbe200b85bbbb8f4
[packages/gc.git] / gc.spec
1 Summary:        Conservative garbage collector
2 Summary(pl):    Konserwatywny od¶miecacz pamiêci
3 Name:           gc
4 Version:        6.1
5 Release:        1
6 License:        BSD-like
7 Group:          Development/Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}%{version}.tar.gz
9 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 Gc is a conservative garbage collector for C and C++. It is used as a
14 replacement for standard malloc() and free(). GC_malloc will attempt
15 to reclaim inaccessible space automatically by invoking a conservative
16 garbage collector at appropriate points.
17
18 %description -l pl
19 Gc jest konserwatywnym od¶miecaczem pamiêci dla C i C++. Jest u¿ywany
20 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
21 próbuje odzyskaæ niedostêpna pamiêc automatycznie przez wywo³ywanie
22 konserwatywnego od¶miecacza pamiêci w odpowiednich miejscach.
23
24 %package devel
25 Summary:        Headers for conservative garbage collector
26 Summary(pl):    Nag³ówki dla konserwatywnego od¶miecacza pamiêci
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}
29
30 %description devel
31 Headers for conservative garbage collector
32
33 %description devel -l pl
34 Nag³ówki dla konserwatywnego od¶miecacza pamiêci
35
36 %package static
37 Summary:        Static version of gc library
38 Summary(pl):    Statyczna wersja biblioteki gc
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}
41
42 %description static
43 Static version of gc library
44
45 %description static -l pl
46 Statyczna wersja biblioteki gc
47
48 %prep
49 %setup -q -n %{name}%{version}
50
51 %build
52 cp -f /usr/share/automake/config.* .
53 %configure2_13
54 sed -e 's/-lpthread/& -ldl/' Makefile > Makefile.tmp
55 mv -f Makefile.tmp Makefile
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_includedir}/gc
64 cp -ar include/* $RPM_BUILD_ROOT%{_includedir}/gc
65
66 install -d $RPM_BUILD_ROOT%{_mandir}/man3
67 cp doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
78 %doc doc/*.html
79 %attr(755,root,root) %{_libdir}/*.so.*.*
80
81 %files devel
82 %defattr(644,root,root,755)
83 %{_includedir}/gc
84 %{_libdir}/*.so
85 %{_libdir}/*.la
86 %{_mandir}/*/*
87
88 %files static
89 %defattr(644,root,root,755)
90 %{_libdir}/*.a
This page took 0.648044 seconds and 2 git commands to generate.