]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
10591171e4327fa4a52161f65bb75f2b9386dec4
[packages/gc.git] / gc.spec
1 Summary:        The Boehm-Demers-Weiser conservative garbage collector
2 Summary(pl.UTF-8):      Konserwatywny odśmiecacz pamięci Boehma-Demersa-Weisera
3 Name:           gc
4 # NOTE: 7.4.0 is considered experimental (as of Nov 2013)
5 Version:        7.2e
6 Release:        1
7 License:        BSD-like
8 Group:          Libraries
9 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}-%{version}.tar.gz
10 # Source0-md5:  5e230029f802d0ac633b1d9b3d4934c9
11 Patch0:         %{name}-ac.patch
12 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
13 BuildRequires:  autoconf >= 2.64
14 BuildRequires:  automake
15 BuildRequires:  libatomic_ops >= 7.2e
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Gc is a conservative garbage collector for C and C++. It is used as a
22 replacement for standard malloc() and free(). GC_malloc will attempt
23 to reclaim inaccessible space automatically by invoking a conservative
24 garbage collector at appropriate points.
25
26 %description -l pl.UTF-8
27 Gc jest konserwatywnym odśmiecaczem pamięci dla C i C++. Jest używany
28 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
29 próbuje odzyskać niedostępna pamięć automatycznie przez wywoływanie
30 konserwatywnego odśmiecacza pamięci w odpowiednich miejscach.
31
32 %package devel
33 Summary:        Headers for conservative garbage collector
34 Summary(pl.UTF-8):      Nagłówki dla konserwatywnego odśmiecacza pamięci
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libatomic_ops >= 7.2e
38
39 %description devel
40 Headers for conservative garbage collector
41
42 %description devel -l pl.UTF-8
43 Nagłówki dla konserwatywnego odśmiecacza pamięci
44
45 %package static
46 Summary:        Static version of gc library
47 Summary(pl.UTF-8):      Statyczna wersja biblioteki gc
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static version of gc library
53
54 %description static -l pl.UTF-8
55 Statyczna wersja biblioteki gc
56
57 %package c++
58 Summary:        C++ interface to GC library
59 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC
60 Group:          Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description c++
64 C++ interface to GC library.
65
66 %description c++ -l pl.UTF-8
67 Interfejs C++ do biblioteki GC.
68
69 %package c++-devel
70 Summary:        Header files for C++ interface for GC library
71 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki GC
72 Group:          Development/Libraries
73 Requires:       %{name}-c++ = %{version}-%{release}
74 Requires:       %{name}-devel = %{version}-%{release}
75 Requires:       libstdc++-devel
76
77 %description c++-devel
78 Header files for C++ interface for GC library.
79
80 %description c++-devel -l pl.UTF-8
81 Pliki nagłówkowe interfejsu C++ do biblioteki GC.
82
83 %package c++-static
84 Summary:        C++ interface to GC library - static library
85 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC - biblioteka statyczna
86 Group:          Development/Libraries
87 Requires:       %{name}-c++-devel = %{version}-%{release}
88
89 %description c++-static
90 C++ interface to GC library - static library.
91
92 %description c++-static -l pl.UTF-8
93 Interfejs C++ do biblioteki GC - biblioteka statyczna.
94
95 %prep
96 %setup -q -n %{name}-7.2
97 %patch0 -p0
98
99 # don't install docs to %{_datadir}/%{name}
100 %{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/doc.am
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 %configure \
108 %ifnarch sparc64
109         CPPFLAGS="-DUSE_LIBC_PRIVATES" \
110 %endif
111         --enable-cplusplus \
112         --enable-threads=posix
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
122 install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
123 # are these still needed? (what is ecls?)
124 install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %post   c++ -p /sbin/ldconfig
133 %postun c++ -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}} doc/*.html
138 %attr(755,root,root) %{_libdir}/libcord.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libcord.so.1
140 %attr(755,root,root) %{_libdir}/libgc.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libgc.so.1
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libcord.so
146 %attr(755,root,root) %{_libdir}/libgc.so
147 %{_libdir}/libcord.la
148 %{_libdir}/libgc.la
149 %dir %{_includedir}/gc
150 %{_includedir}/gc/private
151 %{_includedir}/gc/cord.h
152 %{_includedir}/gc/gc.h
153 %{_includedir}/gc/gc_allocator.h
154 %{_includedir}/gc/gc_amiga_redirects.h
155 %{_includedir}/gc/gc_backptr.h
156 %{_includedir}/gc/gc_config_macros.h
157 %{_includedir}/gc/gc_gcj.h
158 %{_includedir}/gc/gc_inline.h
159 %{_includedir}/gc/gc_mark.h
160 %{_includedir}/gc/gc_pthread_redirects.h
161 %{_includedir}/gc/gc_tiny_fl.h
162 %{_includedir}/gc/gc_typed.h
163 %{_includedir}/gc/gc_version.h
164 %{_includedir}/gc/leak_detector.h
165 %{_includedir}/gc/new_gc_alloc.h
166 %{_includedir}/gc/weakpointer.h
167 %{_includedir}/gc.h
168 %{_pkgconfigdir}/bdw-gc.pc
169 %{_mandir}/man3/gc.3*
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libcord.a
174 %{_libdir}/libgc.a
175
176 %files c++
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libgccpp.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libgccpp.so.1
180
181 %files c++-devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libgccpp.so
184 %{_libdir}/libgccpp.la
185 %{_includedir}/gc/gc_cpp.h
186 %{_includedir}/gc_cpp.h
187
188 %files c++-static
189 %defattr(644,root,root,755)
190 %{_libdir}/libgccpp.a
This page took 0.086934 seconds and 2 git commands to generate.