]> git.pld-linux.org Git - packages/gazpacho.git/blob - gazpacho.spec
BR: rpmbuild(macros) >= 1.710
[packages/gazpacho.git] / gazpacho.spec
1 Summary:        Building Interfaces the easy way
2 Summary(pl.UTF-8):      Tworzenie interfejsów w łatwy sposób
3 Name:           gazpacho
4 Version:        0.7.2
5 Release:        4
6 License:        LGPL
7 Group:          Development/Building
8 Source0:        http://ftp.acc.umu.se/pub/GNOME/sources/gazpacho/0.7/%{name}-%{version}.tar.bz2
9 # Source0-md5:  ca9c3c308a63194e6dcec3c932c98fbc
10 Patch0:         %{name}-desktop.patch
11 URL:            http://gazpacho.sicem.biz/
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 BuildRequires:  gettext-tools
14 BuildRequires:  python-devel
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  sed >= 4.0
17 BuildRequires:  python-kiwi
18 Requires:       python-pygtk-gtk >= 1:2.6.0
19 %pyrequires_eq  python-modules
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _noautocompressdoc      AUTHORS CONTRIBUTORS COPYING
24
25 %description
26 This program allows you to create the Graphical User Interface (GUI)
27 of your GTK+ program in a visual way. It started as a Glade-3 clone
28 but now it is more complete and featured than its ancestor. It tries
29 to be compatible with libglade but it can handle some widgets that
30 still lack support in libglade.
31
32 %description -l pl.UTF-8
33 Ten program pozwala tworzyć graficzny interfejs użytkownika (GUI) dla
34 programów GTK+ w sposób wizualny. Z początku był klonem Glade-3, ale w
35 chwili obecnej jest bardziej zaawansowany od swojego przodka. Gazpacho
36 stara się być kompatybilnym z libglade, choć zawiera kilka kontrolek
37 wciąż nie wspieranych przez libglade.
38
39 %prep
40 %setup -q
41 #%patch0 -p1
42
43 sed -i  -e "s/from gazpacho import application//" \
44         -e "s/application.__version__/'%{version}'/" \
45         setup.py
46
47 #sed -i -e "s@return self._variables\['docs_dir'\]\[0\]@return '/usr/share/doc/%{name}-%{version}/'@" gazpacho/environ.py
48
49 %build
50 %py_build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_pixmapsdir}}
55
56 %py_install \
57         --root $RPM_BUILD_ROOT
58
59 find $RPM_BUILD_ROOT%{py_sitescriptdir}/gazpacho -name '*.py' -exec rm -f {} \;
60
61 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
62
63 %find_lang %{name}
64
65 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66 install pixmaps/gazpacho-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/gazpacho.png
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 umask 022
73 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
74
75 %postun
76 if [ $1 = 0 ]; then
77     umask 022
78     [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
79 fi
80
81 %files -f %{name}.lang
82 %defattr(644,root,root,755)
83 # do not remove COPYING -- needed at runtime
84 %doc AUTHORS COPYING CONTRIBUTORS ChangeLog NEWS README
85 %attr(755,root,root) %{_bindir}/*
86 %{_datadir}/gazpacho
87 %{py_sitescriptdir}/gazpacho
88 %{_desktopdir}/*.desktop
89 %{_examplesdir}/%{name}-%{version}
90 %{_pixmapsdir}/*.png
This page took 0.061809 seconds and 3 git commands to generate.