]> git.pld-linux.org Git - packages/gawk.git/commitdiff
This commit was manufactured by cvs2git to create tag 'STABLE'. STABLE
authorcvs2git <feedback@pld-linux.org>
Mon, 17 Jun 2002 18:02:59 +0000 (18:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2002-06-17 18:02:59 UTC kloczek <kloczek@pld-linux.org> '- bump release to 3 and merge ja translations from Kondara.'
Cherrypick from master 2001-05-16 10:12:07 UTC kloczek <kloczek@pld-linux.org> '- use ${TEMDIR:-/tmp} instead /tmp in base directory name for temporary files.':
    gawk-DESTDIR.patch -> 1.3
    gawk-mktemp.patch -> 1.2
    gawk-unaligned.patch -> 1.1

gawk-DESTDIR.patch [new file with mode: 0644]
gawk-mktemp.patch [new file with mode: 0644]
gawk-unaligned.patch [new file with mode: 0644]

diff --git a/gawk-DESTDIR.patch b/gawk-DESTDIR.patch
new file mode 100644 (file)
index 0000000..b5e3b49
--- /dev/null
@@ -0,0 +1,102 @@
+--- gawk-3.0.6/doc/Makefile.in.wiget   Wed Jun  7 10:48:18 2000
++++ gawk-3.0.6/doc/Makefile.in Sat Sep  2 09:53:02 2000
+@@ -69,29 +69,29 @@
+ all: $(DOCS) info
+-install: $(mandir)/gawk$(manext) $(mandir)/igawk$(manext) $(infodir)/gawk.info
++install: $(DESTDIR)$(mandir)/gawk$(manext) $(DESTDIR)$(mandir)/igawk$(manext) $(DESTDIR)$(infodir)/gawk.info
+-$(infodir)/gawk.info::
++$(DESTDIR)$(infodir)/gawk.info::
+       -if test -f gawk.info; then d=.; \
+       else d=$(srcdir); fi; \
+-      if    [ -f $(infodir)/dir -a -f $(infodir)/gawk.info ] \
+-         && cmp $$d/gawk.info $(infodir)/gawk.info > /dev/null \
+-         && grep '(gawk)' $(infodir)/dir  > /dev/null; then \
++      if    [ -f $(DESTDIR)$(infodir)/dir -a -f $(DESTDIR)$(infodir)/gawk.info ] \
++         && cmp $$d/gawk.info $(DESTDIR)$(infodir)/gawk.info > /dev/null \
++         && grep '(gawk)' $(DESTDIR)$(infodir)/dir  > /dev/null; then \
+               exit 0; \
+       fi; \
+-      $(INSTALL_DATA) $$d/gawk.info $(infodir)/gawk.info ; \
++      $(INSTALL_DATA) $$d/gawk.info $(DESTDIR)$(infodir)/gawk.info ; \
+       if $(SHELL) -c 'install-info --version' > /dev/null 2>&1 ; \
+-      then install-info --info-dir=$(infodir) gawk.info ; \
++      then install-info --info-dir=$(DESTDIR)$(infodir) gawk.info ; \
+       else true ; fi; exit 0
+-$(mandir)/gawk$(manext):: gawk.1
+-      $(INSTALL_DATA) $(srcdir)/gawk.1 $(mandir)/gawk$(manext)
++$(DESTDIR)$(mandir)/gawk$(manext):: gawk.1
++      $(INSTALL_DATA) $(srcdir)/gawk.1 $(DESTDIR)$(mandir)/gawk$(manext)
+-$(mandir)/igawk$(manext):: igawk.1
+-      $(INSTALL_DATA) $(srcdir)/igawk.1 $(mandir)/igawk$(manext)
++$(DESTDIR)$(mandir)/igawk$(manext):: igawk.1
++      $(INSTALL_DATA) $(srcdir)/igawk.1 $(DESTDIR)$(mandir)/igawk$(manext)
+ uninstall:
+-      rm -f $(mandir)/gawk$(manext) $(mandir)/igawk$(manext) $(infodir)/gawk.info*
++      rm -f $(DESTDIR)$(mandir)/gawk$(manext) $(DESTDIR)$(mandir)/igawk$(manext) $(DESTDIR)$(infodir)/gawk.info*
+ dvi:  gawk.dvi
+--- gawk-3.0.6/awklib/Makefile.in.wiget        Wed Oct  7 22:33:20 1998
++++ gawk-3.0.6/awklib/Makefile.in      Sat Sep  2 09:51:10 2000
+@@ -73,13 +73,13 @@
+       sed 's;/usr/local/libexec/awk;$(libexecdir);' < groupawk.in) > group.awk
+ install: igawk $(AUXPROGS) $(AUXAWK)
+-      $(INSTALL_PROGRAM) igawk $(bindir)/igawk
++      $(INSTALL_PROGRAM) igawk $(DESTDIR)$(bindir)/igawk
+       for i in $(AUXPROGS) ; do \
+-              $(INSTALL_PROGRAM) $$i $(libexecdir)/$$i ; \
++              $(INSTALL_PROGRAM) $$i $(DESTDIR)$(libexecdir)/$$i ; \
+       done
+       for i in $(AUXAWK) $(srcdir)/eg/lib/*.awk ; do \
+               progname=`echo $$i | sed 's;.*/;;'` ; \
+-              $(INSTALL_DATA) $$i $(datadir)/$$progname ; \
++              $(INSTALL_DATA) $$i $(DESTDIR)$(datadir)/$$progname ; \
+       done
+ # libexecdir and datadir are removed in the top level Makefile's uninstall
+--- gawk-3.0.6/Makefile.in.wiget       Sun Jun 18 14:14:08 2000
++++ gawk-3.0.6/Makefile.in     Sat Sep  2 09:51:10 2000
+@@ -55,6 +55,8 @@
+ datadir = @datadir@/awk
+ libexecdir = @libexecdir@/awk
++DESTDIR =
++
+ DEFPATH = ".:$(datadir)"
+ SHELL = /bin/sh
+@@ -175,11 +177,11 @@
+ alloca.o:     alloca.c
+ install:      gawk info installdirs
+-      -rm -f $(bindir)/gawk
++      -rm -f $(DESTDIR)$(bindir)/gawk
+       fullname=gawk-$(REL).`./gawk '{print $$3}' $(srcdir)/patchlevel.h` ; \
+-      $(INSTALL_PROGRAM) gawk $(bindir)/$$fullname ; \
+-      (cd $(bindir); $(LN) $$fullname gawk)
+-      (cd $(bindir); \
++      $(INSTALL_PROGRAM) gawk $(DESTDIR)$(bindir)/$$fullname ; \
++      (cd $(DESTDIR)$(bindir); $(LN) $$fullname gawk)
++      (cd $(DESTDIR)$(bindir); \
+       if [ ! -f awk ]; \
+       then    $(LN_S) gawk awk; \
+       fi; exit 0)
+@@ -187,8 +189,9 @@
+       cd awklib && $(MAKE) install
+ installdirs: mkinstalldirs
+-      $(srcdir)/mkinstalldirs $(bindir) $(datadir) \
+-              $(libdir) $(infodir) $(mandir) $(libexecdir)
++      $(srcdir)/mkinstalldirs $(DESTDIR)$(bindir) $(DESTDIR)$(datadir) \
++              $(DESTDIR)$(libdir) $(DESTDIR)$(infodir) $(DESTDIR)$(mandir) \
++              $(DESTDIR)$(libexecdir)
+ install-strip:
+       $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install
diff --git a/gawk-mktemp.patch b/gawk-mktemp.patch
new file mode 100644 (file)
index 0000000..66c11b4
--- /dev/null
@@ -0,0 +1,86 @@
+--- gawk-3.0.3.orig/awklib/eg/prog/igawk.sh
++++ gawk-3.0.3/awklib/eg/prog/igawk.sh
+@@ -4,13 +4,16 @@
+ # Arnold Robbins, arnold@gnu.ai.mit.edu, Public Domain
+ # July 1993
++igs=`mktemp ${TEMDIR:-/tmp}/ig.s.XXXXXX` || exit 1
++ige=`mktemp ${TEMDIR:-/tmp}/ig.e.XXXXXX` || exit 1
++
+ if [ "$1" = debug ]
+ then
+     set -x
+     shift
+ else
+     # cleanup on exit, hangup, interrupt, quit, termination
+-    trap 'rm -f /tmp/ig.[se].$$' 0 1 2 3 15
++    trap 'rm -f $igs $ige' 0 1 2 3 15
+ fi
+ while [ $# -ne 0 ] # loop over arguments
+@@ -27,26 +30,26 @@
+     -[vF]*) opts="$opts '$1'" ;;
+-    -f)     echo @include "$2" >> /tmp/ig.s.$$
++    -f)     echo @include "$2" >> $igs
+             shift;;
+     -f*)    f=`echo "$1" | sed 's/-f//'`
+-            echo @include "$f" >> /tmp/ig.s.$$ ;;
++            echo @include "$f" >> $igs ;;
+     -?file=*)    # -Wfile or --file
+             f=`echo "$1" | sed 's/-.file=//'`
+-            echo @include "$f" >> /tmp/ig.s.$$ ;;
++            echo @include "$f" >> $igs ;;
+     -?file)    # get arg, $2
+-            echo @include "$2" >> /tmp/ig.s.$$
++            echo @include "$2" >> $igs
+             shift;;
+     -?source=*)    # -Wsource or --source
+             t=`echo "$1" | sed 's/-.source=//'`
+-            echo "$t" >> /tmp/ig.s.$$ ;;
++            echo "$t" >> $igs ;;
+     -?source)  # get arg, $2
+-            echo "$2" >> /tmp/ig.s.$$
++            echo "$2" >> $igs
+             shift;;
+     -?version)
+@@ -61,19 +64,19 @@
+     shift
+ done
+-if [ ! -s /tmp/ig.s.$$ ]
++if [ ! -s $igs ]
+ then
+     if [ -z "$1" ]
+     then
+          echo igawk: no program! 1>&2
+          exit 1
+     else
+-        echo "$1" > /tmp/ig.s.$$
++        echo "$1" > $igs
+         shift
+     fi
+ fi
+-# at this point, /tmp/ig.s.$$ has the program
++# at this point, $igs has the program
+ gawk -- '
+ # process @include directives
+@@ -124,7 +127,7 @@
+         }
+         close(input[stackptr])
+     }
+-}' /tmp/ig.s.$$ > /tmp/ig.e.$$
+-eval gawk -f /tmp/ig.e.$$ $opts -- "$@"
++}' $igs > $ige
++eval gawk -f $ige $opts -- "$@"
+ exit $?
diff --git a/gawk-unaligned.patch b/gawk-unaligned.patch
new file mode 100644 (file)
index 0000000..d66c5f5
--- /dev/null
@@ -0,0 +1,37 @@
+
+From davidm@AZStarNet.com Mon Sep  2 10:39:42 1996
+Date: Sun, 1 Sep 1996 21:06:10 -0700
+From: David Mosberger-Tang <davidm@AZStarNet.com>
+To: ewt@redhat.com
+Cc: richard@atheist.tamu.edu
+Subject: awk fix
+
+The patch below fixes the unaligned accesses.  This is a genuine bug,
+so it's better to fix it asap (not that unaligned accesses are not
+worth fixing...).
+
+The problem is as follows: re_syntax_options is a bss symbol in libc
+that is 4 bytes long.  GNU awk comes with its own regex.{h,c} files
+and there, that variable is declared as an `unsigned long' common
+symbol.  The runtimes linker then resolves that symbol to the instance
+in the shared library.  So gawk accesses that variable as a "long"
+while in reality it's just 4 bytes long.
+
+Actually, the linker warns about this.  Probably good to keep an eye
+open for these:
+
+ld: Warning: size of symbol `re_syntax_options' changed from 8 to 4 in /lib/libc.so.6
+
+       --david
+
+--- gawk-3.0.0/regex.c.~1~     Fri Dec 15 04:53:05 1995
++++ gawk-3.0.0/regex.c Sun Sep  1 19:10:54 1996
+@@ -920,7 +920,7 @@
+    syntax, so it can be changed between regex compilations.  */
+ /* This has no initializer because initialized variables in Emacs
+    become read-only after dumping.  */
+-reg_syntax_t re_syntax_options;
++reg_syntax_t re_syntax_options = 0;
+ /* Specify the precise syntax of regexps for compilation.  This provides
This page took 0.093805 seconds and 4 git commands to generate.