]> git.pld-linux.org Git - packages/gawk.git/commitdiff
up to 5.3.0 master auto/th/gawk-5.3.0-1
authorJan Palus <atler@pld-linux.org>
Fri, 3 Nov 2023 23:59:11 +0000 (00:59 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 3 Nov 2023 23:59:11 +0000 (00:59 +0100)
gawk-4.2.0-000-do-not-fold-constant-strings.patch [deleted file]
gawk-4.2.0-001-rwarray-small-improvements.patch [deleted file]
gawk-info.patch
gawk-shutup.patch
gawk.spec
no-pty-test.patch

diff --git a/gawk-4.2.0-000-do-not-fold-constant-strings.patch b/gawk-4.2.0-000-do-not-fold-constant-strings.patch
deleted file mode 100644 (file)
index eb4a0b0..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From 08897b5c5facfd35aa971321a248e6fcd6abf5d8 Mon Sep 17 00:00:00 2001
-From: "Arnold D. Robbins" <arnold@skeeve.com>
-Date: Sat, 21 Oct 2017 20:59:19 +0300
-Subject: [PATCH] Don't fold constant strings if either is translatable.
-
----
- awkgram.y | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/awkgram.y b/awkgram.y
-index 1a75e64..9f35143 100644
---- a/awkgram.y
-+++ b/awkgram.y
-@@ -1589,7 +1589,8 @@ common_exp
-                       // 1.5 ""   # can't fold this if program mucks with CONVFMT.
-                       // See test #12 in test/posix.awk.
--                      if ((n1->flags & (NUMBER|NUMINT)) != 0 || (n2->flags & (NUMBER|NUMINT)) != 0)
-+                      // Also can't fold if one or the other is translatable.
-+                      if ((n1->flags & (NUMBER|NUMINT|INTLSTR)) != 0 || (n2->flags & (NUMBER|NUMINT|INTLSTR)) != 0)
-                               goto plain_concat;
-                       n1 = force_string(n1);
--- 
-2.9.5
-
diff --git a/gawk-4.2.0-001-rwarray-small-improvements.patch b/gawk-4.2.0-001-rwarray-small-improvements.patch
deleted file mode 100644 (file)
index 10059bd..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-From 750e3168705de678474fea0a551f9cf29e9e077d Mon Sep 17 00:00:00 2001
-From: "Arnold D. Robbins" <arnold@skeeve.com>
-Date: Sat, 28 Oct 2017 23:22:15 +0300
-Subject: [PATCH] Small improvements in extension/rwarray.c.
-
----
- extension/ChangeLog | 5 +++++
- extension/rwarray.c | 6 ++++--
- 2 files changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/extension/ChangeLog b/extension/ChangeLog
-index 4bfd896..c04e9c2 100644
---- a/extension/ChangeLog
-+++ b/extension/ChangeLog
-@@ -1,3 +1,8 @@
-+2017-10-28         Arnold D. Robbins     <arnold@skeeve.com>
-+
-+      * rwarray.c (do_writea): Fix description in comment.
-+      (write_array): Free the flattened array if writing an element fails.
-+
- 2017-10-19         Arnold D. Robbins     <arnold@skeeve.com>
-       * 4.2.0: Release tar ball made.
-diff --git a/extension/rwarray.c b/extension/rwarray.c
-index 2e82ca7..997b6b2 100644
---- a/extension/rwarray.c
-+++ b/extension/rwarray.c
-@@ -114,7 +114,7 @@ do_writea(int nargs, awk_value_t *result, struct awk_ext_func *unused)
-       if (nargs < 2)
-               goto out;
--      /* directory is first arg, array to dump is second */
-+      /* filename is first arg, array to dump is second */
-       if (! get_argument(0, AWK_STRING, & filename)) {
-               fprintf(stderr, _("do_writea: argument 0 is not a string\n"));
-               errno = EINVAL;
-@@ -178,8 +178,10 @@ write_array(FILE *fp, awk_array_t array)
-               return awk_false;
-       for (i = 0; i < flat_array->count; i++) {
--              if (! write_elem(fp, & flat_array->elements[i]))
-+              if (! write_elem(fp, & flat_array->elements[i])) {
-+                      (void) release_flattened_array(array, flat_array);
-                       return awk_false;
-+              }
-       }
-       if (! release_flattened_array(array, flat_array)) {
--- 
-2.9.5
-
index fedb93384f8bf841296204f0fd8a14795c0c7fb9..753ede1c9853cf76db712f1805cf2155edb0a6a7 100644 (file)
@@ -16,7 +16,7 @@
 +* awk: (gawk)gawk.                    Text scanning and processing
  @end direntry
  
- @c Enable better indexing, requires texindex from Texinfo 6 or later.
+ @ifset FOR_PRINT
 @@ -437,7 +434,7 @@
  * Getting Started::                A basic introduction to using
                                     @command{awk}. How to run an @command{awk}
@@ -56,8 +56,8 @@
 --- gawk-4.2.0/doc/gawkinet.texi.orig  2017-12-07 17:43:05.506383316 +0100
 +++ gawk-4.2.0/doc/gawkinet.texi       2017-12-07 17:49:30.369712255 +0100
 @@ -5,9 +5,9 @@
- @c %**end of header (This is for running Texinfo on a region.)
- @c FIXME: web vs. Web
+ @c https://english.stackexchange.com/questions/120869/should-i-capitalize-the-word-web-in-this-sentence
+ @c We leave the many occurrences of web in this file as they are.
  
 -@dircategory Network applications
 +@dircategory Programming Languages:
@@ -66,7 +66,7 @@
 +* awkinet: (gawkinet).                        TCP/IP Internetworking With `gawk'
  @end direntry
  
- @c Enable better indexing, requires texindex from Texinfo 6 or later.
+ @iftex
 --- gawk-4.2.0/doc/gawkworkflow.texi.orig      2017-08-17 06:58:56.000000000 +0200
 +++ gawk-4.2.0/doc/gawkworkflow.texi   2017-12-07 20:35:57.092931555 +0100
 @@ -5,13 +5,9 @@
  @end direntry
  
  @c With early 2014 texinfo.tex, restore PDF links and colors
+--- gawk-5.2.0/doc/pm-gawk.texi.orig   2022-08-25 07:35:28.000000000 +0200
++++ gawk-5.2.0/doc/pm-gawk.texi        2022-09-05 20:26:36.701023264 +0200
+@@ -21,9 +21,9 @@ pm-@gwk{}
+ @setfilename pm-gawk.info
+ @settitle @value{TYTL}
+-@dircategory Text creation and manipulation
++@dircategory Programming Languages:
+ @direntry
+-* pm-gawk: (pm-gawk).    Persistent memory version of gawk.
++* pm-gawk: (pm-gawk).                 Persistent memory version of gawk
+ @end direntry
+ @fonttextsize 11
index d414495e6dceded0eaaf154d206138327d1960f6..096441feddec0eebf41f6c44a55c0ddb68587fa2 100644 (file)
@@ -8,4 +8,4 @@
 -                      warning(_("escape sequence `\\%c' treated as plain `%c'"), uc, uc);
                }
        }
-               return c;
+               buf[0] = c;
index 2617a979c1133a7035363f9a6b89d4b94a7eca89..7ef5e2497cd50e0f0901d28c051a9f4857776a86 100644 (file)
--- a/gawk.spec
+++ b/gawk.spec
@@ -13,30 +13,28 @@ Summary(ru.UTF-8):  GNU версия утилиты обработки текст
 Summary(tr.UTF-8):     GNU araçları metin düzenleyici
 Summary(uk.UTF-8):     GNU версія утиліти обробки текстів awk
 Name:          gawk
-Version:       4.2.0
-Release:       2
+Version:       5.3.0
+Release:       1
 License:       GPL v3+
 Group:         Applications/Text
-Source0:       http://ftp.gnu.org/gnu/gawk/%{name}-%{version}.tar.lz
-# Source0-md5: 716b498c13c96c01758ab59415763e72
+Source0:       https://ftp.gnu.org/gnu/gawk/%{name}-%{version}.tar.lz
+# Source0-md5: ceacc7e6192ad5f7f6984490c680797c
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 80753d75be0f469f70e8c90e75121a9c
-Patch100:      gawk-4.2.0-000-do-not-fold-constant-strings.patch
-Patch101:      gawk-4.2.0-001-rwarray-small-improvements.patch
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-shutup.patch
 Patch2:                no-pty-test.patch
 URL:           http://www.gnu.org/software/gawk/
-BuildRequires: autoconf >= 2.69
-BuildRequires: automake >= 1:1.15
-BuildRequires: gettext-tools >= 0.19.7
+BuildRequires: autoconf >= 2.71
+BuildRequires: autoconf-archive
+BuildRequires: automake >= 1:1.16
+BuildRequires: gettext-tools >= 0.20.2
 BuildRequires: gmp-devel
-BuildRequires: libsigsegv
 BuildRequires: lzip
 BuildRequires: mpfr-devel
 BuildRequires: readline-devel
 BuildRequires: tar >= 1:1.22
-BuildRequires: texinfo >= 4.3
+BuildRequires: texinfo >= 7.1
 Requires:      mktemp
 Requires:      sed
 Obsoletes:     gawk-doc
@@ -122,8 +120,6 @@ Ten pakiet zawiera pliki nagłówkowe dla gawka.
 
 %prep
 %setup -q
-%patch100 -p1
-%patch101 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -136,7 +132,13 @@ Ten pakiet zawiera pliki nagłówkowe dla gawka.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-
+cd extension
+%{__libtoolize}
+%{__aclocal} -I m4 -I ../m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd ..
 %configure \
        --datadir=%{_libdir}
 
@@ -146,6 +148,7 @@ Ten pakiet zawiera pliki nagłówkowe dla gawka.
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -175,6 +178,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS POSIX.STD README
 %attr(755,root,root) %{_bindir}/gawk
+%attr(755,root,root) %{_bindir}/gawkbug
 %dir %{_libdir}/gawk
 %attr(755,root,root) %{_libdir}/gawk/*.so
 %dir %{_libdir}/awk
@@ -187,6 +191,8 @@ rm -rf $RPM_BUILD_ROOT
 /etc/profile.d/gawk.csh
 /etc/profile.d/gawk.sh
 %{_mandir}/man1/gawk.1*
+%{_mandir}/man1/gawkbug.1*
+%{_mandir}/man1/pm-gawk.1*
 %{_mandir}/man3/filefuncs.3am*
 %{_mandir}/man3/fnmatch.3am*
 %{_mandir}/man3/fork.3am*
@@ -204,6 +210,9 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_mandir}/ja/man1/gawk.1*
 %lang(pl) %{_mandir}/pl/man1/gawk.1*
 %{_infodir}/gawk*.info*
+%{_infodir}/gawk*.jpg
+%{_infodir}/gawk*.png
+%{_infodir}/pm-gawk.info*
 
 %files devel
 %defattr(644,root,root,755)
index 4c50ead31f9ba6bf6251ed45b44740ceb6f48797..3626fd54487b8a58259f79365477407304b46cf2 100644 (file)
@@ -1,20 +1,24 @@
---- gawk-4.2.0/test/Makefile.am.orig   2017-10-17 20:46:48.000000000 +0200
-+++ gawk-4.2.0/test/Makefile.am        2017-12-07 17:51:57.069710581 +0100
-@@ -876,8 +876,6 @@
+--- gawk-5.0.0/test/Makefile.am.orig   2019-04-07 20:53:42.000000000 +0200
++++ gawk-5.0.0/test/Makefile.am        2019-04-12 21:10:26.219201910 +0200
+@@ -934,10 +934,6 @@
        prt1eval.ok \
        prtoeval.awk \
        prtoeval.ok \
 -      pty1.awk \
 -      pty1.ok \
+-      pty2.awk \
+-      pty2.ok \
        rand-mpfr.ok \
        rand.awk \
        rand.ok \
-@@ -1261,7 +1259,7 @@
-       nastyparm negtime next nondec nondec2 nonfatal1 nonfatal2 nonfatal3 \
-       patsplit posix printfbad1 printfbad2 printfbad3 printfbad4 printhuge \
-       procinfs profile0 profile1 profile2 profile3 profile4 profile5 profile6 \
--      profile7 profile8 profile9 profile10 pty1 \
-+      profile7 profile8 profile9 profile10 \
-       rebuf regnul1 regnul2 regx8bit reginttrad reint reint2 rsgetline rsglstdin \
-       rsstart1 rsstart2 rsstart3 rstest6 \
-       shadow shadowbuiltin sortfor sortfor2 sortu sourcesplit split_after_fpat \
+@@ -1558,8 +1558,8 @@
+       printfbad1 printfbad2 printfbad3 printfbad4 printhuge procinfs \
+       profile0 profile1 profile10 profile11 profile12 profile13 \
+       profile14 profile15 profile16 profile17 profile2 profile3 \
+-      profile4 profile5 profile6 profile7 profile8 profile9 pty1 \
+-      pty2 rebuf regexsub reginttrad regnul1 regnul2 regx8bit reint \
++      profile4 profile5 profile6 profile7 profile8 profile9 \
++      rebuf regexsub reginttrad regnul1 regnul2 regx8bit reint \
+       reint2 rsgetline rsglstdin rsstart1 rsstart2 rsstart3 rstest6 \
+       sandbox1 shadow shadowbuiltin sortfor sortfor2 sortu sourcesplit \
+       split_after_fpat splitarg4 strftfld strftime strtonum strtonum1 \
This page took 0.621383 seconds and 4 git commands to generate.