]> git.pld-linux.org Git - packages/gaphor.git/blob - gaphor.spec
- typo(?)
[packages/gaphor.git] / gaphor.spec
1 Summary:        UML modeling environment written in Python
2 Summary(pl):    ¦rodowisko modelowania UML oparte o Pythona
3 Name:           gaphor
4 Version:        0.5.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Engineering
8 Source0:        http://dl.sourceforge.net/gaphor/%{name}-%{version}.tar.gz
9 # Source0-md5:  761451126030e3171d0b20fee829d800
10 Patch0:         %{name}-pluginsdir.patch
11 Patch1:         %{name}-datadir.patch
12 URL:            http://gaphor.sourceforge.net/
13 BuildRequires:  python-devel
14 Requires:       python-pygtk-gtk >= 2.0.0
15 Requires:       python-diacanvas >= 0.13
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Gaphor is an easy to use modeling environment. This means that you are
21 able to create nice UML diagrams for documentation and to assist you
22 with design decisions. Gaphor will help you create your applications.
23
24 %description -l pl
25 Gaphor jest ³atwym w u¿yciu ¶rodowiskiem do projektowania UML. To
26 znaczy u³atwia tworzenie diagramów UML dla dokumentacji oraz pomaga w
27 podejmowaniu decyzji. Gaphor u³atwia pracê przy tworzeniu aplikacji.
28
29 %prep
30 %setup -q
31 %patch0
32 %patch1
33
34 %build
35 python setup.py build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_bindir}
40
41 python setup.py install \
42         --optimize=2 \
43         --root=$RPM_BUILD_ROOT
44
45 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
46 #!/usr/bin/python -O
47 import gaphor
48 gaphor.main()
49 EOF
50
51 %find_lang %{name}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files -f %{name}.lang
57 %defattr(644,root,root,755)
58 %doc README PKG-INFO NEWS TODO AUTHORS
59 %attr(755,root,root) %{_bindir}/*
60 %dir %{py_sitescriptdir}/%{name}
61 %dir %{py_sitescriptdir}/%{name}/ui
62 %dir %{py_sitescriptdir}/%{name}/misc
63 %dir %{py_sitescriptdir}/%{name}/diagram
64 %dir %{py_sitescriptdir}/%{name}/UML
65 %{py_sitescriptdir}/%{name}/*.py[oc]
66 %{py_sitescriptdir}/%{name}/ui/*.py[oc]
67 %{py_sitescriptdir}/%{name}/misc/*.py[oc]
68 %{py_sitescriptdir}/%{name}/diagram/*.py[oc]
69 %{py_sitescriptdir}/%{name}/UML/*.py[oc]
70 %{_datadir}/%{name}
This page took 0.084922 seconds and 4 git commands to generate.