]> git.pld-linux.org Git - packages/gaphor.git/blob - gaphor.spec
- rel 4 for fixed desktop file
[packages/gaphor.git] / gaphor.spec
1 Summary:        UML modeling environment written in Python
2 Summary(pl):    ¦rodowisko modelowania UML oparte o Pythona
3 Name:           gaphor
4 Version:        0.5.0
5 Release:        4
6 License:        GPL
7 Group:          Applications/Engineering
8 Source0:        http://dl.sourceforge.net/gaphor/%{name}-%{version}.tar.gz
9 # Source0-md5:  761451126030e3171d0b20fee829d800
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-pluginsdir.patch
12 Patch1:         %{name}-datadir.patch
13 URL:            http://gaphor.sourceforge.net/
14 BuildRequires:  python-devel
15 Requires:       python-pygtk-gtk >= 2.0.0
16 Requires:       python-diacanvas >= 0.13
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Gaphor is an easy to use modeling environment. This means that you are
22 able to create nice UML diagrams for documentation and to assist you
23 with design decisions. Gaphor will help you create your applications.
24
25 %description -l pl
26 Gaphor jest ³atwym w u¿yciu ¶rodowiskiem do projektowania UML. To
27 znaczy u³atwia tworzenie diagramów UML dla dokumentacji oraz pomaga w
28 podejmowaniu decyzji. Gaphor u³atwia pracê przy tworzeniu aplikacji.
29
30 %prep
31 %setup -q
32 %patch0
33 %patch1
34
35 %build
36 python setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_bindir},%{_desktopdir}}
41
42 python setup.py install \
43         --optimize=2 \
44         --root=$RPM_BUILD_ROOT
45
46 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
47 #!/usr/bin/python -O
48 import gaphor
49 gaphor.main()
50 EOF
51
52 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
53 %find_lang %{name}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files -f %{name}.lang
59 %defattr(644,root,root,755)
60 %doc README PKG-INFO NEWS TODO AUTHORS
61 %attr(755,root,root) %{_bindir}/*
62 %dir %{py_sitescriptdir}/%{name}
63 %dir %{py_sitescriptdir}/%{name}/ui
64 %dir %{py_sitescriptdir}/%{name}/misc
65 %dir %{py_sitescriptdir}/%{name}/diagram
66 %dir %{py_sitescriptdir}/%{name}/UML
67 %{py_sitescriptdir}/%{name}/*.py[oc]
68 %{py_sitescriptdir}/%{name}/ui/*.py[oc]
69 %{py_sitescriptdir}/%{name}/misc/*.py[oc]
70 %{py_sitescriptdir}/%{name}/diagram/*.py[oc]
71 %{py_sitescriptdir}/%{name}/UML/*.py[oc]
72 %{_datadir}/%{name}
73 %{_desktopdir}/%{name}.desktop
This page took 0.053674 seconds and 4 git commands to generate.