]> git.pld-linux.org Git - packages/gaphor.git/blob - gaphor.spec
- missing pyreqeq, sorting
[packages/gaphor.git] / gaphor.spec
1 Summary:        UML modeling environment written in Python
2 Summary(pl):    ¦rodowisko modelowania UML oparte o Pythona
3 Name:           gaphor
4 Version:        0.7.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Engineering
8 Source0:        http://dl.sourceforge.net/gaphor/%{name}-%{version}.tar.gz
9 # Source0-md5:  ed771389b03f4a8ab06b4021263dbe74
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-datadir.patch
12 URL:            http://gaphor.sourceforge.net/
13 BuildRequires:  X11-Xvfb
14 BuildRequires:  python-devel
15 BuildRequires:  python-diacanvas >= 0.13
16 BuildRequires:  python-pygtk-gtk >= 2.0.0
17 %pyrequires_eq  python-libs
18 Requires:       python-diacanvas >= 0.13
19 Requires:       python-pygtk-gtk >= 2.0.0
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Gaphor is an easy to use modeling environment. This means that you are
25 able to create nice UML diagrams for documentation and to assist you
26 with design decisions. Gaphor will help you create your applications.
27
28 %description -l pl
29 Gaphor jest ³atwym w u¿yciu ¶rodowiskiem do projektowania UML. To
30 znaczy u³atwia tworzenie diagramów UML dla dokumentacji oraz pomaga w
31 podejmowaniu decyzji. Gaphor u³atwia pracê przy tworzeniu aplikacji.
32
33 %prep
34 %setup -q
35 %patch0 -p1
36
37 %build
38 /usr/X11R6/bin/Xvfb :69 -nolisten tcp -ac -terminate >/dev/null 2>&1 &
39 xvfb_pid=${!}
40 DISPLAY=:69 \
41         python setup.py build
42 kill ${xvfb_pid} >/dev/null 2>&1 || :
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_bindir},%{_desktopdir}}
47
48 /usr/X11R6/bin/Xvfb :69 -nolisten tcp -ac -terminate >/dev/null 2>&1 &
49 xvfb_pid=${!}
50 DISPLAY=:69 \
51         python setup.py install \
52                 --optimize=2 \
53                 --root=$RPM_BUILD_ROOT
54                 --build-dir=$(pwd)
55 kill ${xvfb_pid} >/dev/null 2>&1 || :
56
57 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
58 #!/usr/bin/python -O
59 import gaphor
60 gaphor.main()
61 EOF
62
63 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
64 %find_lang %{name}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files -f %{name}.lang
70 %defattr(644,root,root,755)
71 %doc README PKG-INFO NEWS TODO AUTHORS
72 %attr(755,root,root) %{_bindir}/*
73 %dir %{py_sitescriptdir}/%{name}
74 %dir %{py_sitescriptdir}/%{name}/ui
75 %dir %{py_sitescriptdir}/%{name}/misc
76 %dir %{py_sitescriptdir}/%{name}/diagram
77 %dir %{py_sitescriptdir}/%{name}/UML
78 %{py_sitescriptdir}/%{name}/*.py[oc]
79 %{py_sitescriptdir}/%{name}/ui/*.py[oc]
80 %{py_sitescriptdir}/%{name}/misc/*.py[oc]
81 %{py_sitescriptdir}/%{name}/diagram/*.py[oc]
82 %{py_sitescriptdir}/%{name}/UML/*.py[oc]
83 %{_datadir}/%{name}
84 %{_desktopdir}/%{name}.desktop
This page took 0.098911 seconds and 4 git commands to generate.