]> git.pld-linux.org Git - packages/gap.git/blob - gap.spec
perl -pi -e "s/pld-list\@pld.org.pl/feedback\@pld.org.pl/"
[packages/gap.git] / gap.spec
1 Summary:        Groups, Algorithms and Programming
2 Summary(pl):    Grupy, Algorytmy i Programowanie
3 Name:           gap
4 Version:        4.2
5 Release:        1
6 License:        distributable
7 Group:          Applications/Math
8 Group(de):      Applikationen/Mathematik
9 Group(pl):      Aplikacje/Matematyczne
10 URL:            http://www-gap.dcs.st-and.ac.uk/gap
11 Source0:        ftp://ftp-gap.dcs.st-and.ac.uk/pub/gap/gap4/%{name}4r2.zoo
12 Patch0:         %{name}-gac.patch
13 BuildRequires:  unzoo
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 GAP is a free, open and extensible software package for computation in
18 discrete abstract algebra.
19
20 %description -l pl
21 GAP jest darmowym, otwartym i rozszerzalnym pakietem oprogramowania do
22 obliczeñ dyskretnej abstrakcyjnej algebry.
23
24 %prep
25 %setup -q -c -T
26 unzoo -x %{SOURCE0}
27 %patch0 -p1
28
29 %build
30 cd gap4r2
31 mv -f cnf/configure.in cnf/configure.bak
32 sed -e 's/GP_CFLAGS//g' cnf/configure.bak > cnf/configure.in
33 %{__make} -C cnf configure.out
34 %configure2_13
35
36 mkdir -p bin/%{_target_platform}
37 cp -f cnf/configure.out bin/%{_target_platform}/configure
38 cd bin/%{_target_platform}
39 %configure2_13
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/gap/pkg,%{_examplesdir}/gap}
45
46 cd gap4r2
47
48 cp -a sysinfo.gap grp lib prim small src tbl tom trans tst $RPM_BUILD_ROOT%{_datadir}/gap/
49 cp -a pkg/example/* $RPM_BUILD_ROOT%{_examplesdir}/gap
50
51 install bin/%{_target_platform}/gap $RPM_BUILD_ROOT%{_bindir}/%{_target_platform}-gap
52 install bin/%{_target_platform}/gac $RPM_BUILD_ROOT%{_bindir}
53
54 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gap
55 #!/bin/sh
56 [ -z "\$GAP_MEM" ] && GAP_MEM=12m
57 exec %{_bindir}/%{_target_platform}-gap -m \$GAP_MEM -l %{_datadir}/gap \$*
58 EOF
59
60 cd doc
61 for i in ext new prg ref tut ; do
62         (cd $i ; dvips manual.dvi -o )
63 done
64 dvips fullindex.dvi -o
65 mv -f new/manual.ps supplement.ps
66 mv -f ext/manual.ps prgmanual.ps
67 mv -f prg/manual.ps prgtutorial.ps
68 mv -f ref/manual.ps refman.ps
69 mv -f tut/manual.ps tutorial.ps
70
71 gzip -9nf *.ps
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc gap4r2/doc/*.ps.gz gap4r2/doc/htm/*
79 %attr(755,root,root) %{_bindir}/*
80 %{_datadir}/gap
81 %{_examplesdir}/gap
This page took 0.053936 seconds and 3 git commands to generate.