]> git.pld-linux.org Git - packages/gap.git/blob - gap.spec
- added tetex-dvips to BuildRequires:
[packages/gap.git] / gap.spec
1 Summary:        Groups, Algorithms and Programming
2 Summary(pl):    Grupy, Algorytmy i Programowanie
3 Name:           gap
4 Version:        4.2
5 Release:        2
6 License:        distributable
7 Group:          Applications/Math
8 Source0:        ftp://ftp-gap.dcs.st-and.ac.uk/pub/gap/gap4/%{name}4r2.zoo
9 Patch0:         %{name}-gac.patch
10 URL:            http://www-gap.dcs.st-and.ac.uk/gap/
11 BuildRequires:  unzoo
12 BuildRequires:  tetex-dvips
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 GAP is a free, open and extensible software package for computation in
17 discrete abstract algebra.
18
19 %description -l pl
20 GAP jest darmowym, otwartym i rozszerzalnym pakietem oprogramowania do
21 obliczeñ dyskretnej abstrakcyjnej algebry.
22
23 %package share_package_demo
24 Summary:        Example share package for GAP
25 Summary(pl):    ¬ród³a przyk³adowego pakietu wspó³dzielonego dla GAP
26 Group:          Applications/Math
27 Requires:       gap >= 4.0
28
29 %description share_package_demo
30 This is an example how to add a share package to GAP (version 4).
31
32 %description share_package_demo -l pl
33 Przyk³ad, jak dodaæ wspó³dzielony pakiet do GAP (wersja 4).
34
35 %prep
36 %setup -q -c -T
37 unzoo -x %{SOURCE0}
38 %patch0 -p1
39
40 %build
41 cd gap4r2
42 mv -f cnf/configure.in cnf/configure.bak
43 sed -e 's/GP_CFLAGS//g' cnf/configure.bak > cnf/configure.in
44 %{__make} -C cnf configure.out
45 %configure2_13
46
47 mkdir -p bin/%{_target_platform}
48 cp -f cnf/configure.out bin/%{_target_platform}/configure
49 cd bin/%{_target_platform}
50 %configure2_13
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/gap/pkg,%{_examplesdir}/gap}
56
57 cd gap4r2
58
59 cp -a sysinfo.gap grp lib prim small src tbl tom trans tst $RPM_BUILD_ROOT%{_datadir}/gap/
60 cp -a pkg/example/* $RPM_BUILD_ROOT%{_examplesdir}/gap
61
62 install bin/%{_target_platform}/gap $RPM_BUILD_ROOT%{_bindir}/%{_target_platform}-gap
63 install bin/%{_target_platform}/gac $RPM_BUILD_ROOT%{_bindir}
64
65 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gap
66 #!/bin/sh
67 [ -z "\$GAP_MEM" ] && GAP_MEM=12m
68 exec %{_bindir}/%{_target_platform}-gap -m \$GAP_MEM -l %{_datadir}/gap \$*
69 EOF
70
71 cd doc
72 for i in ext new prg ref tut ; do
73         (cd $i ; dvips manual.dvi -o )
74 done
75 dvips fullindex.dvi -o
76 mv -f new/manual.ps supplement.ps
77 mv -f ext/manual.ps prgmanual.ps
78 mv -f prg/manual.ps prgtutorial.ps
79 mv -f ref/manual.ps refman.ps
80 mv -f tut/manual.ps tutorial.ps
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc gap4r2/doc/*.ps gap4r2/doc/htm/*
88 %attr(755,root,root) %{_bindir}/*
89 %{_datadir}/gap
90
91 %files share_package_demo
92 %defattr(644,root,root,755)
93 %{_examplesdir}/gap
This page took 0.064231 seconds and 3 git commands to generate.