]> git.pld-linux.org Git - packages/ganeti-p2v-transfer.git/commitdiff
- new
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 1 Nov 2013 12:47:20 +0000 (13:47 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 1 Nov 2013 12:47:20 +0000 (13:47 +0100)
DESTDIR.patch [new file with mode: 0644]
ganeti-p2v-transfer.spec [new file with mode: 0644]

diff --git a/DESTDIR.patch b/DESTDIR.patch
new file mode 100644 (file)
index 0000000..b2b92c9
--- /dev/null
@@ -0,0 +1,23 @@
+--- ganeti-p2v-transfer-0.1/instance-p2v-target/Makefile.am~   2011-08-04 09:23:48.000000000 +0200
++++ ganeti-p2v-transfer-0.1/instance-p2v-target/Makefile.am    2013-11-01 13:23:26.474636488 +0100
+@@ -1,7 +1,7 @@
+ osname=p2v-target
+-osdir=$(DESTDIR)$(OS_DIR)/$(osname)
+-configdir=$(DESTDIR)$(sysconfdir)/ganeti/instance-$(osname)
++osdir=$(OS_DIR)/$(osname)
++configdir=$(sysconfdir)/ganeti/instance-$(osname)
+ variantsdir=$(configdir)/variants
+ hookdir=$(configdir)/hooks
+ fixesdir=$(configdir)/fixes
+@@ -58,8 +58,8 @@
+       $(do_subst) < $< > $@
+ install-exec-local:
+-      @mkdir_p@ $(variantsdir)
+-      touch $(variantsdir)/default.conf
++      @mkdir_p@ $(DESTDIR)$(variantsdir)
++      touch $(DESTDIR)$(variantsdir)/default.conf
+ install-exec-hook:
+       @echo
diff --git a/ganeti-p2v-transfer.spec b/ganeti-p2v-transfer.spec
new file mode 100644 (file)
index 0000000..5c15fc9
--- /dev/null
@@ -0,0 +1,96 @@
+Summary:       Tool for converting a physical computer into a Ganeti instance
+Name:          ganeti-p2v-transfer
+Version:       0.1
+Release:       0.1
+License:       GPL v2
+Group:         Applications/System
+Source0:       https://ganeti.googlecode.com/files/%{name}-%{version}.tar.gz
+# Source0-md5: c0333098304fa1868ffcaa82a942eba0
+Patch0:                DESTDIR.patch
+URL:           https://code.google.com/p/ganeti/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: docutils
+BuildRequires: rpmbuild(macros) >= 1.647
+Requires:      ganeti
+Requires:      mawk
+Requires:      tar
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This is a tool for converting a physical computer into a ganeti
+instance. It consists of two parts, a ganeti instance OS template that
+allows the instance to be booted to receive the files, and a script
+that is run on the source machine to make the transfer.
+
+A design document is available in doc/design.rst that describes the
+functioning of the system. This document will focus on getting the
+system up and running, and the process for actually performing
+physical-to-virtual transfers.
+
+%package source
+Summary:       Source system transfer script.
+Group:         Applications/System
+
+%description source
+This script is run from the transfer OS to establish an SSH connection
+with the bootstrap OS, mount the source filesystem(s), and copy
+the data over to the target. It will prompt the user for credentials
+as necessary to gain access to the bootstrap OS.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+%{__aclocal}
+%{__autoconf}
+%{__automake}
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install-source install-target \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} -r $RPM_BUILD_ROOT/%{_docdir}/%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc NEWS README* doc/design.* doc/instance-p2v-target.*
+%dir %{_sysconfdir}/ganeti/instance-p2v-target
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/p2v-target.conf
+%dir %{_sysconfdir}/ganeti/instance-p2v-target/fixes
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/10_fix_fstab
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/20_remove_persistent_rules
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/30_add_console_inittab
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/30_add_console_upstart
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/40_copy_hostname
+%dir %{_sysconfdir}/ganeti/instance-p2v-target/fixes/fixlib
+%{_sysconfdir}/ganeti/instance-p2v-target/fixes/fixlib/*.py*
+%dir %{_sysconfdir}/ganeti/instance-p2v-target/hooks
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/clear-root-password
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/install-fixes
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/interfaces
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/ramboot
+%attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/xen-hvc0
+%dir %{_sysconfdir}/ganeti/instance-p2v-target/variants
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/variants/default.conf
+%dir %{_datadir}/ganeti/os/p2v-target
+%{_datadir}/ganeti/os/p2v-target/common.sh
+%attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/create
+%attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/export
+%{_datadir}/ganeti/os/p2v-target/ganeti_api_version
+%attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/import
+%attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/rename
+%{_datadir}/ganeti/os/p2v-target/variants.list
+%attr(755,root,root) %{_sbindir}/make_ramboot_initrd.py
+
+%files source
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/p2v_transfer.py
This page took 0.106534 seconds and 4 git commands to generate.