]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
- typo (removed with some needless parts)
[packages/gammu.git] / gammu.spec
1 Summary:        Tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi do telefonów komórkowych
3 Name:           gammu
4 Version:        1.22.1
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  5d06f38d16043600a6b216db42197ea8
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake >= 2.4.6
15 BuildRequires:  curl-devel
16 BuildRequires:  gettext-devel
17 BuildRequires:  mysql-devel
18 BuildRequires:  postgresql-devel
19 BuildRequires:  rpmbuild(macros) >= 1.293
20 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
21 Provides:       mygnokii2
22 Obsoletes:      mygnokii2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Gammu (formerly known as MyGnokii2) is cellular manager for various
27 mobile phones and modems. It currently supports Nokia 3210, 33xx,
28 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
29 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
30 WaveCom, IPAQ, and other). It has a command line version with many
31 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
32 calls, etc. It can also make full backups and restore them.
33
34 %description -l pl.UTF-8
35 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
36 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
37 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
38 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
39 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
40 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
41 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
42 kopie zapasowe danych i odtwarzać je.
43
44 %package libs
45 Summary:        Gammu library
46 Summary(pl.UTF-8):      Biblioteka Gammu
47 Group:          Libraries
48
49 %description libs
50 Gammu tool suite library.
51
52 %description libs -l pl.UTF-8
53 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
54
55 %package devel
56 Summary:        Header files for Gammu tool suite for mobile phones
57 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
58 Group:          Development/Libraries
59 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
60 Requires:       bluez-libs-devel
61
62 %description devel
63 Header files for Gammu tool suite for mobile phones.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
67
68 %package static
69 Summary:        Gammu static library
70 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
73
74 %description static
75 Gammu static library.
76
77 %description static -l pl.UTF-8
78 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 mkdir -p build
86 cd build
87 %cmake .. \
88         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
89         -DCMAKE_VERBOSE_MAKEFILE=ON \
90         -DBUILD_SHARED_LIBS=OFF \
91         -DINSTALL_LIB_DIR=%{_lib} \
92         -DINSTALL_LIBDATA_DIR=%{_libdir} \
93         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
94 %{__make}
95 mv common/libGammu.a ..
96 %cmake .. \
97         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
98         -DCMAKE_VERBOSE_MAKEFILE=ON \
99         -DBUILD_SHARED_LIBS=ON \
100         -DINSTALL_LIB_DIR=%{_lib} \
101         -DINSTALL_LIBDATA_DIR=%{_libdir} \
102         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
108
109 %{__make} -C build install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
113 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
114 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
115 %find_lang %{name}
116
117 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
118
119 # for rpm autodeps
120 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   libs -p /sbin/ldconfig
126 %postun libs -p /sbin/ldconfig
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
131 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
132 %attr(755,root,root) %{_bindir}/%{name}
133 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
134 %{_examplesdir}/%{name}-%{version}
135 %{_mandir}/man1/*
136
137 %files libs
138 %defattr(755,root,root,755)
139 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libGammu.so.5
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/%{name}-config
145 %attr(755,root,root) %{_libdir}/libGammu.so
146 %{_includedir}/*
147 %{_pkgconfigdir}/gammu.pc
148
149 %files static
150 %defattr(755,root,root,755)
151 %{_libdir}/libGammu.a
This page took 0.063451 seconds and 4 git commands to generate.